ipp printer isn't shown automatically - adding it errors with a CUPS internal error

Bug #1815307 reported by fargoth on 2019-02-09
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Medium
Unassigned

Bug Description

System: Ubuntu 18.04
system-config-printer version: 1.5.11-1ubuntu
printer: Canon iP7250

I expect to be able to see the printer in the panel just as 'lpstat -l -e' or 'driverless' can see them, without the need to especially add a new printer.

And if I do need to add it (don't see why that should be the case, but still), I expect that choosing the printer's name under network would result in adding the printer.

What happened instead:

Canon iP7250 isn't shown in the Printers panel, clicking on add and expanding the network options - it is shown, but when trying to add it (either driverless IPP, LPD via DNS-SD or IPP via DNS-SD) it gives an error about CUPS internal error.

`$ lpstat -l -e` gives
`Canon_iP7200_series network none ipp://Canon%20iP7200%20series._ipp._tcp.local/`

So the system does see it, and `lp -d Canon_iP7200_series /etc/nsswitch.conf` does print (and for a minute the printer is shown in the Printers panel - but then disappears).

I can add it by *not* clicking on the printer's name under Network, but rather, click on ipp printer and manually choose Canon -> iP7200 -> CUPS+Gutenprint driver (and not the recommended driverless option - which, if I choose results in that same cryptic error I get when trying to add the printer by clicking on it, as described above).

fargoth (cantfind) on 2019-02-09
description: updated
Till Kamppeter (till-kamppeter) wrote :

Probably your printer suffers the problem shown in the following upstream bug report on cups-filters:

https://github.com/OpenPrinting/cups-filters/issues/22

It is currently worked on this, especially also here

https://github.com/OpenPrinting/cups-filters/pull/86

and here

https://github.com/apple/cups/issues/5484

Please run the following command:

driverless

This will output the URI of your printer. Does it do so? Then run the following command:

ipptool -tv URI get-printer-attributes.test > ipp-attrs.txt

Replace URI by your printer's URI which you obtained with the first command. Please attach the resulting ipp-attrs.txt file to this bug. Thanks.

Changed in system-config-printer (Ubuntu):
status: New → Incomplete
Till Kamppeter (till-kamppeter) wrote :

The issues referenced in the previous comment are all fixed upstream now. If they were the cause for your problem, your problem will be solved in Disco.

fargoth (cantfind) wrote :

Added the requested result of the ipptool query

Changed in system-config-printer (Ubuntu):
status: Incomplete → New
fargoth (cantfind) wrote :

Also added the ipptool results of the modified test given in https://github.com/OpenPrinting/cups-filters/issues/22

Seems to me that it is a similar issue.

Till Kamppeter (till-kamppeter) wrote :

A similar report got also to CUPS upstream:

https://github.com/apple/cups/issues/5512

and it seems that there is either a firmware bug in the AirPrint-supporting Canon printers or some problem with the client-side IPP implementation (which is in libcups, part of CUPS).

Michael Sweet, author of CUPS, will get a Canon printer on the coming Wednesday for further investigation.

Moving this bug to CUPS, system-config-printer has nothing to do with it.

affects: system-config-printer (Ubuntu) → cups (Ubuntu)
Changed in cups (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
fargoth (cantfind) wrote :

@till-kamppeter

> The issues referenced in the previous comment are all fixed upstream now. If they were the cause for > your problem, your problem will be solved in Disco.

I've just tested this using Disco, and it's even worse there - see my bug report: https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1816191

Till Kamppeter (till-kamppeter) wrote :

@fargoth, sorry for that comment. I was wrong. What got actually fixed was another thing which I observed during the investigations for this bug.

Therefore I have re-opened

https://github.com/OpenPrinting/cups-filters/issues/22

Please see my comments #5 and #6.

Till Kamppeter (till-kamppeter) wrote :

Michael Sweet was not able to reproduce this bug with the Canon printer he got at Apple. See

https://github.com/apple/cups/issues/5512

Please post in this bug report to directly interact with Michael.

Before doing so, get a setup of Disco (upcoming Ubuntu 19.04) and check whether your problem still exists. Disco contains all the fixes mentioned in the upstream bug reports.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.