courier-authdaemon not enabled by default to start

Bug #1599601 reported by JR on 2016-07-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
courier-authlib (Ubuntu)
High
Unassigned

Bug Description

The service authdaemond is not started by default at startup.
I had to use the following command so the service was started at startup :
$> sudo systemctl enable courier-authdaemon.service

Then the courier-imap with no particular authentification (ie through authdaemon) method was able to work perfectly!

To give more details, the error encountered was that I wasn't able to use the imap over ssl (although it worked perfectly up to 15.10 with nothing special to do)
In /var/log/syslog, the logged lines that appeared each time my mail client was trying to access to the local imap server were:
imapd-ssl: authdaemon: s_connect() failed: No such file or directory
imapd-ssl: LOGIN FAILED, user=JR, ip=[::ffff:192.168.1.254]
imapd-ssl: authentication error: No such file or directory

The release is:
Description: Ubuntu 16.04 LTS
Release: 16.04

courier-authdaemon:
  Installé : 0.66.4-3build1
  Candidat : 0.66.4-3build1
 Table de version :
 *** 0.66.4-3build1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status

I expected that the service was started automatically at startup.
What happened instead was it was not enabled, leading to this mess on my kubuntu installation.

So if the package's maintainer could check whether on a usual install( maybe this happened only on my computer) this service was enabled by default, that could help other people.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-28.47-generic 4.4.13
Uname: Linux 4.4.0-28-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Jul 4 20:19:02 2016
InstallationDate: Installed on 2016-05-25 (40 days ago)
InstallationMedia: Kubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcEnviron:
 LANGUAGE=
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)

JR (jrzspam) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Changed in xorg (Ubuntu):
importance: Undecided → High
Timo Aaltonen (tjaalton) wrote :

what on earth does this have to do with xorg?

JR (jrzspam) wrote :

Deeply sorry for the wrong assignment. Anyway the description reported the actual package.
Regards

affects: xorg (Ubuntu) → courier-authlib (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers