[Edgy] gnome-settings-daemon acting up

Bug #59217 reported by Toby Smithe on 2006-09-06
54
Affects Status Importance Assigned to Milestone
control-center (Ubuntu)
High
Ubuntu Desktop Bugs
gstreamer0.10 (Ubuntu)
High
Ubuntu Desktop Bugs
Edgy
Undecided
Unassigned

Bug Description

Sometimes it starts, others it doesn't. Here is the output on the terminal of one time it didn't:

toby@leopard:~$ gnome-settings-daemon &
[1] 6430
toby@leopard:~$
(gnome-settings-daemon:6430): GLib-GObject-WARNING **: gsignal.c:2269: signal name `new-toplevel_window' is invalid for instance `0x80a3c90'

(gnome-settings-daemon:6430): GLib-GObject-WARNING **: gsignal.c:2269: signal name `new-toplevel_window' is invalid for instance `0x80a3c90'

(gnome-settings-daemon:6430): GLib-GObject-WARNING **: gsignal.c:2269: signal name `new-toplevel_window' is invalid for instance `0x80a3c90'

(gnome-settings-daemon:6430): GLib-GObject-WARNING **: gsignal.c:2269: signal name `new-toplevel_window' is invalid for instance `0x80a3c90'

(gnome-settings-daemon:6430): GLib-GObject-WARNING **: gsignal.c:2269: signal name `new-toplevel_window' is invalid for instance `0x80a3c90'

(gnome-settings-daemon:6430): GLib-GObject-WARNING **: gsignal.c:2269: signal name `new-toplevel_window' is invalid for instance `0x80a3c90'
#&'([1157562290,000,xklavier.c:xkl_engine_start_listen/] The backend does not require manual layout management - but it is provided by the applicationCould not initialized GStreamer: unknown error occurred

Jos Dehaes (jos-dehaes) wrote :

I have the same problem. I often need to start the daemon manually. Sometimes it works, sometimes it doesn't.

Jos Dehaes (jos-dehaes) wrote :

More info in #60477.

Mitchell Lewandowski (iamski) wrote :

I can confirm this as well from an installation of Edgy Knot-3. The only way that I can seem to get it to restart however, is to reboot.

Sebastian Breier (tomcat42) wrote :

I can confirm that.

I just installed a fresh edgy knot-3. When logging in for the first time, everything is good. When I log out and log in again, I get this message:

"There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The last error message was:

Process /usr/lib/control-center/gnome-settings-daemon exited with status 1

GNOME will still try to restart the Settings Daemon next time you log in."

See screenshot.

I can reproduce it always... whenever I log in for the second time without rebooting, I have no settings daemon. Please tell me how to further debug this (don't really know what to attach strace to).

Sebastian Breier (tomcat42) wrote :

Confirmed from several people.

Changed in control-center:
status: Unconfirmed → Confirmed
Matt Zimmerman (mdz) wrote :

I just saw this on a fresh install of the 20060920 daily

Changed in control-center:
importance: Untriaged → High
Sebastien Bacher (seb128) wrote :

Do people having the issue have it only after returning to gdm and login with the same user again? Do you have processus from that user still running when you are to gdm?

Matt Zimmerman (mdz) wrote :

In my case, it happened on a fresh boot of the live CD, so definitely no processes running from a previous login.

Christoffer Karvonen (xopher) wrote :

I also have this. Running

strace -f gnome-settings-daemon

seems to work though..

This happens well, randomly, when logging in to my other account it works fine. (almost every time). And once when I ran gnome-keyboard-properties, it fixed it.
Running edgy amd64

Sebastian Breier (tomcat42) wrote :

I only have it on re-logging in. However, I just tried and it only happened on the third login (= the second re-log in). Weird...

The only thing I noticed when logging out is that the dbus-daemon and the gnome-vfs-daemon don't get stopped, and another pair of these is started whenever I log in... it's probably another bug, because when I killed them prior to logging in, the gnome-settings-daemon bug still popped up.

Gustaf (opera) wrote :

Yes, when logout-login on the same user. Solution: reboot. Tried to stop gdm, rm -rf /tmp/*, kill all of 'my' processes, and start gdm. Nope.

gnome-settings-daemon has been like this back and forth for years. This means, the real bug is never solved. I dream of the day its main developer actually fixes this once and for all.

jbj (jbj-ubu) wrote :

I am having the same exact issue described, I did manage to see gnome-settings-daemon mess up when started by hand a few times, and each time it outputted the following message before its death:

$ gnome-settings-daemon
a3g3[1159659073,000,xklavier.c:xkl_engine_start_listen/] The backend does not require manual layout management - but it is provided by the applicationCould not initialize GStreamer: unknown error occurred

And that's the only output for me, much like the original post. It may or may not start randomly. I haven't seen it fail running under strace

mithras (jsluiman) wrote :

I have the same problem, but that is not the point.

Is there *any* workaround? This is really annoying, especially when I'm installing things like the new Nvidia beta driver and beryl, so I have to restart X all the time. Every time there is the notice the daemon couldn't be launched and (re)starting it doesn't help...

ruffneckc (ruffneckc) wrote :

As mentioned by xopher in a post above - adding

strace -f gnome-settings-daemon

to your gnome sessions - startup programs is a workaround ATM.

Wenzhuo Zhang (wenzhuo) wrote :

I can confirm the problem in 6.10 beta. The symptoms are exactly the same as described in comment #4 <https://launchpad.net/distros/ubuntu/+source/control-center/+bug/59217/comments/4>

When I was looking for this bug in lauchpad I stumbled over very similar bug-descriptions (which are possibly duplicates):
Please see bug 56890 and bug 57154.

Lee.Tambiah (flossgeek) wrote :

On booting with the Live install disk on an IBM ThinkPAd R50e this bug is produced. After logging in the GDM I am presented with a dialogue which displays the following:-

"There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The last error message was:

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply. The reply timeout expired, or the network connection was broken.

GNOME will still try to restart the Settings Daemon next time you log in."

I installed edgy despite the error above and it seems fine at logging in from a fresh boot. However if I log out back to the GDM and Log back in I am given the following error:-

" There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The last error message was:

Process /usr/lib/control-center/gnome-settings-daemon exited with status 1.

GNOME will still try to restart the Settings Daemon next time you log in."

----------------------------------------------------------------------------------------------------

If I produce the bug and the open a terminal and run:-

$ gnome-settings-daemon

I gain my theme back with the following output in terminal:

xrdb: "*Label.background" on line 243 overrides entry on line 170
xrdb: "*Text.background" on line 249 overrides entry on line 211
xrdb: "*Label.foreground" on line 255 overrides entry on line 171
xrdb: "*Text.foreground" on line 261 overrides entry on line 212

However as soon as I close terminal or use the "Ctrl" + C my theme then returns back to the abnormal state.

zerkkk (thomas-mcgowan) wrote :

I have exactly the same problem on Edgy. I went from Dapper to Edgy.
The troubles came after a dist-upgrade. Before that I had Edgy runing ok.

When I reboot or restart X server, the problem comes back.

When I load gnome-settings-daemon manually then it's allright even if i change session (without restarting X).

Petri Järvisalo (reaby) wrote :

Daemon stopped working after i installed compiz-gnome + compiz-base from software channels.

Sebastien Bacher (seb128) wrote :

the g-s-d call to gst_init() seems to fail sometime and that create the issue

Changed in gstreamer0.10:
importance: Undecided → High
status: Unconfirmed → Confirmed
Changed in control-center:
assignee: nobody → desktop-bugs
Sebastien Bacher (seb128) wrote :

the issue seems to be due to g-s-t, one duplicate has a comment where the user states that gst-inpect crash for him and that chmoding the gstlibvisual plugin fixes the issue

ruffneckc (ruffneckc) wrote :

Found this on the Ubuntu Forums:

Had the same problem and permanently got rid of it
by adding the following $HOME/.Xsession file:

------------------------------------------
#!/bin/sh
exec gnome-session
------------------------------------------

That solved the problem, but don't ask me why...

Sebastien Bacher (seb128) wrote :

I'm working on a patched package for that and will probably upload tomorrow

Changed in gstreamer0.10:
assignee: nobody → desktop-bugs
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

This upload should fix the issue:

" gstreamer0.10 (0.10.10-1ubuntu2) edgy; urgency=low
 .
   * debian/patches/01_fix_gst_init_race_issue.patch:
     - backport patch from CVS to fix gst_init() race issue (GNOME: #355499),
       fix gnome-settings-daemon randomly refusing to start (Ubuntu: #59217)"

Could people comment to say if they still have the issue or not after upgrading to the new version?

Changed in gstreamer0.10:
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

not a control-center issue, gst_init() should always work

Changed in control-center:
status: Confirmed → Rejected
Erik Meitner (e.meitner) wrote :

Yes, the gstreamer0.10 update seems to have resolved the problem on my test system.

jsage (jsage) wrote :

Sebastien,

Thanks for your hard work nailing this down. I've installed the update and the problem so far has not recurred. I've restarted several times with and without Beryl, using CTL-ALT-BACKSPACE or full system restart and have not seen the problem.

thanks again,
john

After installing the gstreamer update I can chmod libgstlibvisual.so
back to 644 and gst-inspect / gnome-settings-daemon no longer crash
on my (slow) PPC machine. Thanks.

ruffneckc (ruffneckc) wrote :

Got the update and no longer having the problems. Thanks very much.

Sebastien Bacher (seb128) wrote :

thank you for the comments, I think it can be considered as fixed ;)

Sebastian Breier (tomcat42) wrote :

Yeah, pretty much fixed. :D
Thanks Sebastien.

i still have this problem on current edgy. the gstreamer patch is applied.

Sebastien Bacher (seb128) wrote :

Le vendredi 24 novembre 2006 à 09:05 +0000, Bernhard Valenti a écrit :
> i still have this problem on current edgy. the gstreamer patch is
> applied.

that might be a different bug, you should probably open a new bug for it

Sebastien Bacher (seb128) wrote :

no need of an edgy task, the bug has been fixed before edgy

Changed in gstreamer0.10:
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers