Ubuntu

There is no way to control which sound device or mixer the keyboard shortcuts use

Reported by C. Cooke on 2005-09-30
126
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Medium
control-center (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

The keyboard shortcuts control (gnome-keybinding-properties) has keys for volume
up, volume down and mute. It is these keys which hardware buttons on laptops and
multimedia keyboards are assigned. However, there is no way to control which
mixer device the keys control. On my laptop, they control the PCM-2 mixer, which
has absolutely no effect on the output volume.

http://bugzilla.gnome.org/show_bug.cgi?id=173035: http://bugzilla.gnome.org/show_bug.cgi?id=173035

Sebastien Bacher (seb128) wrote :

Thanks for your bug. That's known upstream as
http://bugzilla.gnome.org/show_bug.cgi?id=173035

Sebastien Bacher (seb128) wrote :

*** Bug 26052 has been marked as a duplicate of this bug. ***

Changed in control-center:
status: Unconfirmed → Confirmed

I'm having the same problem too. When I'm not using headphones, my sound card uses the 'Master' to control the volume, but when I'm using headphones the volume control goes to 'Headphone'. The problem is that The keyboard shortcuts of my laptop are configurable only to deal with the 'Master' volume trigger.

I'm using the latest Dapper release (as for 31/05/06), my laptop is a Dell D600 and the sound card is a Intel 82801DB-ICH4.

Changed in control-center:
status: Unconfirmed → Confirmed
Pavel Rojtberg (rojtberg) wrote :

can we have this patch applied as a hotfix?
http://bugzilla.gnome.org/attachment.cgi?id=59061&action=view

Sebastien Bacher (seb128) wrote :

We will consider that patch for edgy

Changed in control-center:
assignee: seb128 → desktop-bugs
Jan Mynarik (jan-mynarik) wrote :

So, is there any chance it will be fixed in edgy?

Sebastien Bacher (seb128) wrote :

Not likely, it doesn't look like anybody is working on that at the moment

Pavel Rojtberg (rojtberg) wrote :

and what about the patch?

Sebastien Bacher (seb128) wrote :

The patches modifies the alsa mixer control code and we build with gstreamer, the code modified is not used. Dropping the milestone since the patch doesn't workaround the bug

Changed in control-center:
importance: Medium → Wishlist
Jan Mynarik (jan-mynarik) wrote :

Maybe there is a possible solution, mostly workaround but needs some code to be written.

Situation: keyboard shortcuts control 'main' mixer, volume applet controls both 'main' and 'PCM' together; to really change volume while using headphones, you need to change 'PCM'.

Possible solution: keyboard shortcuts will remain changing only 'main' but volume applet could see the change of volume (it already does because it changes itself visually) and update 'PCM' (the other applet-controlled mixer) accordingly.

What do you think?

Hi,

Jan Mynarik <email address hidden> wrote:
Situation: keyboard shortcuts control 'main' mixer, volume applet
controls both 'main' and 'PCM' together; to really change volume while
using headphones, you need to change 'PCM'.
This would work in situations where the headphones are driven off thesame soundcard as the main audio but it wouldn't solve the problem I have with my USB Headset.

I have a Logitech Premium USB Headset 350 which plugs into a USB port and appears as a soundcard in its own right. Changing the main mixer PCM and Master would only change the volume of the built-in sound device on the computer (which I use for the ringing on my VOIP app) and not the master channel on the "Logitech USB Headset" mixer which controls the volume of the headphones. The headset has switches built into the cord which tell the computer to change the headset volume or mute its mic.

From my point of view, the perfect solution would be one that spotted that the buttons were on the same USB device as one of my soundcards then steered the button data towards the correct mixer or that let me define a binding between devices and mixers manually. I believe it's possible to use uDev to make sure the same USB network card always gets the same interface name regardless of which port it's connected to or the order it's plugged in. Could something similar be done here?

Thanks,
Paul.

---------------------------------
Everyone is raving about the all-new Yahoo! Mail beta.

Changed in control-center:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

Fixed with that upload:

 control-center (1:2.17.5-0ubuntu1) feisty; urgency=low
 .
   * New upstream version:
     about-me:
     - Fix displaying of image selected by the user (Ubuntu: #47170)
     background:
     - Mark message showing background image size and type for translation
     - Switched from popt to GOptionContext
     - Fix memory leaks
     - Fix crash when changing image name
     - Fix ability to change settings after manual change
     - Improve management of background thumbnails
     - Fix compilation on Solaris
     common:
     - Fix leaks
     - Add support for disabling esound
     fonts:
     - Make 'Font may be too large' dialog cleare
     keybindings:
     - Reuse the existing tree model instead of discarding and rebuilding it
     - Fix leaks
     keyboard:
     - Switch from popt to GOptionContext
     - Fix typo
     mouse:
     - Switch from popt to GOptionContext
     network:
     - Add option to use the same proxy for all protocols
     - Add missing mnemonic
     sound:
     - Mark sound system names translatable
     - Do proper dbus/libhal error handling
     - Switch from popt to GOptionContext
     - Make ESD optional
     - Add accelerators to the device tab
     - Spelling fixes
     - Use GtkAlignment for padding, not GtkHBox+GtkFrame
     - Make volume up/down keys affect default channel of the applet
     theme-switcher:
     - Fix crash on manually changing the icon theme name
     - Fix some HIG issues with strings
     - Fix leaks
     - Set minimun size request on the treeview rather than the entire window
     - Fix build with c89 compilers
     - Avoid markup in translatable messages
     - Enable a message when the current theme does not support colour schemes
     - Add custom colour scheme saving UI
     - Add MIME type for theme packages and support in the GUI
     windows:
     - Avoid markup in translatable messages
     shell:
     - Fix build with c89 compilers
     - Use categories for control center applets
     settings daemon:
     - Add DBus methods for media players to grab/release the keys (Ubuntu: #40747)
     - Add support for GConf device and track selection
     fontilus:
     - Add support for specifying string and font-size to use in the thumbnailer
     themus:
     - Fix crash when running from command prompt
   * debian/patches/13_unlink_out_of_date_thumbs.patch:
     - dropped, the new version has fixes for the thumbnailing
   * debian/patches/17_menu-changes.patch:
     - dropped, deprecated by the new control-center shell and the menus change
   * debian/patches/22_bkg_capplet_follow_symlink.patch:
     - dropped, the new version has fixes for the thumbnailing
   * debian/patches/35_fix_menu_to_use_for_the_shell.patch:
     - updated for now, will change again with the next gnome-menus version

Changed in control-center:
status: Confirmed → Fix Released
Jan Mynarik (jan-mynarik) wrote :

It works! Thanks. Confirmed with 1:2.17.5-0ubuntu3.

Sebastien Bacher (seb128) wrote :

no problem, thank you for confirming that it works fine

randomwalker (randomwalker) wrote :

copying my comment from bug 63544

This pref should be in only one place globally. Volume control applet already has it ("select the device and track to control"). The same setting should be respected instead of adding another pref.

Mark Grandi (markgrandi) wrote :

this does not work for me.

i am using fiesty, which uses control-center 1.2.18.1-0ubuntu2 and this still does not work

the up/down volume buttons on my keyboard control the IEC958 Center/LFE channel, but the sound that i actually hear is "Analog Front"

there is no option in the volume control applet or anywhere to change which channel the keyboard volume buttons control.

Polygon a écrit :
> this does not work for me.
>

Same thing for me.

Guido Conaldi (guido-conaldi) wrote :

Since the last updates I'm experiencing a similar issue on my dell xps m1330 (Intel HDA audio with a Sigmetal STAC9228 codec): the multimedia volume keys control the surround channel, which has no effect. It used to control the Front channel.

paumarc (paumarc) wrote :

I'm having the same problem with a hp dv 5000 series, i can't control volumen

thanks

Changed in gnome-control-center:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.