[System settings] Can't set user-supplied ring tone

Bug #1268097 reported by Daniel Holbach
228
This bug affects 43 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Fix Released
Wishlist
Bill Filler
content-hub (Ubuntu)
Triaged
Wishlist
Unassigned
ubuntu-system-settings (Ubuntu)
Fix Released
Wishlist
Ken VanDine

Bug Description

AFAICS I can't set a custom ring tone without using a writable image. (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)

<https://wiki.ubuntu.com/Sound#Custom_ringtone>: "In the “Ringtone” screen, immediately before “None” should be a “Custom Ringtone…” item..."

Tags: avengers bq

Related branches

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that doesn't make much sense, the setting is an user one and written in the user directory.

What image are you using? Whazt do you do exactly? What error do you get?

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Iain Lane (laney) wrote : Re: [Bug 1268097] Re: Can't set custom ring tone

On Mon, Jan 13, 2014 at 09:26:57AM -0000, Sebastien Bacher wrote:
> Thank you for your bug report, that doesn't make much sense, the setting
> is an user one and written in the user directory.
>
> What image are you using? Whazt do you do exactly? What error do you
> get?

I think that custom ringtones means allowing the user to supply their
own. It'd be nice to support this indeed, by defining a well known
directory to put them in and then listing those.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

summary: - Can't set custom ring tone
+ Can't set user-supplied ring tone
Revision history for this message
Sebastien Bacher (seb128) wrote : Re: Can't set user-supplied ring tone

(That bug has nothing to do with the image being readonly, you can copy a ringtone in your user directory and set the gsettings key to that location)

> It'd be nice to support this indeed, by defining a well known directory to put them in and then listing those.

I don't think that's the right approch/what is asked there (the users probably don't really want to have to adb to the device to sudo cp file to add a ringtone). The way to add a custom soundfile should be the same as for the custom background image, through content-hub.

We need a file picker to be added to content-hub first, then we need a design on what the UI would look like on the settings side.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Hey Matthew, I guess the feature request makes sense, could you have a look to the UI/design side of it?

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Low → Wishlist
status: Incomplete → Triaged
Revision history for this message
Sebastien Bacher (seb128) wrote :

Hey Ken, do you know if there is a file picker on the content-hub roadmap for this cycle?

Changed in content-hub (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Revision history for this message
Daniel Holbach (dholbach) wrote :

Séb: unfortunately this does not work with an RO image:

root@ubuntu-phablet:/# gsettings set com.ubuntu.touch.sound incoming-call-sound home/phablet/Music/bla.mp3

(process:2141): dconf-CRITICAL **: unable to create directory '/root/.cache/dconf': Read-only file system. dconf will not work properly.

(process:2141): dconf-CRITICAL **: unable to create directory '/root/.cache/dconf': Read-only file system. dconf will not work properly.

(process:2141): dconf-CRITICAL **: unable to create directory '/root/.cache/dconf': Read-only file system. dconf will not work properly.

(process:2141): dconf-WARNING **: failed to commit changes to dconf: Error spawning command line 'dbus-launch --autolaunch=b80c9e37e4d22c5146a60050386d6c97 --binary-syntax --close-stderr': Child process exited with code 1
root@ubuntu-phablet:/#

Revision history for this message
Sebastien Bacher (seb128) wrote :

> Séb: unfortunately this does not work with an RO image:

you shouldn't run that command as root but with your own user...

Changed in ubuntu-system-settings (Ubuntu):
status: Triaged → Confirmed
Revision history for this message
Bogdan (boghison) wrote :

Hey guys. I've tried GSettings both as root and as phablet, doesn't work, but I didn't get any errors either.

Revision history for this message
Cris Dywan (kalikiana) wrote :

Doesn't work here either.

Changed in ubuntu-ux:
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → Wishlist
summary: - Can't set user-supplied ring tone
+ [System settings] Can't set user-supplied ring tone
Changed in ubuntu-ux:
status: New → Triaged
tags: added: bq
Revision history for this message
Rex Tsai (chihchun) wrote :

It only need the ubuntu-system-settings to look into user's folder.

I wonder would it be suitable to just looks into ${XDG_MUSIC_DIR} or we like to have ${XDG_MUSIC_DIR}/ringtone or ${XDG_MUSIC_DIR}/notification

XDG_MUSIC_DIR="/home/phablet/Music"

Revision history for this message
John McAleely (john.mcaleely) wrote :

@pat, can you triage this for c-d-s-i?

Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → Wishlist
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww17-2015
Revision history for this message
Sebastien Bacher (seb128) wrote :

@Rex, no, it's not that simple, that should probably use content-hub to import content

Revision history for this message
Rex Tsai (chihchun) wrote :

It sounds like ubuntu-system-settings should not scan the folders for ringtone, but get media files from content-hub.

An extra request - please also consider to provide an API for developers to set ringtone (and wallpaper[1]). Personalization seems like one of the major features the user expect to have. :-)

[1] http://blog.csdn.net/u013151336/article/details/45154095 (use case a Chinese user like to set their own wallpaper)

Revision history for this message
EricDHH (ericdhh) wrote :

Ubuntu 14.10 (r21) on bq aquaris

This image have 2015-04-20 as date, bug still exists on.

Changed in canonical-devices-system-image:
milestone: ww17-2015 → ww21-2015
Revision history for this message
pragomer (pragomer) wrote :

I have a brand-new BQ Ubuntu Phone. Same issue. Cannot choose a custom ringtone.

Revision history for this message
Martin Wildam (mwildam) wrote :

Iam also on the bq aquaris and I tried downloading an mp3 ringtone with uDropCabin hoping it offers me to open the file with an application that can set it as ringtone. Usually when playing music on Android, i* etc devices you have always an option to set current music as a ringtone.

I even tried via contacts to choose a ringtone but it seems there is even no chance to set a separate ringtone for different people.

Essential features missing here in my opinion.

Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

In backlog?

Changed in canonical-devices-system-image:
milestone: ww21-2015 → none
Revision history for this message
Alexander Kinne (alexanderkinne) wrote :

How about for the time being simply defining a directory in Userland that the ringtones can be dropped into while a solution using the content hub is being worked on? This seemed to be an option in the past with changing the gsettings to pick up that directory.

Revision history for this message
Csernátoni Csaba (csaba-csernatoni) wrote : Re: [Bug 1268097] Re: [System settings] Can't set user-supplied ring tone

Where/how do I do that?

Alexander Kinne <email address hidden> ezt írta (2015. szeptember
16., szerda):
> How about for the time being simply defining a directory in Userland
> that the ringtones can be dropped into while a solution using the
> content hub is being worked on? This seemed to be an option in the past
> with changing the gsettings to pick up that directory.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1496111).
> https://bugs.launchpad.net/bugs/1268097
>
> Title:
> [System settings] Can't set user-supplied ring tone
>
> Status in Canonical System Image:
> Confirmed
> Status in Ubuntu UX:
> Triaged
> Status in content-hub package in Ubuntu:
> Triaged
> Status in ubuntu-system-settings package in Ubuntu:
> Confirmed
>
> Bug description:
> AFAICS I can't set a custom ring tone without using a writable image.
> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions
>

Revision history for this message
Alexander Kinne (alexanderkinne) wrote :

Hi there,

I don't know how... I am not a developer, just a user like you. I was
annoyed seeing the bug still not being worked on today and just wanted
to bump it for the developers. ;-)

As I understand it it used to be possible to edit gesettings and define
a directory there for your ringtones. But that does not work any more -
instead the bug mentions that it should be fixed with the content hub.
But nothing is happening so i simply proposed to give US a directory
again.

Cheers,
Alex

On Mi, Sep 16, 2015 at 5:43 , Csernátoni Csaba
<email address hidden> wrote:
> Where/how do I do that?
>
>
> Alexander Kinne <email address hidden> ezt írta (2015.
> szeptember
> 16., szerda):
>> How about for the time being simply defining a directory in Userland
>> that the ringtones can be dropped into while a solution using the
>> content hub is being worked on? This seemed to be an option in the
>> past
>> with changing the gsettings to pick up that directory.
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (1496111).
>> https://bugs.launchpad.net/bugs/1268097
>>
>> Title:
>> [System settings] Can't set user-supplied ring tone
>>
>> Status in Canonical System Image:
>> Confirmed
>> Status in Ubuntu UX:
>> Triaged
>> Status in content-hub package in Ubuntu:
>> Triaged
>> Status in ubuntu-system-settings package in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> AFAICS I can't set a custom ring tone without using a writable
>> image.
>> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>>
>> To manage notifications about this bug go to:
>>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions
>
>
> --
> You received this bug notification because you are subscribed to the
> bug
> report.
> https://bugs.launchpad.net/bugs/1268097
>
> Title:
> [System settings] Can't set user-supplied ring tone
>
> Status in Canonical System Image:
> Confirmed
> Status in Ubuntu UX:
> Triaged
> Status in content-hub package in Ubuntu:
> Triaged
> Status in ubuntu-system-settings package in Ubuntu:
> Confirmed
>
> Bug description:
> AFAICS I can't set a custom ring tone without using a writable
> image.
> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions

Revision history for this message
Csernátoni Csaba (csaba-csernatoni) wrote :
Download full text (3.4 KiB)

Oh, I see :)
All right, thank you for the support :)

Alexander Kinne <email address hidden> ezt írta (2015. szeptember
16., szerda):
> Hi there,
>
> I don't know how... I am not a developer, just a user like you. I was
> annoyed seeing the bug still not being worked on today and just wanted
> to bump it for the developers. ;-)
>
> As I understand it it used to be possible to edit gesettings and define
> a directory there for your ringtones. But that does not work any more -
> instead the bug mentions that it should be fixed with the content hub.
> But nothing is happening so i simply proposed to give US a directory
> again.
>
> Cheers,
> Alex
>
> On Mi, Sep 16, 2015 at 5:43 , Csernátoni Csaba
> <email address hidden> wrote:
>> Where/how do I do that?
>>
>>
>> Alexander Kinne <email address hidden> ezt írta (2015.
>> szeptember
>> 16., szerda):
>>> How about for the time being simply defining a directory in Userland
>>> that the ringtones can be dropped into while a solution using the
>>> content hub is being worked on? This seemed to be an option in the
>>> past
>>> with changing the gsettings to pick up that directory.
>>>
>>> --
>>> You received this bug notification because you are subscribed to a
>>> duplicate bug report (1496111).
>>> https://bugs.launchpad.net/bugs/1268097
>>>
>>> Title:
>>> [System settings] Can't set user-supplied ring tone
>>>
>>> Status in Canonical System Image:
>>> Confirmed
>>> Status in Ubuntu UX:
>>> Triaged
>>> Status in content-hub package in Ubuntu:
>>> Triaged
>>> Status in ubuntu-system-settings package in Ubuntu:
>>> Confirmed
>>>
>>> Bug description:
>>> AFAICS I can't set a custom ring tone without using a writable
>>> image.
>>> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>>>
>>> To manage notifications about this bug go to:
>>>
>>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions
>>
>>
>> --
>> You received this bug notification because you are subscribed to the
>> bug
>> report.
>> https://bugs.launchpad.net/bugs/1268097
>>
>> Title:
>> [System settings] Can't set user-supplied ring tone
>>
>> Status in Canonical System Image:
>> Confirmed
>> Status in Ubuntu UX:
>> Triaged
>> Status in content-hub package in Ubuntu:
>> Triaged
>> Status in ubuntu-system-settings package in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> AFAICS I can't set a custom ring tone without using a writable
>> image.
>> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>>
>> To manage notifications about this bug go to:
>>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1496111).
> https://bugs.launchpad.net/bugs/1268097
>
> Title:
> [System settings] Can't set user-supplied ring tone
>
> Status in Canonical System Image:
> Confirmed
> Status in Ubuntu UX:
> Triaged
> Status in content-hub package in Ubuntu:
> Triaged
> Status in ubuntu-system-settings package in Ubuntu:
> Confirmed
>
> Bug description:
> AFAICS I can't set a custom ring...

Read more...

Revision history for this message
Alexander Kinne (alexanderkinne) wrote :
Download full text (4.5 KiB)

On Wednesday, 16 September 2015, Csernátoni Csaba <
<email address hidden>> wrote:
> Oh, I see :)
> All right, thank you for the support :)
>
>
> Alexander Kinne <email address hidden> ezt írta (2015. szeptember
> 16., szerda):
>> Hi there,
>>
>> I don't know how... I am not a developer, just a user like you. I was
>> annoyed seeing the bug still not being worked on today and just wanted
>> to bump it for the developers. ;-)
>>
>> As I understand it it used to be possible to edit gesettings and define
>> a directory there for your ringtones. But that does not work any more -
>> instead the bug mentions that it should be fixed with the content hub.
>> But nothing is happening so i simply proposed to give US a directory
>> again.
>>
>> Cheers,
>> Alex
>>
>> On Mi, Sep 16, 2015 at 5:43 , Csernátoni Csaba
>> <email address hidden> wrote:
>>> Where/how do I do that?
>>>
>>>
>>> Alexander Kinne <email address hidden> ezt írta (2015.
>>> szeptember
>>> 16., szerda):
>>>> How about for the time being simply defining a directory in Userland
>>>> that the ringtones can be dropped into while a solution using the
>>>> content hub is being worked on? This seemed to be an option in the
>>>> past
>>>> with changing the gsettings to pick up that directory.
>>>>
>>>> --
>>>> You received this bug notification because you are subscribed to a
>>>> duplicate bug report (1496111).
>>>> https://bugs.launchpad.net/bugs/1268097
>>>>
>>>> Title:
>>>> [System settings] Can't set user-supplied ring tone
>>>>
>>>> Status in Canonical System Image:
>>>> Confirmed
>>>> Status in Ubuntu UX:
>>>> Triaged
>>>> Status in content-hub package in Ubuntu:
>>>> Triaged
>>>> Status in ubuntu-system-settings package in Ubuntu:
>>>> Confirmed
>>>>
>>>> Bug description:
>>>> AFAICS I can't set a custom ring tone without using a writable
>>>> image.
>>>> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>>>>
>>>> To manage notifications about this bug go to:
>>>>
>>>
>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions
>>>
>>>
>>> --
>>> You received this bug notification because you are subscribed to the
>>> bug
>>> report.
>>> https://bugs.launchpad.net/bugs/1268097
>>>
>>> Title:
>>> [System settings] Can't set user-supplied ring tone
>>>
>>> Status in Canonical System Image:
>>> Confirmed
>>> Status in Ubuntu UX:
>>> Triaged
>>> Status in content-hub package in Ubuntu:
>>> Triaged
>>> Status in ubuntu-system-settings package in Ubuntu:
>>> Confirmed
>>>
>>> Bug description:
>>> AFAICS I can't set a custom ring tone without using a writable
>>> image.
>>> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>>>
>>> To manage notifications about this bug go to:
>>>
>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions
>>
>> --
>> You received this bug notification because yo
u are subscribed to a
>> duplicate bug report (1496111).
>> https://bugs.launchpad.net/bugs/1268097
>>
>> Title:
>> [System settings] Can't set user-supplied ring tone
>>
>> Status in Canonical System Image:
>> Confirmed
>> Status in Ubuntu U...

Read more...

Revision history for this message
Csernátoni Csaba (csaba-csernatoni) wrote :
Download full text (5.5 KiB)

U2. And I have the same considerations.

Alexander Kinne <email address hidden> ezt írta (2015. szeptember
16., szerda):
> On Wednesday, 16 September 2015, Csernátoni Csaba <
> <email address hidden>> wrote:
>> Oh, I see :)
>> All right, thank you for the support :)
>>
>>
>> Alexander Kinne <email address hidden> ezt írta (2015. szeptember
>> 16., szerda):
>>> Hi there,
>>>
>>> I don't know how... I am not a developer, just a user like you. I was
>>> annoyed seeing the bug still not being worked on today and just wanted
>>> to bump it for the developers. ;-)
>>>
>>> As I understand it it used to be possible to edit gesettings and define
>>> a directory there for your ringtones. But that does not work any more -
>>> instead the bug mentions that it should be fixed with the content hub.
>>> But nothing is happening so i simply proposed to give US a directory
>>> again.
>>>
>>> Cheers,
>>> Alex
>>>
>>> On Mi, Sep 16, 2015 at 5:43 , Csernátoni Csaba
>>> <email address hidden> wrote:
>>>> Where/how do I do that?
>>>>
>>>>
>>>> Alexander Kinne <email address hidden> ezt írta (2015.
>>>> szeptember
>>>> 16., szerda):
>>>>> How about for the time being simply defining a directory in Userland
>>>>> that the ringtones can be dropped into while a solution using the
>>>>> content hub is being worked on? This seemed to be an option in the
>>>>> past
>>>>> with changing the gsettings to pick up that directory.
>>>>>
>>>>> --
>>>>> You received this bug notification because you are subscribed to a
>>>>> duplicate bug report (1496111).
>>>>> https://bugs.launchpad.net/bugs/1268097
>>>>>
>>>>> Title:
>>>>> [System settings] Can't set user-supplied ring tone
>>>>>
>>>>> Status in Canonical System Image:
>>>>> Confirmed
>>>>> Status in Ubuntu UX:
>>>>> Triaged
>>>>> Status in content-hub package in Ubuntu:
>>>>> Triaged
>>>>> Status in ubuntu-system-settings package in Ubuntu:
>>>>> Confirmed
>>>>>
>>>>> Bug description:
>>>>> AFAICS I can't set a custom ring tone without using a writable
>>>>> image.
>>>>> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>>>>>
>>>>> To manage notifications about this bug go to:
>>>>>
>>>>
>>
>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions
>>>>
>>>>
>>>> --
>>>> You received this bug notification because you are subscribed to the
>>>> bug
>>>> report.
>>>> https://bugs.launchpad.net/bugs/1268097
>>>>
>>>> Title:
>>>> [System settings] Can't set user-supplied ring tone
>>>>
>>>> Status in Canonical System Image:
>>>> Confirmed
>>>> Status in Ubuntu UX:
>>>> Triaged
>>>> Status in content-hub package in Ubuntu:
>>>> Triaged
>>>> Status in ubuntu-system-settings package in Ubuntu:
>>>> Confirmed
>>>>
>>>> Bug description:
>>>> AFAICS I can't set a custom ring tone without using a writable
>>>> image.
>>>> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>>>>
>>>> To manage notifications about this bug go to:
>>>>
>>
>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions
>>>
>>> --
>>> You received this bug notification because yo
> u are subscribed ...

Read more...

Revision history for this message
Bill Filler (bfiller) wrote :

Proposal is to do exactly what clock does to set custom alarm tones:

- In system settings, add a "Custom..." entry
- When press on it, show content-hub picker for sources that export music (music-app does export music now)
- select the song from source app
- use that song as the ringtone
- play the song from the beginning when needed as the ringtone

Changed in canonical-devices-system-image:
milestone: none → ww46-2015
Changed in ubuntu-system-settings (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → Ken VanDine (ken-vandine)
Revision history for this message
Sebastien Bacher (seb128) wrote :

Bill, some questions:
- how is the song supposed to be listed then?
- how many songs can you add? one at time?
- how can you delete it?

also be aware of bug #1413818 if you import songs in a custom directory some services are not going to be able to access those

Revision history for this message
Alexander Dobetsberger (masternoob) wrote :

Should the ability to set a custom sound for sms/mms or other notifications be it's own bug entry?

Revision history for this message
Andrew Hayzen (ahayzen) wrote :

@Sebastien, note that this is what Clock has done when you are selecting the alarm sound.

- They have a separate section for 'custom' audio.
- It appears you can add as many as you want.
- These custom items can then be swipe deleted.

Revision history for this message
vidda (hardouaibe) wrote :

Maybe we could change or add a path to new ringtones in an imported config file?

Bill Filler (bfiller)
Changed in canonical-devices-system-image:
milestone: ww46-2015 → ww02-2016
Revision history for this message
Karlheinz Salver (ksalver) wrote :

i solved temporarily this problem with "sudo mount -o remount,rw /" and copying my ringtones to "/usr/share/sounds/ubuntu/ringtones/" via "sudo cp myringtone.ogg ..."

he final solution, (i hope) will be the possibility to set individual ringtones in contacts. maybe in release 16.04.

Revision history for this message
Julia Palandri (julia-palandri) wrote :

Please take to account that by having done that you risk not being able to update your phone to the next OTA - you might want to undo it.

Revision history for this message
Csernátoni Csaba (csaba-csernatoni) wrote :

Why? How? That would be the ultimate bug, an update not updating the
system...

Julia Palandri <email address hidden> ezt írta (2015. november 3.,
kedd):
> Please take to account that by having done that you risk not being able
> to update your phone to the next OTA - you might want to undo it.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1496111).
> https://bugs.launchpad.net/bugs/1268097
>
> Title:
> [System settings] Can't set user-supplied ring tone
>
> Status in Canonical System Image:
> Confirmed
> Status in Ubuntu UX:
> Triaged
> Status in content-hub package in Ubuntu:
> Triaged
> Status in ubuntu-system-settings package in Ubuntu:
> Confirmed
>
> Bug description:
> AFAICS I can't set a custom ring tone without using a writable image.
> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions
>

Changed in ubuntu-ux:
importance: Wishlist → High
status: Triaged → In Progress
Revision history for this message
Matthew Paul Thomas (mpt) wrote :
Changed in ubuntu-ux:
status: In Progress → Fix Committed
description: updated
Revision history for this message
Harshavardhan Rajopadhye (harsh-physik) wrote :

There's no such option. No none button nor custom ringtone.

On my BQ Aquaris E5 phone, I went in following path:

System Settings -> Sound -> Ringtone.

However, there are only inbuilt ringtone options. No none/custom ringtone.

Regards,

Harsh
On Nov 9, 2015 3:40 PM, "Matthew Paul Thomas" <email address hidden> wrote:

> Specification updated.
> <https://wiki.ubuntu.com/Sound?action=diff&rev2=158&rev1=156>
>
> ** Changed in: ubuntu-ux
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1509961).
> https://bugs.launchpad.net/bugs/1268097
>
> Title:
> [System settings] Can't set user-supplied ring tone
>
> Status in Canonical System Image:
> Confirmed
> Status in Ubuntu UX:
> Fix Committed
> Status in content-hub package in Ubuntu:
> Triaged
> Status in ubuntu-system-settings package in Ubuntu:
> Confirmed
>
> Bug description:
> AFAICS I can't set a custom ring tone without using a writable image.
> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions
>

Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

You don't need to comment on this bug at this point as such, the lack of feature is understood and in progress.

The current status fields show that the design (Ubuntu UX) is complete but the new design is not implemented (in ubuntu-system-settings) nor released to users (Canonical System Image). Once all of those have been set to "Fix Released", users have the fix.

Bill Filler (bfiller)
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Revision history for this message
vidda (hardouaibe) wrote :

Well i think it's not bad at all to make changes "handly". Personally, i'm satisfied with "linux' way of use" and could expect to get something like that on an Ubuntu phone.
The command given by Karlheinz Salver (wrote on 2015-11-03) is a good way to do what we want easily. (works fine with .mp3 too)

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+16.04.20151123-0ubuntu1

---------------
ubuntu-system-settings (0.3+16.04.20151123-0ubuntu1) xenial; urgency=medium

  * Allow setting custom ringtone with content-hub (LP: #1268097)

 -- Ken VanDine <email address hidden> Mon, 23 Nov 2015 21:27:41 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Revision history for this message
Csernátoni Csaba (csaba-csernatoni) wrote :

HI,

So this option will appear after the next OTA update?

Regards,
Csaba

Jean-Baptiste Lallement <email address hidden> ezt írta
(2015. november 24., kedd):
> ** Changed in: canonical-devices-system-image
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1496111).
> https://bugs.launchpad.net/bugs/1268097
>
> Title:
> [System settings] Can't set user-supplied ring tone
>
> Status in Canonical System Image:
> Fix Committed
> Status in Ubuntu UX:
> Fix Committed
> Status in content-hub package in Ubuntu:
> Triaged
> Status in ubuntu-system-settings package in Ubuntu:
> Fix Released
>
> Bug description:
> AFAICS I can't set a custom ring tone without using a writable image.
> (http://askubuntu.com/questions/372759/ringtones-in-ubuntu-touch)
>
> <https://wiki.ubuntu.com/Sound#Custom_ringtone>: "In the “Ringtone”
> screen, immediately before “None” should be a “Custom Ringtone…”
> item..."
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1268097/+subscriptions
>

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Yes, it will be in OTA9.

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Revision history for this message
vidda (hardouaibe) wrote :

We had an upgrade last week and everything is ok now; on BQ Aquaris 4.5 i now have a link to choose phone-ring file.
Not the same for ringtones but... what ever...

no longer affects: ubuntu-ux
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers