console-kit-daemon[2951]: WARNING: Couldn't read /proc/2950/environ: Failed to open file '/proc/2950/environ': No such file or directory

Bug #367334 reported by Alexander Gieg on 2009-04-26
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
ConsoleKit
Fix Released
Unknown
consolekit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: consolekit

This line appears in my syslog. I don't know what its importance is:

console-kit-daemon[2951]: WARNING: Couldn't read /proc/2950/environ: Failed to open file '/proc/2950/environ': No such file or directory

The folder 2950 itself also doesn't exist. 2951 however does. Just a guess then: shouldn't it be trying to read /proc/2951/environ instead?

Ubuntu 9.04, consolekit 0.3.0-2ubuntu4 (jaunty proposed)

On Sun, 2009-04-26 at 13:39 +0000, Alexander Gieg wrote:
> Public bug reported:
>
> Binary package hint: consolekit
>
> This line appears in my syslog. I don't know what its importance is:
>
> console-kit-daemon[2951]: WARNING: Couldn't read /proc/2950/environ:
> Failed to open file '/proc/2950/environ': No such file or directory
>
> The folder 2950 itself also doesn't exist. 2951 however does. Just a
> guess then: shouldn't it be trying to read /proc/2951/environ instead?

Nope. /proc/ is a virtual file-system that has a directory per process,
so /proc/2950 and /proc/2951 give information about different processes.

My guess is that process 2950 is very short-lived, so consolekit
notices it, and then when it goes to find the information about the
process it has already exited, so the directory no longer exists.

If that is the case then it would make this bug "Invalid" I guess, but
it would be good to confirm that it is indeed the case.

Thanks,

James

Alexander Gieg (alexgieg) wrote :

Ah, I see. Good to know it probably isn't important. Thanks!

click170 (click170) wrote :

The nature of the problem is such that makes it rather hard to confirm.
I would propose that a check be performed instead of issuing that warning; Could console-kit-daemon not do an existence check before issuing that warning, and then only issue said warning if the directory does exist?
This would prevent any short-lived processes from generating those warnings in ckd, but would still generate warnings if for some reason the directory did exist but ckd could not read it.
In any event, its just an eye-sore seeing them in the logs knowing they don't need to be there. Short-lived processes, though rare, aren't something to be concerned about most of the time so it seems to me they shouldn't generate warnings.
Cheers,
Click.

Changed in consolekit:
status: Unknown → Confirmed
starslights (starslights) wrote :

hello,

I am on Kubuntu Karmic 4, 2.6.31-10-generic

console-kit-daemon[2490] WARNING: Couldn't read /proc/2488/environ: Failed to open file '/proc/2488/environ': No such file or directory

Changed in consolekit:
status: Confirmed → New
Juha Karonen (juha-karonen) wrote :

Hi,

Kubuntu 9.04

Oct 10 17:30:01 kubuntu console-kit-daemon[3321]: WARNING: Couldn't read /proc/3320/environ: Failed to open file '/proc/3320/environ': No such file or directory

Some (not all) of these lines are followed by:
Oct 10 17:30:01 kubuntu /USR/SBIN/CRON[3941]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)

At the same time some error results a non-responding UI (processes are ok, mouse moves but the UI is frozen)
I have Ati Radeon with "radeon" OS driver. This might have nothing to do with the error message, but timing is same.

Linux kubuntu 2.6.28-15-generic #52-Ubuntu SMP Wed Sep 9 10:48:52 UTC 2009 x86_64 GNU/Linux

tekstr1der (tekstr1der) on 2009-10-16
Changed in consolekit (Ubuntu):
status: New → Confirmed
hmatsue (hmatsue) wrote :

I saw similar phenomena with my system.
After logout from KDE, the screen is blacked out, and could not see gdm login screen, and could not login from virtual console neither.
The system was able to respond to ping from another machine.
It seems that re-creation of the phenomena is easier with linux-image-2.6.28-3-rt than with linux-image-2.6.28-15-generic .
I'm using nvidia Quadro4, not Radeon. The output of lspci is:
01:00.0 VGA compatible controller: nVidia Corporation NV17GL [Quadro4 550 XGL] (rev a3)
And somebody claim that he is suffering same problem with Intel Xserver in Japanese forums.
So I don't think it is caused by the Xserver.

I found some warning/error in my system's log file:

daemon.log:Oct 17 16:30:02 my-system console-kit-daemon[3150]: WARNING: Couldn't read /proc/3149/environ: Failed to open file '/proc/3149/environ': No such file or directory

syslog:Oct 17 16:30:40 my-system gdm[4045]: CRITICAL: gdm_config_value_get_bool: assertion `value->type == GDM_CONFIG_VALUE_BOOL' failed

Please give me some ideas to find out the cause of this problem.
Regrads.

Bill Owens (wrowens) wrote :

While this bug may be hard to confirm, I have numerous occurrences of this bug on an Acer Aspire 6930 laptop running Kubuntu 9.04. The interval between occurrences is apparently random, but may happen several times a day or, on some days, it never occurs (but I have never had more than one day of this fortuitous happening).

The result is either a general protection fault, or a non-responsive UI that requires a reboot or shutdown.

I also run 64-bit Vista on this machine and 32-bit Windows XP on VMWare and have never seen this problem with either of them.

Bill

Ariel Faigon (ariel.faigon) wrote :

Adding another observation:

Jan 17 01:02:23 ze console-kit-daemon[1001]: WARNING: Couldn't read
/proc/1000/environ: Failed to open file '/proc/1000/environ': No such file or
directory

As earlier reporters noticed, console-kit-daemon is PID=1001 and it tries to open /proc/1000/environ

Is this a real problem? I'm not sure, but konsole has other problems since the switch to KDE 4, notably its inability to remember window-geometries between sessions so I thought I should add my report to this bug.

Floyd B. (fbufkin) wrote :

I too, am having this error. Background, Karmic64 bit. I had Ubuntu installed and then installed the Kubuntu desktop, which I have since removed. Also I am unable to access a tty using the keyboard shortcut. I think this is related.

matangdilis (matangdilis) wrote :

I also have this warning but different number, from daemon.log

<snip ...>
Mar 29 07:55:39 kamote dhclient: bound to 192.168.1.2 -- renewal in 42241 seconds.
Mar 29 07:55:39 kamote acpid: client connected from 1115[0:0]

Mar 29 07:55:40 kamote console-kit-daemon[959]: WARNING: Couldn't read /proc/946 /environ: Failed to open file '/proc/946/environ': No such file or directory

Mar 29 07:55:40 kamote NetworkManager: <info> (eth0): device state change: 7 -> 8 (reason 0)
<snip ...>

matangdilis (matangdilis) wrote :

Oh, I'm using Ubuntu Karmic amd64 bit, and gnome desktop.

jhthayer (jhthayer) wrote :

KDE version of 9.10, 32-bit, on an AMD Athlon 64 3000+, Gigabyte GA K8NS-pro, nVidia FX5200 gpu. Started refusing to authenticate at KDM login about 1 month ago--no clue as to what triggered it. But the logs show the same message--console-kit-daemon[####] Warning: couldn't read /proc/###+#/environ: Failed to open file . . . . at the time when the authentication fails; no other evident errors, consistently, save for desktop app errors which appear to result from permission lack when the authentication fails. Have pored over all the related dbus, consolekit, and pam files and find nothing apparently out of order. Very unsettling to need to operate as root, which is the only way one may get into the system. Would appreciate info as to what is meant by the error in the syslog from pam-ck-connector (also at the same time) wherein it refers to nox11 mode . . . what does that mean? None of this makes any sense at all. A terrible letdown from Dapper and Hardy. And Lucid has more of this stuff??

jhthayer (jhthayer) wrote :

Just realised that I said the pam-ck-connector error was in the syslog. Actually, it was in the auth.log.

Changed in consolekit:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.