Ubuntu

shutdown and restart buttons do nothing

Reported by Pavol Klačanský on 2008-07-21
302
This bug affects 3 people
Affects Status Importance Assigned to Milestone
consolekit (Ubuntu)
High
Martin Pitt
Intrepid
High
Martin Pitt

Bug Description

When I shutdown computer (System->Shutdown->button Shutdown computer) then nothing happens.

Workarounds:
1) log off and restart/shutdown in gdm.
2) run "sudo reboot" or "sudo halt" in a terminal
3) configure your chassis power button to shutdown your PC.

Related branches

Benjamin Drung (bdrung) wrote :

I have a similar problem: When I try to reboot, GNOME logs out and GDM comes up. There I can reboot my machine.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in gdm.

don't specify the version you are using in the title, it's confusing and create extra work, you can use the description

Changed in gdm:
importance: Undecided → High
Daresch (fukla-msi) wrote :

I've the same problem with my Intrepid.

Peter Júnoš (petoju) wrote :

This bug can be seen in alpha version of each Ubuntu I have ever tested (=since 6.10). I don't know, whether someone tried to fix it, but if not, it could be one of the consequences of missing 3D acceleration or kernel, that isn't tuned up so well.

Peter Júnoš (petoju) wrote :

My 3D acceleration with non-free drivers is working now, but Shutdown still doesn't work as expected.

There will be different problem to solve.

Martin Pool (mbp) wrote :

Confirmed for me too in Intrepid.

I'm using the 'autologin' gdm setting. It also occurs with the 'timed login' setting. I'm not sure if it's reproducible without this set.

Steve Langasek (vorlon) on 2008-07-28
Changed in gnome-session:
milestone: none → intrepid-alpha-5
Peter Júnoš (petoju) wrote :

I use neither 'autologin' nor 'timed login' and this bug appears also on my desktop.

John Vivirito (gnomefreak) wrote :

gnome -session version is 2.23.5-0ubuntu2
gdm version 2.20.7-0ubuntu2
versions of packages are helpful in bugs the above sees this issue.

John Vivirito (gnomefreak) wrote :

This is the first time ive seen this issue so im not sure what problem peter is seeing in 6.10 but its EOS anyway

Sebastien Bacher (seb128) wrote :

the bug has been confirmed and is a known upstream gnome-session issue there is no need to add extra comments to say you have the issue too or specify the version you are using, all the intrepid users have this bug

Robertjm (robertjm) wrote :

If you click on Restart, the same issue happens.

I have to say, "Shutting down from the Login Screen" is even more fun than "Shutting down by pressing the start button"!

Sebastien Bacher (seb128) wrote :

turns out the issue is a consolekit one, debian disagree on the way upstream is handling those restart and stop actions apparently and decided to not ship the .policy to allow doing that, reassigning to policykit

Mehdi Abaakouk (sileht) wrote :

Debian have added this patch because it does not compile consolekit with PolicyKit and in this case anyone have the right to shutdown or reboot the system
   * debian/patches/01-dbus_policy.patch
     - Allow only root to call the Restart and Stop D-Bus methods since we are
       not using PolicyKit to restrict the access to those methods.

But ubuntu ship policykit and can build consolekit with policykit support

To fix the problem, we need to remove this patches and add a dependencie on policykit.

Intead, for the security problem pointed by debian, Upstream version have release a patch

Mehdi Abaakouk (sileht) wrote :

Modified packages

Mehdi Abaakouk (sileht) wrote :
Mehdi Abaakouk (sileht) wrote :

Patch attached

Changed in consolekit:
status: Confirmed → Fix Committed
Mehdi Abaakouk (sileht) on 2008-08-10
Changed in consolekit:
status: Fix Committed → Confirmed
Mehdi Abaakouk (sileht) wrote :

the ConsoleKit policy file for policykit miss in the packages too
Need to add "debian/tmp/usr/share/PolicyKit/policy/" in the debian/consolekit.install file

Daryl Lublink (dlublink) wrote :

Work around : set in power management that the power key is shutdown. So just hit the shutdown when you are done with the computer. Works great on laptops. (normally I set the shutdown key to hibernate ).

seldon7 (ubuntu-pengo) wrote :

This is a problem in my intrepid alpha 4 and 5 as well (first versions I have used since 8.04). Shutdown, reboot buttons do nothing. Never had this problem before.

Kai Arne (kaiarne5) wrote :

Same her. Shutdown, reboot buttons do nothing.

Similar problem, when I try to shutdown/reboot system from a menu, it does nothing, so I have to do it from the console.

reh4c (gene-hoffler) wrote :

"Similar problem, when I try to shutdown/reboot system from a menu, it does nothing, so I have to do it from the console."
-same problem here on my Core2Quad desktop with Intrepid x64 Alpha 4.

danbuter (buter1) wrote :

I am having the same problem with Ubuntu Intrepid Ibex. The KDE and XFCE Intrepid Ibex versions both shut down fine, though.

MustangSallydd (dougiesta-aol) wrote :

I also have seen this shut down bug in past release in the Alpha stages

Found this in my .xsession-errors:

** (gnome-session:6273): DEBUG: GsmManager: Shutdown called
** (gnome-session:6273): DEBUG: GsmManager: Logout dialog response: 2
** (gnome-session:6273): DEBUG: GsmManager: requesting shutdown

** (gnome-session:6273): WARNING **: Unable to stop system: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.ConsoleKit.Manager" member "Stop" error name "(unset)" destination "org.freedesktop.ConsoleKit")

Chris Coulson (chrisccoulson) wrote :

Christian - Please have a read through the discussion above. The developers are well aware of why this is happening.

Thanks

Andrea Caminiti (nrayever) wrote :

here too! i have to finish my session in order to restart or shut-down. and i don't know why the need to have 2 different menus one for ending the session and so and the other one to restart/shut-down! that is not practical! why not add one more icon on the previous shutdown menu? i believe this way is more painful!

is this a gnome idea or ubuntu one?? bad idea for my point of view! this are my 2 cents.

Well, hello everyone

I'm testing Intrepid in my wife Laptop, an IBM ThinkPad T40, with 8.10 in Spanish, this one, have the same BUG, don't want to power off or restart from the Desktop. I must to go to GDM closing the session, and then use the GDM's bottons.

Benjamin Drung (bdrung) on 2008-08-26
description: updated
dano (danoex) wrote :

I am having the same bug with Ubuntu Intrepid Ibex

Steve Langasek (vorlon) on 2008-08-29
Changed in consolekit:
assignee: nobody → pitti
James Westby (james-w) wrote :

Hi,

Trying to at least allow the user to shut down by changing
gnome-session to not try and use consolekit, either by simply
patching the code, or rebuilding without libpolkit-gnome,
doesn't work. I couldn't find any errors though.

It seems that the code either doesn't fall back to using gdm,
which it looks like it should, or it fails quietly trying to do so.

Thanks,

James

James Westby (james-w) wrote :

Hi,

I looked further tonight, the code works as it should, it just something
different to what I expected.

It requests that gdm restart when the user logs out, and then leaves
the session open after doing this. Simply using GDM in the current state
isn't really an option then, as this is pretty confusing.

It could be changed to close the session after communicating with gdm
say, but this isn't a viable long term solution, as there is no access
control on these requests done by gdm, so anyone is able to shut
down the machine, which isn't what we want.

Thanks,

James

Alex Mayorga (alex-mayorga) wrote :

I've found a workaround of sorts, I've added Fast User Switch Applet 2.22.0+svn20080815 that now provides a Shutdown option that works on Intrepid.

@James, maybe you might want to take a look into their code, or maybe they're not doing "what we want". BTW "what we want" is that not every user is allowed to shutdown the host or what?

On Sun, 2008-08-31 at 17:28 +0000, Alex Mayorga Adame wrote:
> @James, maybe you might want to take a look into their code, or maybe
> they're not doing "what we want". BTW "what we want" is that not every
> user is allowed to shutdown the host or what?

Yeah, it's not desirable to have any user be able to shutdown the
system.

I've just had a look at fast-user-switch-applet, thanks for the tip.
It also uses GDM, but at least has a simple authentication check
which should ensure that only local console users can shut down
the system. This would be better than the gnome-session way of
doing it, but still lacking I think.

The problem is that using something like policykit/consolekit
solves this quite nicely, but it's not really the right
place for the functionality, and leads to a circular build
dependency, which is a pain.

One solution could be to pull the code out of consolekit in
to a "ShutdownKit" package, and then patch all the other
packages to use its dbus path instead.

I'm not the person to decide all of this though, I was just
investigating the current state to see what our options were.

Thanks,

James

Matt Zimmerman (mdz) on 2008-09-01
Changed in consolekit:
status: Confirmed → Triaged

for those that dont yet know it, you can add a button to the applet top bar, that will mimic the old behaviour! but now we end up with two buttons to manage the session.

johnn1949 (johnn1949) wrote :

I had the applet on the bar and it behaved the same as the menu shutdown. Nothing

IanW (launchpad-washuu) wrote :

Having this problem on EeePC 701, using Aug 31 daily build, updated since.

Logoff only takes me to GDM login. shutdown from there leaves OS closed, but Eee powered up.
"sudo shutdown -P now" has exactly the same result. Black screen & power on.

My current workaround is to get it to this state & hold down the power button for 5+ seconds.

As things stand, I'd call this a "Showstopper"

Chris Coulson (chrisccoulson) wrote :

IanW - Your EeePC remaining powered up after you shut it down is completely separate to this issue and you should open a new bug report.

James Westby (james-w) wrote :

On Tue, 2008-09-02 at 08:10 +0000, IanW wrote:
> shutdown from there leaves OS closed, but Eee powered up.
> "sudo shutdown -P now" has exactly the same result. Black screen & power on.

Hi Ian,

That is a kernel problem I believe. I think it is a known problem
with the Eee, but I don't have a bug number to give you, sorry.

Thanks,

James

On Tuesday 02 September 2008 09:10:23 IanW wrote:
> My current workaround is to get it to this state & hold down the power button for 5+ seconds.

Doesnt "sudo halt" work for you, either? doing hard power downs may damage your PC, and corrupt files.

--
BUGabundo :o)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net
Linux user #443786 GPG key 1024D/A1784EBB
My new micro-blog @ http://BUGabundo.net

Recently the Suspend and Hibernate options disappeared from options.
Did the patch got removed?

--
BUGabundo :o)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net
Linux user #443786 GPG key 1024D/A1784EBB
My new micro-blog @ http://BUGabundo.net

Hi everyone,

I did a tail -f /var/log/syslog

then try to reboot the machine from System > Shutdown pressing the Reboot button , this like other times do nothing, but the tail say:

p 2 11:40:33 stardust x-session-manager[5962]: DEBUG(+): GsmManager: Shutdown called
Sep 2 11:40:36 stardust x-session-manager[5962]: DEBUG(+): GsmManager: Logout dialog response: 3
Sep 2 11:40:36 stardust x-session-manager[5962]: DEBUG(+): GsmManager: requesting reboot

IanW (launchpad-washuu) wrote :

Chris & James - Thanks. I'll log a new bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package consolekit - 0.2.10-1ubuntu4

---------------
consolekit (0.2.10-1ubuntu4) intrepid; urgency=low

  * Enable PolicyKit controlled shutdown/reboot functionality (LP: #250506):
    - Disable 01-dbus_policy.patch.
    - Add libpolkit-dev build dependency.
    - debian/consolekit.install: Install .policy file.

 -- Martin Pitt <email address hidden> Wed, 03 Sep 2008 15:44:43 +0200

Changed in consolekit:
status: Triaged → Fix Released
Daryl Lublink (dlublink) wrote :

I tested on my machine and it seems to work fine. (Only restart was tested ).

IanW (launchpad-washuu) wrote :

It turns out that the failure to switch off that I experienced was related to the need (on the EeePC 701) to add "rmmod snd-hda-intel" to /etc/halt.

Mehdi Abaakouk (sileht) wrote :

Is the loop dependency problem with policykit resolved ?
policykit doesn't depend any more on consolekit ?

Mehdi Abaakouk [2008-09-05 16:52 -0000]:
> Is the loop dependency problem with policykit resolved ?
> policykit doesn't depend any more on consolekit ?

No, it's the upstream solution for now with the mutual dependency. I
wanted to have at least something working instead of leaving it broken
forever until we get a better solution. But since essentially all the
other distros except Debian (which isn't using CK at all yet) gave up
discussion with upstream and swallowed this hack, we are on our own
and need to find some serious time to work on this.

Harvey Muller (hlmuller) wrote :

Hope I'm not adding noise.

Testing the Ubuntu 8.10 amd64 Alpha 6 livecd, indicates that the problem remains at least in the LiveCDs. I was unable to either reboot or shutdown from the System menu. Was able to shutdown using the terminal:

    $ sudo shutdown -h now

Dave Morley (davmor2) wrote :

this is fixed in latter daily images

Jan-Philipp Litza (jplitza) wrote :

I am running an installed version of intrepid, and the problems didn't go away for me either. consolekit is version 0.2.10-1ubuntu5, but still the buttons do nothing. Do I have to change anything in the GNOME configuration or something?

Martin Pitt (pitti) wrote :

Jan-Philipp Litza [2008-09-30 8:01 -0000]:
> Do I have to change anything in the GNOME configuration or
> something?

No, it should "just work". Do you have a consolekit session? We have a
couple of reports of consolekit-daemon crashing. Can you please give
us the output of

  ck-list-sessions

(from a Terminal)?

$ ck-list-sessions
Session7:
 uid = '1000'
 realname = '(``-_-´´),,,,'
 seat = 'Seat1'
 session-type = ''
 active = TRUE
 x11-display = ':0'
 x11-display-device = '/dev/tty7'
 display-device = ''
 remote-host-name = ''
 is-local = TRUE
 on-since = '2008-09-30T17:17:06.321133Z'

but i came from a dupe, with a different symptom.

Jan-Philipp Litza (jplitza) wrote :

Hm, I just tried to shut down and it worked flawlessly. (it rarely does, usually something hangs in the init scripts)
The important part: The menu item worked as well. Don't know why it did now and didn't some other times, but I will try to observe that further and post a session list here when it goes wrong again. I am sure it didn't work after the fix was posted here sometimes.

kulight (kulight) wrote :

im using ubuntu 8.10 fully updated and the problem still there

Martin Pitt (pitti) wrote :

kulight, does "ck-list-sessions" have a session for you, or is it empty?

Harvey Muller (hlmuller) wrote :

Appears to be resolved as of the Intrepid Beta release and later. (personally using amd64 desktop)

kulight (kulight) wrote :

martin,
ck-list-session have a session
the problem with the button is fixed for now
but still got this one: https://bugs.launchpad.net/ubuntu/+bug/274508

Aswarp (aswarp2002) wrote :

I have this problem in Ubuntu Lucid Lynx 10.04 on KDE.
It is a fresh install with some added packages and non-free drivers for an Nvidia card.
When clicking shutdown on the K menu, nothing happens. I must resort to console and shutdown there or push the CPU poweroff button.
And as well, the system wont boot ramdomly, which I have recently reported. I mean, it freezes at the KUbuntu logo screen, before the login screen.
Veeeery bad impression of this new "stable" and "solid" release.

Pavel Kukacka (pavel-kukacka) wrote :

I see the same issue as Aswarp reported (the "shutdown problem"), only in GNOME, both 32bit and 64bit. When clicking shutdown (or restart) in "System->Shutdown" nothing happens.
Even without any proprietary drivers. And it seems it happens randomly - sometimes it works and the next day not and the other day it works again. Strange. Weird.

I still experience this bug. I'm using kubuntu lucid lynx 10.04 amd64, fresh install, fully updated, ati open drivers. When I select "Restart" or "Shudown" from the "Leave" menu nothing happens (the notification dialog doesn't appear). I've tried a lot of different things, without success.

Hew McLachlan (hew) wrote :

Please open a new bug for your issue as it's likely different to what was originally reported and fixed, thanks.

To post a comment you must log in.