Please add: Kurdish keyboard configuration "kualt-latin"

Bug #28683 reported by Erdal Ronahi on 2006-01-16
16
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
High
Colin Watson

Bug Description

There is no Kurdish keyboard configuration (ku) available yet, though it is needed for the debian-installer.

We have created a configuration named "kualt-latin" following the example of Turkish-Alt.

Kurdish Debian and Ubuntu users would be happy to see it included.

Kurdish Alt-Q Keyboard Map based on the Turkish Alt-Q keymap.

Matt Zimmerman (mdz) on 2006-04-03
Changed in console-data:
assignee: nobody → tfheen
Erdal Ronahi (erdalronahi) wrote :

You can close this one, the Kurdish Keyboard configurations have been added.

Tollef Fog Heen (tfheen) wrote :

No, we can't. There's no Kurdish keyboard layout for the console yet.

O, I am sorry. I mixed it up with the Xkeyboard. There are three XKB
configurations now for Kurdish.

2006/6/2, Tollef Fog Heen <email address hidden>:
>
> No, we can't. There's no Kurdish keyboard layout for the console yet.
>
> --
> Please add: Kurdish keyboard configuration "kualt-latin"
> https://launchpad.net/bugs/28683
>

Erdal Ronahi skrev:
> O, I am sorry. I mixed it up with the Xkeyboard. There are three XKB
> configurations now for Kurdish.

I know, it was I who added them.

- tfheen

towsonu2003 (towsonu2003) wrote :

should this be closed (fix released) or confirmed, or "in progress"? I'm confused :)

Erdal Ronahi (erdalronahi) wrote :

There is still no option for a Kurdish keyboard for the installer in Edgy Beta. Also, in the console there is Turkish being used instead. So this cannot be closed.

However for X there are several Kurdish keyboards available now. I have heard that the console now also uses the keyboard definitions of X, so a fix should be relatively easy.

towsonu2003 (towsonu2003) wrote :

> There is still no option for a Kurdish keyboard for the installer in Edgy Beta.

I'll go with confirmed then :)

Changed in console-data:
status: Unconfirmed → Confirmed
Tollef Fog Heen (tfheen) wrote :

Unassigning me. Note that we now use console-setup which gets the data from X's keyboard maps, so Kurdish keyboards should be supported in Feisty.

Changed in console-data:
assignee: tfheen → nobody
Daniel Hahler (blueyed) wrote :

Erdal, can you please check this with Gutsy?

Changed in console-data:
assignee: nobody → erdalronahi
Erdal Ronahi (erdalronahi) wrote :

I checked it in an up-to-date installation in Virtualbox. I can confirm that the Kurdish keyboards are selectable when doing a "sudo dpkg-reconfigure console-setup".

However, the result is not satisfying. After a reboot the letters ê, î and û are usable with "Turkey - Kurdish Alt-Q", but the letter "ş", the always-making-trouble-letter, is not. Instead two diamonds and a "^" appear on the screen. Also, some keys are no longer usable, for instance ";" and '.

I also did not yet test whether the keyboards are selectable in Ubiquity or the Alternate-CD installer.

Erdal Ronahi (erdalronahi) wrote :

Actually the keys work partially in nano, at the console itself they don't. Especially everything with RightAlt / AltGr does not work. Furthermore, the keys to the right of l, that is (;) and (') do not work at all, no matter whether I use Turkey - Kurdish Q or Turkish - Kurdish Alt-Q, which have very different characters on that keys.

Erdal Ronahi (erdalronahi) wrote :

This still does not work in Hardy Alpha 3.

When the Kurdish locale is selected, the Turkish Q keyboard is installed on the console and in the X Server environment, rendering the console almost unusable. I encountered this after a install of Hardy Alpha 3 with the alternate CD.

The reason is that the letter "i" cannot by typed at all. So commands like "exit" or "dpkg-reconfigure" cannot be typed. The correct keyboard to install for Kurdish would be tr_kualt

towsonu2003 (towsonu2003) wrote :

rendering the console almost unusable is pretty serious afaik. also, why is this bug assigned to mr ronahi while, looking at his last post, it seems like he is not the one who will resolve the bug...

Changed in console-data:
importance: Medium → High
milestone: ubuntu-6.06 → ubuntu-8.04-beta
Erdal Ronahi (erdalronahi) wrote :

Reassigned to Tollef, since he is most likely to understand the problem and to solve it

Changed in console-data:
assignee: erdalronahi → tfheen
Colin Watson (cjwatson) wrote :

Tollef hasn't done console work for some time. Furthermore, this bug was lost due to being incorrectly assigned to console-data rather than console-setup, which we have been using since Edgy.

Erdal, could you please restate (a) which keyboard layout and variant should be used for Kurdish; (b) what problems remain when selecting that layout and variant?

Changed in console-data:
assignee: tfheen → nobody
Colin Watson (cjwatson) wrote :

Specifically, should it be tr(ku) or tr(ku_alt)? In bug 197612 you say the former, but in comment 13 on this bug you say the latter.

Erdal Ronahi (erdalronahi) wrote :

tr(ku) should be the standard for both console and desktop environment.

I mentioned tr(ku_alt) for the console, because
1. that is closer to the English keyboard I expect console users to be more familiar with
2. the specific Kurdish characters can be only displayed on UTF-8 consoles anyway and there were multiple problems with that in the past

At the moment (Gutsy) there is no problem after selecting tr(ku), neither on the console nor in a desktop environment.

Colin Watson (cjwatson) wrote :

OK, I'll make it be tr(ku) then. Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.21ubuntu4

---------------
console-setup (1.21ubuntu4) hardy; urgency=low

  * Set default layout for Kurdish to tr(ku) (LP: #28683).

 -- Colin Watson <email address hidden> Mon, 03 Mar 2008 13:46:06 +0000

Changed in console-setup:
status: Confirmed → Fix Released
Colin Watson (cjwatson) on 2008-03-12
Changed in console-setup:
assignee: nobody → kamion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers