Lack of terminals in ubuntu 8.10

Bug #281720 reported by elli222 on 2008-10-11
6
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Undecided
Unassigned

Bug Description

In Ubuntu 8.04 i had about three terminals i could use, excluding the one X runs on. These showed me a login prompt. In Ubuntu 8.10 there is no login prompt, but just a blinking underscore ( _ ) X itself runs fine.

<removed>

NOTE: this happened when i did an upgrade from hardy to intrepid, cd install of intrepid is fine...

Dimitrios Symeonidis (azimout) wrote :

i don't understand your description. are you talking about the terminals you get through ctrl+alt+f1/2/3 etc? are you talking about terminal emulators inside your gnome session? or about something else?

elli222 (elliot-purdy) wrote :

Not terminal emulators, the ctrl+alt+F(n) where n is a number
I literally see a blinking underscore, nothing else...

elli222 (elliot-purdy) wrote :

hmm, i can log in, but i cant see any output, i can hear beeps when i press backspace after i log in, and if i type exit then it spits me back to my xserver...

Dimitrios Symeonidis (azimout) wrote :

so you're not seeing the tty1-6 terminals...
that's strange, and I don't know where to start...

Dimitrios Symeonidis (azimout) wrote :

possibly related source package: console-setup
possibly duplicate bug:
https://bugs.launchpad.net/ubuntu/+bug/271911

elliot, can you please try running "dpkg --configure -a"
also, just to clarify: if you open a terminal inside gnome, everything works fine, am i correct?

this might be a resolution issue...

Dimitrios Symeonidis (azimout) wrote :

elliot, can you tell us also which is your graphics card, and what driver you're using with it?

elli222 (elliot-purdy) wrote :

I recently found out that it is a duplicate bug, this happened in gutsy.

The terminals work fine, the display however, dosent.

adding these modules fixed my problem

vga16fb
fbcon

(add them to your /etc/modules file, at the bottom

I am using a Nvidia 6600 GTX, that is soon to be a dual 280 setup :D

Dimitrios Symeonidis (azimout) wrote :

elliot, which is the other bug you found?

elli222 (elliot-purdy) wrote :

it is a duplicate of this bug:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/129910

Their fix fixed it!

description: updated
Taupter (taupter) wrote :

No, it's not.
In bug 129910, Loye Young wrote on 2008-01-10 that that bug is about Gutsy and Gutsy only, Saïvann Carignan wrote on 2008-04-03: Fix released, This bug is fixed and similar issues should be posted as different bugs.

129910 was for 7.10, not for 8.10, and even then, the 7.10 fix wasn't applied to that distro's version afaict. And even if it was somebody should have the decency to reopen bug 129910, as saying this bug is a duplicate of the other "closed" bug that affected an yesteryear distro doesn't do much to fix the problem that's happening _now_. But it seems this "class" of problem is appearing recurrently. Maybe some Ubuntu devs devised that getting framebuffer consoles should be a good "rite of passage", based on the constant ressurgence of this "feature that needs a hack to work like everyone else's distro". Dev's response to bug 129910 was so bad (lack of priority, bug being marked as invalid)

2007-08-02 - Miguel Martinez reported the bug.
2007-09-09 - John Yates explains how to fix this bug. Various people confirm Yate's fix works.
2007-12-07 - Henrik Nilsen Omma said it wouldn't be fixed until 8.04.
2007-12-13 - Leann Ogasawara marked the bug as invalid.
2007-12-13 - Jonas Bygdén asked why they ignored us for so much time just to close the bug with such inane excuse,
2007-12-13 - Felix Miata said that everybody else's distro under the sun doesn't have this problem.
2007-12-13 - Miguel Martinez tried to convince us that bug was in fact a feature.
2008-01-10 - Loye Young said that this bug is about Gutsy and Gutsy only.
2008-01-11 - Andrea Corbellini said it was not critical.
2008-02-25 - Ben Collins closed the bug because "the report is so convoluted", infuriating some.
2008-03-11 - Colin Watson said the reason we don't use vesafb by default is that it breaks suspend/resume.
2008-03-11 - Launchpad Janitor informed This bug was fixed in the package initramfs-tools - 0.85eubuntu29 - after SEVEN MONTHS and nine days.
2008-03-12 - Launchpad Janitor adds another fix.
2008-03-17 - Felix Miata says the problem returns. Argh.
2008-04-03 - Saïvann Carignan said fix released, This bug is fixed and similar issues should be posted as different bugs.

So, please put 129910 to rest. There's an enormous DNR stick on it. 281720 is not a duplicate. And pretty please someone fix 281720 before Intrepid is released. And don't let the this bug lag as 129910 did, thank you very much.

elli222 (elliot-purdy) on 2008-10-22
description: updated

I'm not sure what is gained by arguing about version and bug numbering, but
since I've been quoted, I'll take the bait and dive in.

I did NOT say that the bug was Gutsy "only". I did say that it WAS a bug in
Gutsy, and continues to be a bug, in response to someone unilaterally
setting the bug to WILL NOT FIX. It's been a regression on every version
since Gutsy, and it still should be fixed.

The "fix" in Hardy was a crude hack that has made my job more difficult, but
at least we can get a framebuffer working outside X.

Amazingly, Intrepid breaks the console once again, albeit in a different
way. In fairness, Intrepid's new uvesafb / v86d approach has the potential
to _actually_ fix the console someday, but our in-house testing shows it to
be beta quality at this time. (I'm not sold on the conceptual model of v86d,
but I've still got an open mind.)

Happy Trails,

Loye Young
Isaac & Young Computer Company
Laredo, Texas
http://www.iycc.net

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers