Ubuntu

computer-janitor-gtk crashed with SystemError in open()

Reported by Marcel Buchholz on 2010-03-23
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
computer-janitor (Ubuntu)
Medium
Barry Warsaw

Bug Description

Binary package hint: computer-janitor

Computer Janitor crashes when instantly trying to start it.

ProblemType: Crash
Architecture: i386
Date: Tue Mar 23 19:22:58 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/share/computerjanitor/computer-janitor-gtk
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: wl
Package: computer-janitor-gtk 1.14.1-0ubuntu2
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/computer-janitor-gtk
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
PythonArgs: ['/usr/sbin/computer-janitor-gtk']
SourcePackage: computer-janitor
Title: computer-janitor-gtk crashed with SystemError in open()
Uname: Linux 2.6.32-16-generic i686
UserGroups:

tags: removed: need-duplicate-check
Barry Warsaw (barry) wrote :

This looks like a problem with your system. Something in your apt database got corrupted. Here's an ubuntuforums thread that might help you solve the problem.

http://ubuntuforums.org/showthread.php?t=863742

Changed in computer-janitor (Ubuntu):
status: New → Invalid
Barry Warsaw (barry) on 2010-05-19
visibility: private → public
Changed in computer-janitor (Ubuntu):
status: Invalid → Confirmed
importance: Undecided → Medium
assignee: nobody → Barry Warsaw (barry)
milestone: none → maverick-alpha-1
Barry Warsaw (barry) on 2010-05-20
Changed in computer-janitor (Ubuntu):
status: Confirmed → In Progress
Barry Warsaw (barry) on 2010-05-21
Changed in computer-janitor (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package computer-janitor - 2.0.1-0ubuntu1

---------------
computer-janitor (2.0.1-0ubuntu1) maverick; urgency=low

  * Bumping for Ubuntu.

computer-janitor (2.0.1~ppa1) lucid; urgency=low

  * Display dialog in gtk version when another package manager is running,
    preventing package plugin post-cleanup from completing. (LP: #545306)

computer-janitor (2.0~ppa0) lucid; urgency=low

  * Since CJ 2.0 won't make it into Lucid, do Maverick updates now.
    (LP: #552777)
    - Give computer-janitor-gtk --help and --version command line args.
    - Revert translatable strings to post-Lucid improvements
    - Make string substitutions more consistent
    - Update po

computer-janitor (2.0-0ubuntu5) lucid; urgency=low

  * Move some FIXME comments around for less gettext confusion.

computer-janitor (2.0-0ubuntu4) lucid; urgency=low

  * FFe review resolution (LP: #541990)
    - Reverted some strings back to Karmic versions to satisfy FFe for C-J
      2.0 in Lucid. Strings marked with FIXME for updating in Lucid+1.
    - Catch DBusExceptions in both cli and gtk front-ends and print a
      better error message.

computer-janitor (2.0-0ubuntu3) lucid; urgency=low

  * Some cleanup indicated by visual inspection.
    - Move more exception classes to the error.py module.
    - Update docstring.
    - Do not translate logged error messages (can make log analysis
      scripts more difficult).
    - Update copyright years in About dialog.

computer-janitor (2.0-0ubuntu2) lucid; urgency=low

  * Disable the Do... button when there is no cruft to clean up.

computer-janitor (2.0-0ubuntu1) lucid; urgency=low

  * Refactor all package change operations into a dbus service.
    - Switch to using python-argparse
    - Extend functionality of cli version
    - Change format for state.dat ini file
 -- Barry Warsaw <email address hidden> Fri, 21 May 2010 16:55:46 -0400

Changed in computer-janitor (Ubuntu):
status: Fix Committed → Fix Released
Christopher (soft-kristal) wrote :

Seems to be back in 12.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers