ccsm crashed with KeyError in compizconfig.Plugin.ApplyStringExtensions (src/compizconfig.c:6780)(): '\xd0\t\x9b\n\x01'

Bug #832458 reported by abdullah on 2011-08-24
This bug affects 313 people
Affects Status Importance Assigned to Milestone
Compiz Configuration Library - Python Bindings
Fix Released
Medium
Sam Spilsbury
Unity
Fix Released
Medium
Sam Spilsbury
compizconfig-python (Ubuntu)
Medium
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned

Bug Description

ubuntu11.10 alpha 3
kernel 3.0.9

window border disappeared suddenly and when i try to rest it from ccsm to back again the bug came out just like that

TESTCASE:

Open CCSM
It wont crash

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: compizconfig-settings-manager 0.9.5.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Wed Aug 24 04:25:08 2011
ExecutablePath: /usr/bin/ccsm
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/ccsm
PythonArgs: ['/usr/bin/ccsm']
SourcePackage: compizconfig-settings-manager
Title: ccsm crashed with KeyError in compizconfig.Plugin.ApplyStringExtensions (src/compizconfig.c:6780)(): '\xd0\t\x9b\n\x01'
UpgradeStatus: Upgraded to oneiric on 2011-08-19 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

abdullah (sk--y) wrote :
tags: removed: need-duplicate-check
Changed in compizconfig-settings-manager (Ubuntu):
status: New → Confirmed
Julian Taylor (jtaylor) on 2011-08-24
visibility: private → public
tags: added: bugpattern-needed
Ian Corne (icorne) wrote :

What is bugpattern needed?

dino99 (9d9) wrote :

bug # 836499 have the apport-retrace details

dino99 (9d9) wrote :

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ccm/Utils.py", line 253, in ParseSettings
    plugin.Update ()
  File "compizconfig.pyx", line 783, in compizconfig.Plugin.Update (src/compizconfig.c:5765)
  File "compizconfig.pyx", line 870, in compizconfig.Plugin.ApplyStringExtensions (src/compizconfig.c:6780)
KeyError: 'hN;\t\x01'

florin (florin-arjocu) wrote :

For me this bug apeared after I've just installed the kernel updates for Oneiric. Almost everithing worked ok before the last kernel update, now Unity bar is back to not responding to any CCSM settings I've made.

Hi,

What is the number of the Kernel please ?

Le 31/08/2011 01:50, florin a écrit :
> For me this bug apeared after I've just installed the kernel updates for
> Oneiric. Almost everithing worked ok before the last kernel update, now
> Unity bar is back to not responding to any CCSM settings I've made.
>

tags: removed: bugpattern-needed
Matt 6:27 (goffice) wrote :

I've the same issue as florin (#5) - tried to modify size of icons in launcher via ccsm settings and no changes are taking effect. I've got Kernel 3.0.0-9-generic.

gackthugo (gackthugo) wrote :

Happened to me when changing the opacity of the panel, wobbly windows, auto-hide launcher... Ubuntu 11.10 beta1

florin (florin-arjocu) wrote :

It's true, Oneiric beta 1 has the bug. It's strange as at some point (don't remember exactly when in the last week or this week) this bug were repaired, but the next dist-upgrade brought the bugs back.

D (tenswiths) wrote :

I'm using Oneiric Beta 1, and just had this bug occur. There are no obvious symptoms I can see, other than apport reporting it. Some updates for Compiz have just been released, I think, which may be causing the problem. The crash occurs around 5-10 seconds after opening ccsm, even without doing anything. I have been able to do this 4 times in a row.

As I say, even though the crash is reported, the window remains open, and seems to be running as normal (I can still change options, for example).

Jason Warner (jasoncwarner) wrote :

I got this when I tried to to change the reveal mode setting in the Unity plugin. I got it to happen each time I used that.

To be precise, I did:

* unity --reset
* I like to have both the top left and bottom left corners as reveals for launcher
* opened ccsm
* changed reveal to left and top-left. (crash)
* changed reveal to left, top-left and bottom-left (crash).

I did a fresh install of Oneiric Beta 1, updated everything, and installed ccsm. When I tried to do anything, ccsm crashed and wouldn't let me change any settings.

ziocane (mrc125) wrote :

Happened to me when changing the opacity of the panel with 3.0.0-9-generic kernel and architecture: AMD64

DeadlyWolf (deadlywolf051) wrote :

Happens to me the same as David H (tenswiths) reported,

maara (maara) wrote :

As reported "David H (tenswiths) wrote on 2011-09-06:" .....

Gvozdik Artem (gvozdik) wrote :

Just pressed F10 while looking in CCSM

paul iulian (pauliulian02) wrote :

Când îl inchid eu personal ,atunci sistemul spune că sa inchis neasteptat

soco (soco-n) wrote :

I just got this in ccsm by simply clicking on the copy to texture.

soco (soco-n) wrote :

I also just opened CCSM to verify the "copy to texture" name, and when I pressed enter to submit this bug, it happened. again.

Dave Stroud (bigdavesr) wrote :

with me it happens when compizconf. is open and I change to get properties. It does not seem to have any effect. Im using 32 bit gnome3 fallback.

Jamie Strandboge (jdstrand) wrote :

I encountered this when performing the action in comment #19.

Christopher (soft-kristal) wrote :

Crash reported but CCSM stayed up and running. I was in the Unity plugin settings, but that may not be relevant as there is always a delay before apport kicks in.

Christopher (soft-kristal) wrote :

Forgot to add that I'm on 3.0.0-11 as of earlier today.

Omer Akram (om26er) on 2011-09-12
Changed in compizconfig-settings-manager (Ubuntu):
importance: Undecided → Medium
Tim Stewart (tim-j-stewart) wrote :

I was trying to enable the Application Switcher feature by checking it's box under the Window Management heading.

John Winterton (jwinterton) wrote :

Description: Ubuntu oneiric (development branch)
Release: 11.10
compizconfig-settings-manager:
  Installed: 0.9.5.92-0ubuntu1
  Candidate: 0.9.5.92-0ubuntu1
  Version table:
 *** 0.9.5.92-0ubuntu1 0
        500 http://ca.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status

Occurred without any request when I was just moving the mouse across the icon panel.

Didier Roche (didrocks) on 2011-09-14
Changed in unity:
status: New → Triaged
Changed in compizconfig-settings-manager (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
importance: Undecided → Medium
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 4.16.0
Tim Rørstrøm (timroerstroem) wrote :

Seeing the same thing as Christopher, apport claims that ccsm has crashed, but it keeps on going merrily.

Ant Dickens (antonydickens) wrote :

The launcher in Unity was not responding to unhiding when the mouse was at extreme left of desktop. <Super> did reveal it. I opened CCSM to check settings in the Unity plugin when this crash happened.

jbld (umberto-baldini) wrote :

Nothing happened but the crash poput

Didier Roche (didrocks) on 2011-09-15
Changed in unity:
milestone: 4.16.0 → 4.18.0
Nishant George Agrwal (niagr) wrote :

Using Beta 1
Happens to me a few seconds after opening ccsm. The window remains open and functions as normal after the crash message.

Rainer Rohde (rainer-rohde) wrote :

The same (as reported by #29) happened to me right now as well

other problems with compiz

icb410 (ian-berke) wrote :

Adding my user account to the video group allowed the settings to take affect (I needed to do this to get glx running). I am now able to get smaller icons and can get the opacity to change. However, when I choose the experimental tab I still get a dialog that ccsm crashed unexpectedly- but there's no other problems. The crash dialog is only shown once (and apport isn't run).

Roger (r-wiberg) wrote :

Happened after simply opening ccsm and clicking on the Hide Launcher drop-down menu to look at the alternatives available. I didn't even change any settings.

Cory Dolphin (wcdolphin) wrote :

Same issue as Roger, no settings were applied, crashed immediately upon opening.

Chris Hermansen (c-hermansen) wrote :

Tried to use compizConfig settings manager to set icon size to 32; crashed during this operation.

Chris Hermansen (c-hermansen) wrote :

Just to confirm that compizConfig settings manager now crashes reliably when I try to edit the Unity plug-in settings

i opened compiz config and this report came up but nothing else happened.
ubuntu 11.10 beta1

W Karaki (wafaa-karaki) wrote :

Compiz config settings manager crashes whenever I click on the Unity Plugin settings as well.
Ubuntu 11.10 beta 1, 64 bit installation.

gackthugo (gackthugo) wrote :

Crashed when clicking on a category in ccsm. using 11.10 beta 2

Simon (soshje) wrote :

Crashed when opening ccsm - 11.10 beta 2

Steve Potts (potts1) wrote :

Have Oneiric Beta 2. Installed CompizConfig Settings Manager from Software Centre. Every time I start CCSM, a message appears that says CCSM had a problem and closed unexpectedly yet it continues to work

Same results as Steve Potts above

Download full text (5.9 KiB)

ubuntu 11.10 beta 2

3.0.0-11-generic

dpkg -l|grep unity

ii gir1.2-unity-4.0 4.0.4-0ubuntu1 GObject introspection data for the Unity library
ii libmeanwhile1 1.0.2-4 open implementation of the Lotus Sametime Community Client protocol
ii libunity-2d-private0 4.10.0-0ubuntu1 Unity 2D shared library
ii libunity-core-4.0-4 4.16.0-0ubuntu2 Core library for the Unity interface.
ii libunity-misc4 4.0.4-0ubuntu1 Miscellaneous functions for Unity - shared library
ii libunity5 4.0.0-0ubuntu4 binding to get places into the launcher - shared library
ii libunity6 4.0.4-0ubuntu1 binding to get places into the launcher - shared library
ii unity 4.16.0-0ubuntu2 Interface designed for efficiency of space and interaction.
ii unity-2d 4.10.0-0ubuntu1 Unity interface for non-accelerated graphics cards
ii unity-2d-launcher 4.10.0-0ubuntu1 Unity 2D Launcher
ii unity-2d-panel 4.10.0-0ubuntu1 Unity 2D Panel
ii unity-2d-places 4.10.0-0ubuntu1 Unity 2D Places
ii unity-2d-spread 4.10.0-0ubuntu1 Unity 2D Spread
ii unity-asset-pool 0.8.20-0ubuntu2 Unity Assets Pool
ii unity-common 4.16.0-0ubuntu2 Common files for the Unity interface.
ii unity-greeter 0.0.8-0ubuntu1 Unity Greeter
ii unity-lens-applications 0.4.6-0ubuntu1 Application lens for unity
ii unity-lens-files 0.6.8-0ubuntu1 File lens for unity
ii unity-lens-music 0.1.4-0ubuntu2 Music lens for unity
ii unity-services 4.16.0-0ubuntu2 Services for the Unity interface

dpkg -l|grep gconf

ii compizconfig-backend-gconf 0.9.5.92-0ubuntu2 Compiz Fusion configuration system - gconf backend
ii gconf2 3.1.92-0ubuntu1 GNOME configuration database system (support tools)
ii gconf2-common 3.1.92-0ubuntu1 GNOME configuration database system (common files)
ii gir1.2-gconf-2.0 3.1.92-0ubuntu1 GNOME configuration database system (GObject-Introspection)
ii gstreamer0.10-gconf 0.10.30-1ubuntu7 GStreamer plugin for getting the sink/source information from GC...

Read more...

Martin Wildam (mwildam) wrote :

Crashed when closing Compiz Config Settings Manager changing nothing (just opened it and closed it again) while logged into LXDE session.

Martin Wildam (mwildam) wrote :

On Close cannot reproduce but when clicking on preferences and switching focus to another window.

Tony Mugan (tmugan) wrote :

I got it with Oneiric (with all latest updates) when attempting to enable wobbly windows.

I do not have a 3D driver enabled but would have expected a dialog informing of that fact rather than a crash.

Vadim Peretokin (vperetokin) wrote :

Fairly certain it's not a driver problem - it's not related to it.

Same as #29. I don't actually have to do anything to get the bug, it just appears but the window continues to work.

EricDHH (ericdhh) wrote :

Opened ccsm, look at the icons and crash......

bpf (br1-an) wrote :

using Oneric b2 with latest updates. Ran CCSM for first time and got crash message, however app still running

Rinzwind (w-damen) wrote :

Initializing animation options...done
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ccm/Utils.py", line 253, in ParseSettings
    plugin.Update ()
  File "compizconfig.pyx", line 783, in compizconfig.Plugin.Update (src/compizconfig.c:5765)
  File "compizconfig.pyx", line 870, in compizconfig.Plugin.ApplyStringExtensions (src/compizconfig.c:6780)
KeyError: '@Z\r\n\x01'

Oneiric Beta 2.
Just clicking on `Utility`

Philip Goh (philip-wj-goh) wrote :

I have the latest beta of Oneiric, and I'm getting this error while changing the Unity launcher icon size property. Despite the error message, CCSM successfully persisted the icon settings.

Changed in unity:
status: Triaged → Fix Committed
Changed in compizconfig-settings-manager (Ubuntu):
status: Triaged → Fix Committed
Changed in compiz-compizconfig-python:
importance: Undecided → Medium
Changed in compizconfig-settings-manager (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-compizconfig-python:
assignee: nobody → Sam Spilsbury (smspillaz)
status: New → Fix Committed
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 4.18.0-0ubuntu1

---------------
unity (4.18.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Screen corruption when resuming from suspend/hibernate (LP: #676166)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #764024)
    - Dash and launcher appear underneath windows (LP: #805087)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #811401)
    - [Oneric] unity-panel-service crashed with SIGSEGV in getenv()
      (LP: #817691)
    - compiz crashed with SIGSEGV in unity::FilterBar::RemoveFilter()
      (LP: #845732)
    - crash on closing a window (LP: #856015)
    - Cannot open a window that starts iconified (LP: #732997)
    - Launcher - When useing Alt F1 launcher keyboard navigation, Launcher
      should not scroll until top or bottom of Launcher is reached
      (LP: #765749)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
    - Pull panel to de-maximize window occasionally not working in a secondary
      screen (LP: #802651)
    - Window under Dash gets focused if it opened later (LP: #830730)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
      is set to true (LP: #847967)
    - a11y support on Unity is broken (LP: #851103)
    - compiz crashed with SIGSEGV in dee_model_get_tag() (LP: #840758)
    - crash when looping paint list in preparePaint (on closing windows)
      (LP: #853807)
    - Alt-Tab should not preview windows at excessively large sizes
      (LP: #854740)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - Dragging a launcher icon makes it squashed (LP: #855761)
    - unable to unminimize gedit windows where more than one window where one
      has a dialog open (LP: #856030)
    - (oneiric) alt-tab UX doesn't work well on multi-monitor (LP: #855364)
    - Launcher shows on the primary monitor instead of the left most monitor
      (LP: #857668)
    - Keynav - pressing down key causes launcher items to jump up and down
      (LP: #858469)
    - Windows creep cross the screen with ALT+TAB (LP: #722830)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - All unity windows are invisible (panel, launcher, dash) (LP: #745996)
    - Dash "See 97 more results" has ~1 second of latency (LP: #731158)
    - Windows cannot be dragged down from panel if banshee closed to sound
      menu (LP: #781215)
    - no menu bar on top, compositing bug? (LP: #806358)
    - Launcher - a spread can accidentally be triggered during the 'dragging
      and dropping behind the Launcher' interaction (LP: #832988)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - Application name drawn under Dash controls when window opens under Dash
      (LP: #838176)
    - Start ...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released

When I wan't to change options in Animations in CompizConfig, I've got this bug. It is very strange becouse I don't have options like effects to choice in dialog window..

Vadim Peretokin (vperetokin) wrote :

Have you updated to the new Unity since it was marked as fixed?

gackthugo (gackthugo) wrote :

Crashed when i was navigating in the different categories. Updated system 20 minutes ago. Using 11.10 beta 2.

oder more problems by compiz

Andreas (andreas-rabus) wrote :

here to just after starting ccsm.
Perhaps some plugins are buggy?

Klaus Reichl (klaus-reichl) wrote :

Was not even changing anything. Just started and ... off it went.

Klaus Reichl (klaus-reichl) wrote :

Here a command line trace of the situation. Still not doing anything and ccsm is still operative.

Changed in compizconfig-settings-manager (Ubuntu):
status: Fix Committed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compizconfig-settings-manager (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2011-09-28
Changed in compizconfig-settings-manager (Ubuntu):
status: Confirmed → Invalid
JCCyC (jccyc1965) wrote :

Happened to me while I tried to go to the Unity plugin and change the launcher auto-hide mode to "Never". Version 0.9.5.92-0ubuntu1 on Oneiric Beta updated today.

Kevin Squire (kevin-squire) wrote :

I'm currently running unity 4.20.0-0ubuntu1, and can confirm that the bug is still there. Any time ccsm (version 0.9.5.92-0ubuntu1) is started, I see the same output as in post #4 above.

Changed in compizconfig-settings-manager (Ubuntu):
status: Invalid → Confirmed
Wild Man (wildmanne39) wrote :

compizconfig-settings-manager crashed when I clicked on the unity plug so I could auto hide the launcher.

David (slochower) wrote :

Just opening ccsm in 4.20.0-0ubuntu causes CompizConfig Settings Manager to close unexpectedly.

David Barth (dbarth) wrote :

There is a KeyError trapped by apport bug the program still runs.

André Barmasse (barmassus) wrote :

Bug still there after todays update (october 1st). Randomly crashes, when trying to change something within the unity plugin. After three immediate crashes it suddenly worked without crashing. Does it have to warm up first? Very strange ...

altheli (altheli) wrote :

I only started this programm

Jared (jared-vanvolkenburg) wrote :

Have all the updates as of today 10/01. I just opened CompizConfig Settings Manager and did nothing but scroll down. I didn't open or change any of the settings.

Jared (jared-vanvolkenburg) wrote :

compiz:
  Installed: 1:0.9.6+bzr20110929-0ubuntu1
  Candidate: 1:0.9.6+bzr20110929-0ubuntu1
  Version table:
 *** 1:0.9.6+bzr20110929-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

unity:
  Installed: 4.20.0-0ubuntu2
  Candidate: 4.20.0-0ubuntu2
  Version table:
 *** 4.20.0-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

compizconfig-settings-manager:
  Installed: 0.9.5.92-0ubuntu1
  Candidate: 0.9.5.92-0ubuntu1
  Version table:
 *** 0.9.5.92-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe i386 Packages

Paolo Stivanin (polslinux) wrote :

If i click on "unity plugin" ccsm will crash...i've ubuntu with lastest update...

Riccardo Pelizzi (r-pelizzi) wrote :

it still happens to me as well with the following keyerror:

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ccm/Utils.py", line 253, in ParseSettings
    plugin.Update ()
  File "compizconfig.pyx", line 783, in compizconfig.Plugin.Update (src/compizconfig.c:5765)
  File "compizconfig.pyx", line 870, in compizconfig.Plugin.ApplyStringExtensions (src/compizconfig.c:6780)
KeyError: '\xc8\xb0\x14\n\x01'

fantab (fantab) wrote :

it still crashes

dmiranda (dmiranda) wrote :

>If i click on "unity plugin" ccsm will crash...i've ubuntu with lastest update...
Me too!!!!

Aslam Muhammad (aslamckra) wrote :

ccsm still crashes
compiz version compiz-core 1:0.9.6+bzr20110929-0ubuntu3
ccsm version compizconfig-settings-manager 0.9.5.92-0ubuntu1
way to reproduce, just open ccsm, and wait a few seconds it automatically crash

Changed in unity:
milestone: 4.18.0 → 4.24.0
Didier Roche (didrocks) on 2011-10-05
affects: compizconfig-settings-manager (Ubuntu) → compizconfig-python (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compizconfig-python - 0.9.5.94-0ubuntu2

---------------
compizconfig-python (0.9.5.94-0ubuntu2) oneiric; urgency=low

  * debian/patches/fix-832458.patch
    - upstream patch to fix a ccsm crash (LP: #832458)
  * debian/control, debian/rules:
    - add quilt support
 -- Didier Roche <email address hidden> Wed, 05 Oct 2011 11:57:10 +0200

Changed in compizconfig-python (Ubuntu):
status: Confirmed → Fix Released
description: updated
dino99 (9d9) on 2015-02-12
Changed in compiz-compizconfig-python:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers