compiz crashed with SIGSEGV when imgsvg is loaded, in getCompPluginVTable20090315_imgsvg() from dlloaderLoadPlugin() from CompPlugin::load()

Bug #956986 reported by Daniel Cantarín on 2012-03-16
148
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Compiz
High
Daniel van Vugt
Compiz Core
High
Daniel van Vugt
compiz (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Impact]

Crash when disabling a plugin.

[Test Case]

using ccsm, after disabling "session management", got this error.

[Regression Potential]

Very low, the commit is an additional dependency to a makefile.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: compiz-core 1:0.9.7.0+bzr3035-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
CompizPlugins: [core,composite,opengl,notification,maximumize,imgjpeg,compiztoolbox,decor,move,gnomecompat,wobbly,imgsvg,text,imgpng,workarounds,resize,kdecompat,cube,rotate,resizeinfo,unityshell,unitymtgrabhandles]
CompositorRunning: compiz
CrashCounter: 1
Date: Fri Mar 16 10:53:28 2012
Disassembly: => 0x75a6: Cannot access memory at address 0x75a6
DistUpgraded: Log time: 2012-03-03 15:54:54.478616
DistroCodename: precise
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation Mobile 945GSE Express Integrated Graphics Controller [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8340]
   Subsystem: ASUSTeK Computer Inc. Device [1043:8340]
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
MachineType: ASUSTeK Computer INC. 1000H
ProcCmdline: compiz
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic-pae root=UUID=c214beb7-4177-4333-ace3-7e5d86fd3c91 ro splash vga=788 quiet splash security=selinux selinux=1 vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x75a6: Cannot access memory at address 0x75a6
 PC (0x000075a6) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? ()
 getCompPluginVTable20090315_imgsvg () from /usr/lib/compiz/libimgsvg.so
 ?? () from /usr/lib/libcompiz_core.so.ABI-20120228
 CompPlugin::load(char const*) () from /usr/lib/libcompiz_core.so.ABI-20120228
 compiz::private_screen::PluginManager::updatePlugins() () from /usr/lib/libcompiz_core.so.ABI-20120228
Title: compiz crashed with SIGSEGV in getCompPluginVTable20090315_imgsvg()
UpgradeStatus: Upgraded to precise on 2012-03-05 (10 days ago)
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 02/18/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1701
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1000H
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1701:bd02/18/2009:svnASUSTeKComputerINC.:pn1000H:pvrx.x:rvnASUSTeKComputerINC.:rn1000H:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 1000H
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.7.0+bzr3035-0ubuntu1
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Daniel Cantarín (omega-canta) wrote :

StacktraceTop:
 ?? ()
 getCompPluginVTable20090315_imgsvg () at /build/buildd/compiz-0.9.7.0+bzr3035/plugins/imgsvg/src/imgsvg.cpp:30
 dlloaderLoadPlugin (p=0x85ae520, path=0xbfb9a440 "l.Z\b", name=0xb50141b0 "\203\354,\211\\$ \350K\371\377\377\201\303\070\376") at /build/buildd/compiz-0.9.7.0+bzr3035/src/plugin.cpp:190
 CompPlugin::load (name=0x93c1a7c "imgsvg") at /build/buildd/compiz-0.9.7.0+bzr3035/src/plugin.cpp:466
 compiz::private_screen::PluginManager::updatePlugins (this=0x8337510) at /build/buildd/compiz-0.9.7.0+bzr3035/src/screen.cpp:994

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 956986, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

summary: - compiz crashed with SIGSEGV in getCompPluginVTable20090315_imgsvg()
+ compiz crashed with SIGSEGV in getCompPluginVTable20090315_imgsvg() from
+ dlloaderLoadPlugin() from CompPlugin::load()
Changed in compiz:
status: New → Confirmed
milestone: none → 0.9.8.0
Changed in compiz (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
summary: - compiz crashed with SIGSEGV in getCompPluginVTable20090315_imgsvg() from
- dlloaderLoadPlugin() from CompPlugin::load()
+ compiz crashed with SIGSEGV when imgsvg is loaded, in
+ getCompPluginVTable20090315_imgsvg() from dlloaderLoadPlugin() from
+ CompPlugin::load()
Changed in compiz:
importance: Undecided → Medium
importance: Medium → High
status: Confirmed → In Progress
Changed in compiz-core:
status: New → Triaged
importance: Undecided → High
milestone: none → 0.9.7.10
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3328

Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:compiz-core/0.9.7 at revision 3116

Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Triaged → Fix Committed
Changed in compiz:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package compiz - 1:0.9.8.2+bzr3377-0ubuntu1

---------------
compiz (1:0.9.8.2+bzr3377-0ubuntu1) quantal-proposed; urgency=low

  [ Sam Spilsbury ]
  * debian/python-compizconfig.install
    - Install compizconfig-python.pc
  * debian/patches/100_expo_layout.patch
    - re-add the expo layout that used to be in precise (LP: #1047067)
    - add some testcases

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix multiple window placement bugs (LP: #974242) (LP: #976032)
    - Don't waste CPU looping through and looking at all the windows if you're
      rendering an output that has no damage on it. (LP: #1014986)
    - Updated convert files to fix some typos in the key names. (LP: #1041631)
    - Fix crash when imgsvg is loaded, due to missing symbol
      (decor_apply_gravity from libdecoration). (LP: #956986)
    - Treat unresolved symbols at link time as an error, rather than letting
      them through and cause strange crashes later. (LP: #1043143)
    - Refactors a little bit of the upgrade code and gets it under test to
      prepare to fix (LP: #1042537)
    - Updated AUTHORS from the full bzr log, and re-sort the list.
      (LP: #1042095)
    - Fixes FTBFS for kde4-window-decorator (LP: #1041310)
    - Fix obvious omissions from the introduction of unminimize_*,
      which were causing the unminimize animation settings to be ignored
      (LP: #1040455)
    - resize plugin: don't crash if resize wasn't initiated externally
      (LP: #1045191)
    - Clean up capitalization (LP: #1045652)
    - Avoid division by zero, if plugins try to deform a window down to size
      zero. (LP: #1045235)
    - Make "Unredirect Fullscreen Windows" more reliable. This fixes the
      problem with unredirection failing to engage at all (LP: #1041066) when
      gtk-window-decorator creates offscreen windows that are stacked on top.
      This also fixes the problem with unredirect hiding all windows,
      because it thinks the desktop window should be stacked on top
      (LP: #980663).
    - Ensure unredirected windows don't stay unredirected if they're no longer
      on top. (LP: #1041047)
    - Fix launching terminal functionality and make show-hud default key
      visible. Update the defaults to org.compiz.integrated to reflect the
      actual gnome values pre-gnome-3. (LP: #1040081) (LP: #1046199)
      (LP: #1046190)
    - Fix show-hud, bump COMPIZ_GNOME_INTEGRATED_SETTINGS_LIST_SIZE.
      (LP: #1046212)
    - Fixed: Windows with an alpha-channel, like gnome-terminal, were not
      being considered as possibly covering fullscreen windows. But they most
      certainly can. This ensures such RGBA windows are visible if they're
      stacked above a fullscreen window. (LP: #1046661)
    - Remove ListToStringList (LP: #1046184)
    - Fix typo causing CMake Error (LP: #1045665)
    - Transitions gtk-window-decorator over to use GSettings. Add a testing
      framework for the options code. (LP: #1042323)
    - Also need kdeworkspace since kdecorationbridge.h is there
      (LP: #1046770)
    - Implements some cleanup that was suggested on the merge for the original
      port to gsettings. Other issues fixed as wel...

Read more...

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
description: updated
description: updated
Changed in compiz-core:
status: Fix Committed → Fix Released

Hello Daniel, or anyone else affected,

Accepted compiz into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.7.8+bzr3121-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Not crashing anymore.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.8+bzr3121-0ubuntu1

---------------
compiz (1:0.9.7.8+bzr3121-0ubuntu1) precise-proposed; urgency=low

  * New upstream stable branch snapshot.
    - Includes all the previous cherry-picked fixes
    - Fix crash when imgsvg is loaded, due to missing symbol
      (decor_apply_gravity from libdecoration). (LP: #956986)
    - Fix multiple window placement bugs (LP: #974242) (LP: #976032)
    - Fix window handle leak causing gradual degradation in desktop
      performance (LP: #1050610)
    - Some decoration pixmaps get leaked on window resize, due to race
      conditions between gtk-window-decorator and the decor plugin.
      (LP: #1057263)
    - Avoid a NULL dereference and give a useful error message instead.
      (LP: #944653)
    - Fix leakage of destroyed_pixmaps_table, containing pointers to freed
      decor_t's which could result in a freed GHashTable being passed into
      g_hash_table_remove and causing a crash. (LP: #1060171)
  * debian/patches/compiz-package-gles2.patch:
    - Drop the NEWS file, update decor.cpp part to build with new upstream
      code.
  * debian/patches/revert_fix_933776_955035.patch:
    - Cherry-pick the revert from upstream since the bug fix is not
      suitable for SRU as is
  * debian/patches/revert_fix_994841.patch:
    - Cherry-pick also this revert as non-SRU material, not relevant
      to users
  * debian/libdecoration0.symbols:
    - Update with latest symbols
 -- Timo Jyrinki <email address hidden> Mon, 12 Nov 2012 13:56:29 +0200

Changed in compiz (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.