Super-W shows vanishing windows the first time you hit it. Windows fly off the screen instead of spreading.

Bug #955035 reported by Nick Moffitt on 2012-03-14
182
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Compiz
High
Łukasz Zemczak
Compiz Core
High
Łukasz Zemczak
compiz (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

The first time I hit Super-W in a session, my windows zoom up to corners of my screen and shrink to a vanishing point. It almost looks like some kind of reverse-starfield-screensaver effect. If I Esc out of it and hit Super-W again, I see a neatly-ordered grid of windows again.

This only seems to happen the first time after logging in (or, at least, after rebooting).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.6.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,snap,gnomecompat,grid,regex,mousepoll,compiztoolbox,resize,move,wall,animation,vpswitch,place,imgpng,workarounds,expo,fade,ezoom,session,scale,unityshell]
CompositorRunning: compiz
Date: Wed Mar 14 13:28:17 2012
DistUpgraded: Log time: 2012-02-06 09:06:52.229292
DistroCodename: precise
DistroVariant: ubuntu
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:20e4]
   Subsystem: Lenovo Device [17aa:20e4]
MachineType: LENOVO 7465CTO
ProcEnviron:
 TERM=xterm
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: root=UUID=5237fceb-23d0-412d-84d9-b8f8b3bf28af ro quiet splash
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-03-13 (1 days ago)
dmi.bios.date: 06/25/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6DET55WW (3.05 )
dmi.board.name: 7465CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6DET55WW(3.05):bd06/25/2009:svnLENOVO:pn7465CTO:pvrThinkPadX200s:rvnLENOVO:rn7465CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 7465CTO
dmi.product.version: ThinkPad X200s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.0+bzr3035-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Nick Moffitt (nick-moffitt) wrote :
Nick Moffitt (nick-moffitt) wrote :

In addition, the window that had focus when I hit super-w this first time now appears to be inaccessible. It shows up in Alt-` listings, and I can give it focus. When it has focus, I can click on my nautilus desktop and still get menus for this window. I suspect that it has fallen behind nautilus's root window analogue.

Omer Akram (om26er) on 2012-03-14
tags: added: spread
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
David Barth (dbarth) wrote :

I can't reproduce the issue here, with unity-5.6.0 up to date.
Maybe this is specific to a driver (Intel). I'm running on radeon here.

Omer Akram (om26er) wrote :

Can you please make a video of the problem you are facing?

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
James Troup (elmo) wrote :

Here's a video showing the "vanishing windows" effect.

James Troup (elmo) wrote :

And here's a video showing the "invisible window" effect we think is related to this bug. (No otters were harmed in the making of this video.)

Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Omer Akram (om26er) wrote :

Uh, that hurts :/

Changed in unity:
status: New → Confirmed
Changed in compiz-core:
status: New → Confirmed
Nick Moffitt (nick-moffitt) wrote :

In the end, the otters didn't particularly look like Benedict Cumberbatch: http://emmark.info/otter/

Nick Moffitt (nick-moffitt) wrote :

Upon reflection, however, David Mitchell is absolutely a Koala: http://davidmitchellisakoala.tumblr.com/

Sebastien Bacher (seb128) wrote :

I can confirm that here, quite "scary" in some way, it's easy to reproduce this way
- start a session
- click on nautilus on the launcher
- ctrl-alt-right to go to ws2
- click on nautilus
- ctrl-alt-left to go to ws1
- super-W

it does it most of the time here with those steps

Changed in compiz-core:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

Daniel, Alan, do you think that's something you could look at? It seems a bug that should be fixed in a SRU, the effect can be quite disturbing the first time you seem it

Changed in unity:
milestone: none → 5.12.0
Bruno Santos (bsantos) wrote :

Can we consider this related to bug 933776?

Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0
Changed in compiz:
importance: Undecided → High
status: New → Confirmed
Miklos Juhasz (mjuhasz) wrote :

This issue happens to me not only the first time I hit Super+W but it bites me later as well. I am actively using 4 workspaces if that matters.
I regularly lose windows as described in comment #2 and I have to run 'compiz --replace &' to get them back without having to close the applications but then my windows get mixed up between workspaces so not a very convenient workaround.

summary: - Super-W shows vanishing windows the first time you hit it
+ Super-W shows vanishing windows the first time you hit it. Windows fly
+ off the screen instead of spreading.
Changed in compiz:
milestone: none → 0.9.8.0
affects: unity (Ubuntu) → compiz (Ubuntu)
no longer affects: unity
Changed in compiz:
status: Confirmed → In Progress
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in compiz-core:
status: Confirmed → In Progress
assignee: nobody → Łukasz Zemczak (sil2100)
milestone: none → 0.9.7.10
tags: added: scale
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3271

Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz-core:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core/0.9.7 at revision 3110

Timo Jyrinki (timo-jyrinki) wrote :

12.04 LTS packages for testing at https://launchpad.net/~timo-jyrinki/+archive/compiz-precise-sru - please give feedback.

Tested Timo's PPA and all looks good. I don't get the flying windows problem anymore.

Miklos Juhasz (mjuhasz) wrote :

Using Timo's ppa Super+W for spreading all windows works fine here.

Alan Pope:
> Tested Timo's PPA and all looks good. I don't get the flying windows
> problem anymore.

This is all well and good, but did the otters look like Benedict
Cumberbatch?

--
Nick Moffitt

Launchpad Janitor (janitor) wrote :
Download full text (7.9 KiB)

This bug was fixed in the package compiz - 1:0.9.8+bzr3319-0ubuntu1

---------------
compiz (1:0.9.8+bzr3319-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/patches/ubuntu-config.patch:
    - refresh with latest trunk
  * debian/*docs:
    - remove the TODO copy now removed upstream
  * debian/compiz-plugins.install:
    - install stackswitch, trip plugins
  * debian/rules, debian/control:
    - remove the compiz gnome-control-center key sedding through metacity.
      Compiz now directly ships them.
    - we do not need metacity-common anymore as a build-dep then
  * debian/compiz-gnome.migrations, debian/control:
    - build-dep on dh-migrations and ship gconf -> gsettings migration file

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix Compiz crash in movementWindowOnScreen (LP: #1015151)
    - Start window decorator when decor plugin starts (LP: #1014461)
    - Fixed: Crash in compiz::wall::movementWindowOnScreen (LP: #1015151)
    - Don't waste memory leaving /bin/sh running (LP: #1015422)
    - Add reliable detection of the compiz bin directory (LP: #1015898)
    - Check if the window would actually paint before painting the shadow,
      since it is possible that another plugin could be inhibiting paint of
      the dock window. (LP: #1012956)
    - Don't insert the window into the server list above the window it was
      created above. (LP: #1008020) (LP: #886605)
    - makes compiz enhanced zoom and show mouse plugins considerably
      smoother to use (LP: #930783)
    - Don't set decoration contexts on undecorated windows, since that
      might be read later and code will assume the window is decorated when
      it isn't. (LP: #1015593)
    - Fix potentially unterminated string leading to an uninitialized memory
      read (LP: #1018302)
    - Lift the 31/32 character restriction on key names that was causing so
      many warnings. It's now 1024 characters according to glib. (LP: #1018730)
    - Don't print the result of BUILD_DEB. It prevents ccsm et al from
      installing. (LP: #1018916)
    - Use the XDamage extension more efficiently (the way it was designed to be
      used). This dramatically reduces CPU usage, reduces wakeups, and
      increases frame rates. It also solves at least one observed performance
      bug (LP: #1007299) and probably several more.
    - Do the initial work to get libcompizconfig under test. (LP: #990690)
    - Add support for initiating window picker in other than nomal mode. For
      now added only the additional 'All windows' picker (LP: #933776)
      (LP: #955035)
    - Fixes (LP: #1018602) : An invalid read when using g_variant_iter_loop.
    - Don't allow unbinds of textures kept around for animations in any case,
      not just resizing. (LP: #1016366)
    - Wait for the server to finish processing requests before doing a bind
      (LP: #1016367)
    - Using the next/previous bindings the wall plugin didn't calculate
      correctly the next workspace when it reaches the begin or the end of a
      row of workspaces, so it didn't jump to the n...

Read more...

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
ethanay (ethan-y-us) wrote :

I think Nick Moffitt has either lost his marbles or his account has been hijacked...

Changed in compiz-core:
status: Fix Committed → Fix Released
Margarita Manterola (marga-9) wrote :

Hi, the package has been uploaded to quantal-proposed, but the fix was manually excluded from the precise-proposed upload because:

  * debian/patches/revert_fix_933776_955035.patch:
    - Cherry-pick the revert from upstream since the bug fix is not
      suitable for SRU as is

Is there any extra information about this not being "suitable as is", and how to make it suitable?

Timo Jyrinki (timo-jyrinki) wrote :

Margarita: you can read on the problematics of the fix in the lenghty discussion of bug #933776. If this bug could be fixed separately from that bug, it'd be acceptable for a SRU even if the #933776 would remain unfixed for a longer time than this.

Marked the upstream bug as unfixed, since the patch was also reverted there.

Changed in compiz-core:
status: Fix Released → Confirmed
milestone: 0.9.7.10 → 0.9.7.14
Nekhelesh Ramananthan (nik90) wrote :

Timo, I think the issue in this bug is definitely different from bug #933776 since irrespective of the keyboard shortcut used, the vanishing window appears. I seriously hope this bug is dealt separately and becomes available as a SRU. This vanishing window has been present on precise for almost 9 months now. Please let it land as an SRU considering the fix is already available in code.

Nekhelesh Ramananthan (nik90) wrote :

@Timo, that said can I just install compiz from your ppa despite it being an older version than what is currently offered as an update?

Margarita Manterola (marga-9) wrote :

Timo, thanks for the reply, I've been reading the discussion in the other bug, and I had a look at the code and the reverted patch.

I'm not sure how the other patch actually fixed this issue. The code for "layoutThumbsAll" looks much simpler than the current "layoutThumbs", and nothing seems to be explicitly done to prevent this problem. I'm guessing that the problem that causes this bug is in this piece of complex code, which is not present at all in the other one:

    for (std::map<ScaleWindow *, ScaleSlot>::iterator it = slotWindows.begin ();
         it != slotWindows.end (); it++)
    {
        slots.push_back (it->second);
        windows.push_back (it->first);
        it->first->priv->slot = &slots.back ();
        it->first->priv->slot->setX (it->first->priv->slot->x () + (it->first->priv->window->defaultViewport ().x () - screen->vp ().x ()) * screen->width ());
        it->first->priv->slot->setY (it->first->priv->slot->y () + (it->first->priv->window->defaultViewport ().y () - screen->vp ().y ()) * screen->height ());
    }

But I don't see where exactly the problem lies.

Changed in compiz-core:
status: Confirmed → Fix Released
To post a comment you must log in.