compiz crashed with SIGSEGV in XDefineCursor()

Bug #936487 reported by Gvozdik Artem on 2012-02-19
160
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Alan Griffiths
compiz (Ubuntu)
High
Unassigned

Bug Description

Happened on Acer AOD257 while upgrading from 11.10 to 12.04.
After reboot, just now.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: compiz-core 1:0.9.7.0~bzr2995-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic i686
.tmp.unity.support.test.0:

ApportVersion: 1.91-0ubuntu1
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,regex,snap,imgpng,unitymtgrabhandles,move,mousepoll,place,gnomecompat,resize,vpswitch,grid,session,animation,workarounds,expo,wall,fade,scale,ezoom,unityshell]
CompositorRunning: compiz
Date: Sun Feb 19 23:54:10 2012
DistUpgraded: Log time: 2012-02-19 22:19:34.377782
DistroCodename: precise
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0590]
   Subsystem: Acer Incorporated [ALI] Device [1025:0590]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 04f2:b209 Chicony Electronics Co., Ltd
MachineType: Acer AOD257
ProcCmdline: compiz --replace
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic root=UUID=5e059dc0-7ac8-42b6-939c-a04e6b3c87d2 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x3f0004 <XDefineCursor+20>: mov 0x4d0(%esi),%eax
 PC (0x003f0004) ok
 source "0x4d0(%esi)" (0x000004d0) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 XDefineCursor () from /usr/lib/i386-linux-gnu/libX11.so.6
 PrivateScreen::updateStartupFeedback() () from /usr/lib/libcompiz_core.so.ABI-20120216
 PrivateScreen::removeAllSequences() () from /usr/lib/libcompiz_core.so.ABI-20120216
 CompScreenImpl::~CompScreenImpl() () from /usr/lib/libcompiz_core.so.ABI-20120216
 CompScreenImpl::~CompScreenImpl() () from /usr/lib/libcompiz_core.so.ABI-20120216
Title: compiz crashed with SIGSEGV in XDefineCursor()
UpgradeStatus: Upgraded to precise on 2012-02-19 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 10/21/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: V1.15
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JE06_PT
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrV1.15:bd10/21/2011:svnAcer:pnAOD257:pvrV1.15:rvnAcer:rnJE06_PT:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: AOD257
dmi.product.version: V1.15
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu4
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Gvozdik Artem (gvozdik) wrote :
visibility: private → public

StacktraceTop:
 XDefineCursor (dpy=0x0, w=0, cursor=0) at ../../src/DefCursor.c:40
 updateStartupFeedback (this=0x8ffe508) at /build/buildd/compiz-0.9.7.0~bzr2995/src/screen.cpp:2036
 PrivateScreen::updateStartupFeedback (this=0x8ffe508) at /build/buildd/compiz-0.9.7.0~bzr2995/src/screen.cpp:2031
 PrivateScreen::removeAllSequences (this=0x8ffe508) at /build/buildd/compiz-0.9.7.0~bzr2995/src/screen.cpp:2133
 CompScreenImpl::~CompScreenImpl (this=0x8ffe488, __in_chrg=<optimized out>) at /build/buildd/compiz-0.9.7.0~bzr2995/src/screen.cpp:4933

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz (Ubuntu):
importance: Medium → High
Changed in compiz-core:
importance: Undecided → High
Achim Behrens (k1l) wrote :

happens to me several times a day.

described here https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/938947

Sam Spilsbury (smspillaz) wrote :

This crash only happens when DISPLAY= is not set. As such, compiz would fail to start anyways.

Assigning to alan_g in any case.

Changed in compiz-core:
assignee: nobody → Alan Griffiths (alan-griffiths)

On 23/02/12 00:43, Sam Spilsbury wrote:
> This crash only happens when DISPLAY= is not set. As such, compiz would
> fail to start anyways.

I assume from this the desired outcome is a graceful exit?

--
Alan Griffiths +44 (0)798 9938 758
Octopull Ltd http://www.octopull.co.uk/

Tim Penhey (thumper) on 2012-02-23
Changed in compiz-core:
status: New → Fix Committed
milestone: none → 0.9.7.2
Daniel van Vugt (vanvugt) wrote :

If it's committed already then the fix has made it into 0.9.7.0.

Changed in compiz-core:
milestone: 0.9.7.2 → 0.9.7.0
tags: added: bugpattern-needed
Dunkirk (david-davidkrider) wrote :

I've GOT 0.9.7.0 installed, and the automatic bug wrangler still directed me here.

Daniel van Vugt (vanvugt) wrote :

This particular bug is fixed in compiz-core revision 3018. The official compiz 0.9.7.0 released yesterday is revision 3033.

Ubuntu 12.04 however I think still has a pre-release version of compiz 0.9.7.0 based on revision 2995. Hence even if you have compiz 0.9.7.0 in Ubuntu 12.04, you might not have this fix yet.

Changed in compiz-core:
status: Fix Committed → Fix Released
Brett (belgarth) wrote :

I am hitting this bug with ubuntu 12.04 which has 0.9.7.0 rev 2995. Anyone know how to get it upgraded to something with the fix or when the official repositories will get upgraded with a newer revision with the fix?

Daniel van Vugt (vanvugt) wrote :

I believe the fix for this will be in beta-2. So the repositories should be updated to include it within weeks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.0+bzr3035-0ubuntu1

---------------
compiz (1:0.9.7.0+bzr3035-0ubuntu1) precise; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream snapshot:
    - Fix gtk-window-decorator crash upon demaximizing a window (LP: #930071)
    - Fix core keybindings (LP: #930412)
    - Fixes compiz crash with SIGSEGV on shutdown (LP: #931283)
    - Plugins can't tell the difference between a key-tap and modifier
      key-release (LP: #925293)
    - compiz-core r3001 (and 3002) ftbfs (LP: #933226)
    - Semi-maximized windows have no shadow or frame (LP: #924736)
    - Untranslated strings in gtk-window-decorator (LP: #780505)
    - Initialize the _NET_WM_STATE_FOCUSED (LP: #932087)
    - [regression] Customized shortcuts don't work (LP: #931927)
    - Window stacking problem (LP: #936675)
    - Quickly demaximized windows can receive maximized window decorations if
      they were initially maximized (LP: #936778)
    - Maximized windows do not get shadows at all (LP: #936774)
    - [regression] Launcher, top panel and keyboard un-responsive after using
      any Super-x shortcut (LP: #934058)
    - No draggable border if mutter isn't installed (LP: #936781)
    - Fix compiz crash with SIGSEGV in XDefineCursor() (LP: #936487)
    - Fixes memory leak at DecorWindow::updateSwitcher() (LP: #940115)
    - Unresolved symbols in plugins cause compiz to exit (LP: #938478)
    - Fix compiz spending about 51% of its CPU time in CompRegion
      construction/destruction (LP: #940139)
    - Fix Conditional jump or move depends on uninitialised value(s) in
      decor_match_pixmap (LP: #940066)
    - Fix 'show desktop' behaviour (LP: #871801)
    - Tweak algorithm used to cast shadows on maximized windows (LP: #936784)
    - "Svg" and "Png" should be "SVG and "PNG" (LP: #942890)
    - Fix invalid memory usage after free() in DecorWindow (LP: #943116)
    - Fix alt + F10 (LP: #943223)
  * Removed cherry-picked patches
  * debian/patches/fix_944631.patch:
    - Always replay the keyboard if something was grabbed and didn't trigger
      an action and don't trigger actions which aren't added accidentally
      (LP: #943612) (LP: #944631)
  * debian/patches/fix_923683.patch:
    - Backports a patch which prevents the shift race condition

  [ Didier Roche ]
  * debian/patches/fix_alt_pressing.patch:
    - Patch from ddv to fix all the regressions with the alt key fix and other
      (LP: #943851, #945373)
    - Fix Quicklist are not showing if right-clicking a launcher icon in Expo
      mode if triggered by Super + S (LP: #944979)
  * debian/patches/fix_806255.patch:
    - Unity/compiz intercepts keystrokes from grabbed windows (LP: #806255)
  * debian/patches/fix_943194.patch:
    - second part for the alt key fix (LP: #943194)
  * debian/patches/additional_alt_tapping_fix.patch:
    - again another alt tapping related fix for some regressions from the
      previous branch. Taken from "tapping-panacea" upstream branch.
 -- Didier Roche <email address hidden> Mon, 12 Mar 2012 10:22:10 +0100

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.