Keyboard shortcuts set in Gnome Control Center - Keyboard do not have affect if those same shortcuts are set in Compiz

Bug #898087 reported by Iakov Davydov on 2011-11-30
184
This bug affects 43 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Compiz Core
Undecided
Unassigned
compiz (Ubuntu)
Low
Unassigned
gnome-control-center (Ubuntu)
Undecided
Unassigned

Bug Description

Through system settings -> keyboard -> shortcuts -> navigation I can set shortcut to move window to workspace 1/2/3.. But actually shortcuts doesn't work.

It's a bug since the option exist but doesn't work.

Steps to reproduce:
1. Login (using unity)
2. Open System Settings -> Keyboard -> Shortcuts -> Navigation
3. Set "Move window to workspace 2" shortcut to Alt + 2
4. Press Alt + 2

What should happen:
Settings window should be moved to workspace 2.

What happens:
Nothing.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.24.0-0ubuntu2b1
Uname: Linux 3.1.2-030102-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,place,vpswitch,imgpng,move,grid,mousepoll,regex,session,snap,resize,gnomecompat,unitymtgrabhandles,animation,expo,wall,ezoom,workarounds,fade,switcher,scale,unityshell]
Date: Wed Nov 30 13:50:42 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Iakov Davydov (iakov-davydov) wrote :
Omer Akram (om26er) wrote :

thats not a unity bug, neither i believe a comiz one, its gnome-control-center that should not show it (or is gnome-control-center connected to compiz settings?)

affects: unity (Ubuntu) → ubuntu
affects: ubuntu → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

in fact it seems rather a compiz integration bug

Didier, do you know if that's supposed to be working or could easily make to work?

affects: gnome-settings-daemon (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
importance: Undecided → Low
Didier Roche (didrocks) wrote :

Will have a look if it's easily feasable.

Changed in gnome-control-center (Ubuntu):
status: New → Triaged
Robert Roth (evfool) wrote :

Assigning the compiz task to didrocks as it was in bug #897829, marked as a duplicate of this one, as this has tasks for both compiz and control center, while the other only had for compiz.

Changed in compiz (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
El Samuels (wesamuels) wrote :

Bug exists for me since migration to 11.10; was able to assign key bindings (viz., Ctrl + Alt + 1 to move to workspace 1) fine in 10.04.

Tried changing bindings through System Settings, none entered are recognized.

N.B., was able instead to use Compiz Manager and enable "Put to adjacent viewport" to move windows to, well, the adjacent workspaces.

If I should post more info about this (or help in any other way), I'd be happy to.

Thank you all for your hard work making such a great system!

El Samuels (wesamuels) wrote :

P.S., Just noticed that since assigning bindings via Compiz, they showed up under "Custom Shortcuts" under System Settings>Keyboard as "Move Window Right" and "Move Window Left".

Don't know if that's utterly obvious and expected or helpful, but in case it's the latter, I figured I'd post it as well.

Didier Roche (didrocks) wrote :

this is now fixed in precise :)

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released

Sorry to say, Didier, but I'm still unable to assign a shortcut to it in 12.04. Can anyone confirm?

Paul (brandify) wrote :

Indeed, this doesn't appear to work still.

Changed in compiz (Ubuntu):
status: Fix Released → Triaged
Changed in gnome-control-center (Ubuntu):
status: Fix Released → Triaged

I can confirm this still seems to affect me in 12.04. Tried setting the shortcuts in cssm and using the keyboard settings in system settings.

Incidentally, if it is helpful in resolving, keyboard shortcuts to move windows right left up and down still work but moving to a specific workspace does not.

TomasHnyk (sup) on 2012-05-05
summary: - "Move window to workspace 1" shortcut doesn't work
+ Keyboard shortcuts set in Gnome Control Center - Keyboard do not have
+ affect if those same shortcuts are set in Compiz
Sparhawk (sparhawkthesecond) wrote :

Not sure if this is helpful, but for me I could not disable the "show the run command prompt" keyboard shortcut (I wanted to use gmrun). I went to ccsm and then I could disable it.

Changed in compiz-core:
status: New → Confirmed
Changed in compiz:
status: New → Confirmed
Didier Roche (didrocks) wrote :

This is fixed in precise and quantal :)

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
Changed in compiz-core:
status: Confirmed → Fix Released
Changed in compiz:
status: Confirmed → Fix Released
Gao Shichao (xgdgsc) wrote :

@Didier Roche (didrocks)

Quantal on my machine still has this bug, the shortcut to move window to a specific desktop doesn't work at all. Can you give any explanation why this bug has been marked as "fix released" ? Where exactly is the fix ?

Chris Ross (chris-ross) wrote :

@Didier Roche

Still not fixed for me on a new System76 gazp8 with the preinstalled Quantal. To reiterate, the default hotkeys "Move window to workspace left/right/up/down" work fine. But if I use the same hotkey (or any other hotkey) for "Move window to workspace 1/2/3/4" it doesn't work.

Multiple people are still reporting this, so perhaps it shouldn't be marked as fixed?

Nat Wilson (njwilson23) wrote :

One more data point. I am using a fully updated 12.04. This bug is not fixed. Switching the wordspace to 1/2/3/4 works; moving a window to a specific workspace does not.

Jesse Johnson (holocronweaver) wrote :

Still not working in Ubuntu 12.04 or 13.04. Following steps of bug reporter above still results in the same fail case.

This bug was first reported back in 2009 (see duplicates). It is a shame it has taken so long to properly fix.

This is still broken for me too.

Jesse Johnson (holocronweaver) wrote :

Devs, please mark this bug as not fixed.

Daniel Que (daniel2que) wrote :

Problem still exists. Using Ubuntu 12.04

Jesse Johnson (holocronweaver) wrote :

Still broken in latest Ubuntu 14.04 daily.

João Melo (joaolvcm) wrote :

it is still broken in ubuntu 14.04 final

A work-around (works for me, but barely a bug fix):
- Disable the shortcuts you set in step 3
- install compizconfig-settings-manager and compiz-plugins
- start compizconfig-settings-manager, go to "Window Management" and enable "Put"
- select Put and set your shortcuts in "Put to arbitrary viewport"
- select "Misc. Options"->"Unfocus Window"
- log out and in.

Jesse Johnson (holocronweaver) wrote :

I can confirm that this workaround is successful in Ubuntu 14.04. Thanks!

Also agree that we still need this fixed in Control Panel.

Didier Roche (didrocks) wrote :

reopening as mutiple people says they reproduce the issue nowdays.

Changed in compiz (Ubuntu):
assignee: Didier Roche (didrocks) → nobody
status: Fix Released → Confirmed
Paul Winkler (slinkp) wrote :

Still an issue in 16.04. Workaround in comment 24 https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/898087/comments/24 works for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers