"show desktop" shortcut needs to be hit twice to take effect

Bug #878057 reported by Ubugto on 2011-10-19
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Unity
Invalid
Undecided
Unassigned
compiz (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

When using the "show desktop" keyboard shortcut CTRL+ALT+D, it often takes two tries to get it to work.

This can be reliably reproduced by going to the desktop with the shortcut and opening a file from it. This brings all the windows back (which is a step back in terms of usability from the previous behaviour, by the way). Afterwards, the user needs to hit the "show desktop" shortcut twice to get the expected behaviour (hide windows). This may be due to "show desktop" not realizing that the windows have been already brought back by opening a file.

The error also occurs after not having used the shortcut before, but I have yet to figure out what causes it. The whole functionality is definitely somewhat buggy.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.22.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,regex,place,resize,session,mousepoll,imgpng,gnomecompat,grid,animation,unitymtgrabhandles,workarounds,vpswitch,move,snap,expo,wall,ezoom,fade,scale,unityshell]
CompositorRunning: compiz
Date: Wed Oct 19 11:49:54 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 280.13, 3.0.0-12-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation C79 [GeForce 9400] [10de:0867] (rev b1) (prog-if 00 [VGA controller])
   Subsystem: Apple Computer Inc. Device [106b:00ad]
JockeyStatus:
 xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 kmod:wl - Broadcom STA wireless driver (Proprietary, Disabled, Not in use) [auto-install]
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_173_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: Apple Inc. iMac9,1
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=b6b7c62f-8259-4d07-b894-2c5d1169126d ro splash quiet vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/27/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: IM91.88Z.008D.B08.0904271717
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F2218EA9
dmi.board.vendor: Apple Inc.
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 13
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F2218EA9
dmi.modalias: dmi:bvnAppleInc.:bvrIM91.88Z.008D.B08.0904271717:bd04/27/09:svnAppleInc.:pniMac9,1:pvr1.0:rvnAppleInc.:rnMac-F2218EA9:rvr:cvnAppleInc.:ct13:cvrMac-F2218EA9:
dmi.product.name: iMac9,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Ubugto (registrator) wrote :
Ubugto (registrator) wrote :

Also, when going to the desktop by using CTRL+ALT+D, opening a file, hitting CTRL+ALT+D twice to show the desktop again, then hitting it once more to restore the windows, the window controls are broken. Clicking on them will bring the window to the background, instead of closing/minimizing/maximizing it.

Kenneth Venken (kenneth-venken) wrote :

I can confirm this behavior.
A possible duplicate bug can be found here: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/878202

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: New → Confirmed
affects: unity → compiz
Changed in compiz:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
affects: unity (Ubuntu) → compiz (Ubuntu)
Anthony (abastardi) wrote :

I see the same problem in Ubuntu 12.04 Beta 2 64-bit.

Satish (satish-jeswani) wrote :

This bug is really frustating.I hope the next release of 12.04,which is 12.04.1, scheduled to be released in month of August solves this issue.

Daniel van Vugt (vanvugt) wrote :

No longer a duplicate of bug 91784. It's not the same.

affects: compiz → unity
affects: unity → compiz
Peter Harvey (pdqharvey) wrote :

12.10 64 bit:

I confirm the need to select 'Show Desktop' twice in order for it to function. In Quantal it's even worse, since Ctrl+Alt+D does not work any more, so you have to use the App-Switcher (twice!) just to get to the dektop.

Anyone know of a command to show the desktop, which could be assigned to a custom shortcut?

MC Return (mc-return) wrote :

@pdqharvey:
You can adjust the showdesktop settings in CCSM->General Options->Key bindings Tab->Show Desktop (sudo apt-get install compizconfig-settings-manager).
There you can choose a new shortcut, which will work (I got Super+D here).

Also you can choose a mouse shortcut to show the desktop, when touching the upper left corner for example.

Also on Quantal you can now choose a much fancier Show Desktop effect by enabling the plugin "Show Desktop" in CCSM (you need the compiz-plugins-extra package to be installed).

Also you can add a Show Desktop icon to the Launcher, see here for examples on how to do that:
http://handytutorial.com/ubuntu-12-04-12-10-show-desktop-unity-launcher/

Peter Harvey (pdqharvey) wrote :

@MC Return:
Very many thanks for that. I had just gone about it the laborious way, installing wmctrl and copying a script I came across* to be run from a keyboard shortcut, but this is definitely easier. I was congratulating myself that 'my' way did not need the key combination to be hit twice, but I see that sometimes it does. Very odd, but not so very important...

BTW, I missed it in the 'Keyboard Shortcuts' list because it has changed its job title from 'Show Desktop' to 'Hide all normal windows'.

PS: * script to toggle 'show desktop':
#!/bin/sh
if wmctrl -m | grep "mode: ON"; then
exec wmctrl -k off
else
exec wmctrl -k on
fi

Adam Niedling (krychek) wrote :

I have the same problem in Ubuntu 13.04. Also the behavior of the Show Desktop icon on the Launcher is also affected. Sometimes it has to be clicked twice.

MC Return (mc-return) wrote :

Well, this is not a Compiz bug, but a Unity one as Unity uses it's own showdesktop code (please do not ask me why, as I do not know) ;)

@all affected:

Simply use this workaround:
1. sudo apt-get install compiz-plugins compizconfig-settings-manager
2. Start CCSM and enable: "Show Desktop" (recommended for a cool window-slide-out-of-view-action, be sure to check the options)
3. Have fun :)

Changed in compiz:
status: Confirmed → Invalid
Changed in unity:
status: New → Confirmed
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
MC Return (mc-return) wrote :

&& please confirm that the workaround works... ;)

MC Return (mc-return) on 2013-07-06
Changed in compiz:
importance: Low → Undecided
Changed in unity (Ubuntu):
status: New → Confirmed
Alex Baggott (alex-baggott) wrote :

Thank you for taking the time to report this bug. We have tried to recreate this on the latest release of Ubuntu and cannot reproduce it. This bug is being marked as Invalid. If you believe the problem to still exist in the latest version of Ubuntu, please comment on why that is the case and change the bug status to NEW.

By the way, the keyboard shortcut is now Ctrl + Super + D.

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.