When Firefox is running in Unity, drop-down menus sometime close when opened

Bug #872207 reported by Michael on 2011-10-11
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Sam Spilsbury
Compiz Core
Sam Spilsbury
Unity Distro Priority
compiz (Ubuntu)
Canonical Desktop Experience Team
firefox (Ubuntu)

Bug Description

This is something which used to happen regularly though not always (I switched to using fallback mode for a while because of it). Basically, drop-down menus in Firefox such as RSS feeds (or in Natty without the global menu the normal application menus were affected too) are simply not shown when clicked on. Context menus also fail to appear. This often disappeared for no apparent reason after I had used Firefox for a while. I haven't seen it for a while, but it has just re-appeared, possibly because I started Unity as "unity --replace" since I am currently testing an application's behaviour with different window managers.

I'm sorry if this information is a bit threadbare. Please let me know if I can provide any additional helpful information.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.22.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64

ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,regex,snap,compiztoolbox,place,gnomecompat,resize,session,grid,mousepoll,animation,move,workarounds,imgpng,expo,wall,unitymtgrabhandles,vpswitch,fade,scale,ezoom,unityshell]
CompositorRunning: compiz
Date: Tue Oct 11 11:57:45 2011
DistUpgraded: Log time: 2011-09-08 12:02:24.781017
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: vboxhost, 4.1.4, 3.0.0-12-generic, x86_64: installed
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:040a]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Dell Inc. Latitude E6410
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=062b1769-7309-4422-a59c-ad30b109d53c ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-09-27 (14 days ago)
dmi.bios.date: 11/20/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 0667CC
dmi.board.vendor: Dell Inc.
dmi.board.version: A03
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd11/20/2010:svnDellInc.:pnLatitudeE6410:pvr0001:rvnDellInc.:rn0667CC:rvrA03:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6410
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.ia32-libs: ia32-libs 20090808ubuntu25
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Michael (michaeljt) wrote :
Michael (michaeljt) wrote :

This also prevents auto-completion drop-downs from appearing. Note - my Unity just crashed, and after I restarted it the problem was gone again.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: New → Confirmed
Domingos86 (domingos86) wrote :

Actually, it happens to me very often when I switch from one workspace to another using the keyboard shortcut Ctrl+Alt+Arrow. When I click, the menu shows up at first but immediately disappears once I roll the mouse over it.

Right now, to overcome it, I've been using Alt+Tab instead (which seems to work even when the target window is at a different workspace). With the workspace switcher from the unity launcher it seems to work fine as well.

Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

The issue often happens on launchpad has well and was discussed before with the firefox maintainer who said it's a compiz issue, giving focus to something else and back to firefox indeed workarounds it

affects: unity → compiz
Changed in compiz:
importance: Undecided → High
status: Incomplete → Confirmed
summary: - When Firefox is running in Unity, drop-down menus are not always shown
+ When Firefox is running in Unity, drop-down menus sometime close when
+ opened
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
Didier Roche (didrocks) wrote :

same with thunderbird sometimes

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed

I have a Sony Vaio Z13 and it happens with the intel card and the nvidia card. I found this:


But it doen't helped for me.

This has been a problem since Natty. I reported it in Bug #796897 which has just been marked as a duplicate of this one. As mentioned above it's some kind of issue with how compiz is giving focus to windows. (Some things are better in Oneiric - for example, in Natty I used to have the problem that the only way to give focus to the Contact List window in Empathy was to use the Alt-Tab switcher, but this is no longer a problem.)
I can't reproduce it every time I use Ctrl+Alt+Arrows and haven't figured out what triggers it exactly. Using the Unity launcher panel to select a window avoids the problem, but on a netbook with a trackpad and no mouse it's much easier to use the keyboard, and I keep Firefox maximised in its own workspace, so I see this at least a few times per day.

Changed in firefox (Ubuntu):
importance: Undecided → High

For me using unity launcher panel doesn't avoids the problem. It happens for me if I use multiple desktops. After switching from an desktop on which firefox is not running to firefox by clicking it in unity launcher (also by using keyboard shortcuts to switch desktop or windows) the context menu doesn't work, same for thunderbird. But it's not 100% reproducible it's happen around 50% of the tries to reproduce it.

Domingos86 (domingos86) wrote :

I confirm the previous reports. After using Ctrl+Alt+Arrow and having the window maximized on the target workspace the context menus and drop down lists will disappear in about 80% of the times (this percentage measures the times I switch the workspace and it happens, but when it happens it keeps happening until I use Alt+Tab to switch windows). Same problem with Thunderbird as well. Tried other software (empathy, libreoffice, nautilus) but no problem detected.

My chipset is NVIDIA Geforce 7025/nForce 630a, if it matters.

Chris Coulson (chrisccoulson) wrote :

Also note that the same type of steps which cause the problems with Firefox also seem to cause strange behaviour in other applications too (eg, bug 838625), which is also "fixed" by temporarily focusing another window.

Thane (byd) wrote :

I've been dealing with this one on not only my ubuntu 10.10 machine, but my parent's 10.04 machine in another house for months now. So I'm positive, this is not just personal settings on my machine, which are at fault. I have noticed the behaviour occasionally in Firefox. But its mainly a Thunderbird issue for me, when I try to delete junk/spam mail by right clicking on the Junk to access the drop down menu. The drop down menu then disappears, when I try to empty the junk. I'm presently now running the latest lubuntu and linux mint 12 releases in vbox and so far I've not noticed the erratic behaviour in their Thunderbirds (although that may just be temporary good fortune.) At first I thought the cause was related to the ubuntu Updates informing me, that updates were available for download, as that was when the problem occured. But thats not always the case now.

Changed in compiz (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Dave Russell (drussell) wrote :

This is also seriously affecting 11.10 on unity3d.

Other workarounds I've noticed is un-maximising firefox and re-maximising it. That seems to get things working for a while longer.

It eventually has the same problems again though.

I get this 20+ times a day.

Doug Morse (dm-dougmorse) wrote :


[This comment is a bit long. For those in a hurry, perhaps just read the "important part" set off below. :) ]

As with Dave Russell (comment #15), menus disappear for me constantly as well, both in Firefox and in Thunderbird. I'd say 20+ times an hour rather than 20+ per day.

Globalmenus work OK, but right-click and dropdown menus disappear all the time, by either flashing incredibly briefly and then disappearing or sometimes appearing but then disappear as soon as I move the mouse (oddly, using up/down arrow keys does work correctly in this latter case).

As with Domingos86 (comment #4), pressing Alt-Tab does seem to correct the problem. Unfortunately, unlike Dave (comment #15), unmaximizing then re-maximizing the effected window does _not_ work for me.


POSSIBLY IMPORTANT: Unlike Domingos86 (comment #15), best I can tell, I seem to _only_ have the problem when using either the workspace switcher (I use this rarely) or pressing my middle mouse button, which I have mapped to invoke the same Expo view (within the Compiz Expo plugin; I use this constantly). On the other hand, when using the 4 Ctrl+Alt+<arrow key> combinations, I have yet to observe the menus / dropdowns disappearing (I will certainly pay close attention to this and report back if I observe otherwise).

THUS, it might be that the initiation of the problem is localized to activating the Expo view (by whatever means) and then switching to a workspace with a Firefox / Thunderbird window. SO, I'm quite curious: Does anyone else besides Domingos86 encounter the problem _without_ going into Expo view shortly beforehand?


I personally keep only one maximized window, Firefox, on workspace 2 and only one maximized window, Thunderbird, on workspace 4. I say this to say: I wonder if another limiting factor might be that the Firefox / Thunderbird window has to be maximized and the topmost (i.e., top of the window z-order) for the problem to occur. Has anyone encountered this problem with Firefox / Thunderbird _not_ being maximized?

Thanks as always,

Dave Russell (drussell) wrote :

Interesting... I tend to use the unity sidebar to switch between applications, or occasionally alt-tab rather than expo.

I do get the problems when Firefox is *not* maximised, but they happen far more often when firefox *is* maximised.

I must admit I'd forgotten about this bug recently since I switched back to unity2d because it was so irritating, but I'm back in unity3d for a while to see if I can find out what's going on.

Dave Russell (drussell) wrote :

I should also add I tend to ctrl+alt+arrowkey to switch between workspaces because I run firefox on workspace1 and tbird on workspace2, irc on workspace3 and then other random stuff on workspace4.

I used to run everything maximised, but because of this bug I'm currently running nothing maximised. It does seem to lessen the issue... but it still happens a lot.

Doug Morse (dm-dougmorse) wrote :

Thanks Dave for your feedback -- I think the information is quite helpful.

So, just to be clear: You DO have this problem when switching workspaces with Ctrl-Alt-<arrow> (and hence never "zooming out" to Expo view)?

IOW, my present working hypothesis is that going into Expo view is essential to triggering the problem, but it sounds like you have evidence contrary to this supposition. Have I understood correctly?

Again, thanks!

Thane (byd) wrote :

For what its worth, I have this bug with mainly Thunderbird and very occasionally Firefox if I'm editing bookmarks. But I virtually never use more than one compiz workspace and still have the problems. Maybe I'm in the wrong bug report, but it doesn't seem in my case, like this is due to switching between compiz workspaces.

Doug Morse (dm-dougmorse) wrote :

@Thane: Thanks so much. This pretty much disconfirms my working hypothesis, at least for Thunderbird -- that going into Expo view is necessary to trigger the problem -- but disconfirmation is useful information nonetheless.

This seems to be a nasty bug in that I suspect it's going to be a hard one for the developers to nail down. It's specific to Mozilla software, and seems to be a bad Mozilla / Unity 3D / Compiz interaction, possibly also specific to certain video drivers (as not everyone has this problem -- 68 affected users is a lot, but I suspect small compared to the active Ubuntu user base who would take the time to report it).

So, the more we can do to narrow down the boundary conditions -- or define some usage case that _always_ causes the problem for all users affected -- the more we can help the developers isolate the problem (obviously). Unfortunately, I'm not sure what to suggest next, although one question does come to mind:

Is anyone having this problem with a _fresh_ install of Oneiric (11.10)? (I for one upgraded from a 11.04 fresh install to 11.10 on its release date.)

Domingos86 (domingos86) wrote :

My install isn't "fresh"

zzarko (zzarko-gmail) wrote :

This bug was one of main reasons that I stopped using Unity in 11.04 and went back to Gnome 2. After upgrade to 11.10, it kind of dissapeared, showing only occasionaly, but in the last couple of days (maybe after some of the updates) it became again very annoying. I minimize/maximize Firefox at least once in 20 minutes (or, when that doesn't work, close it and start again). It really goes on my nerves, but, alas, I cannot go back to Gnome 2, nor use Gnome Shell (it still has issues with my Radeon card). Unity 2D, last time I tried, didn't have all the features of 3D version (and I don't mean eye-candy). Mint (debian) anyone?

Didier Roche (didrocks) on 2011-12-02
Changed in unity-distro-priority:
status: New → Fix Committed
Doug Morse (dm-dougmorse) wrote :

@Domingos86: OK, good to know, thanks. Anyone out there having this disappearing menu problem based on a fresh (not upgraded) install of Oneiric (11.10)?

AndresClari (andresclari) wrote :

I've always had this problem on fresh installs. I'm have a bad habit of testing new distros every now and then ;) And for the last few releases of Ubuntu fresh, always the same problem. Thing is that is very random sometimes after a reboot it will work for a while, then start disappearing and so on. Probably more of a Compiz issue than Unity tho.

I get it on a fresh install, although I keep my firefox config files on a separate /home partition. (I do however delete the existing compiz config files before installing the new version.)

Doug Morse (dm-dougmorse) wrote :

@Andres and Sean: Most excellent, thanks. :) So, the disappearing menu issue is then not likely due to upgrade issues.

@Andres: I agree, I think that Compiz is definitely implicated. That this problem only occurs with Mozilla apps -- as far as anyone has reported -- seems to narrow it down to at least a Compiz-Mozilla interaction.

I'm beginning to wonder, since the compositing manager seems clearly implicated, if the problem might be related to (a) themes (doubt it, tho') or perhaps (b) transparent menus (which I have enabled with Ubuntu Tweak). I've disabled the latter and will report back if perhaps that corrects the problem.

Perhaps someone has never enabled transparent windows and/or only used default themes and yet still has the problem?

Anders Hall (kallebolle) wrote :

* I have upgraded through several versions were this problems is present (persist).

* I have manually removed all compiz settings files (e.g., when 3d unity crashes) removed all compiz libs with apt and reset/rebuilt compiz - at various dates/releases.

* I have enabled transparency at some versions. Though deleted settings (etc operations) between releases.

Very unlikely to relate to upgrades - if the problem is in compiz.

Unlikely to relate only to transparency settings since I have reset unity and compiz completely at times - after upgrades.

Not sure exactly when it started to happen for me.. prob. some time during the late 10 or early 11 version

. great work Doug :-)

Doug Morse (dm-dougmorse) wrote :

@Anders: Thanks, and thanks for your helpful input!

Disabling transparent menus did seem to help, in that I was able to work intently for about 2 hours w/o menus disappearing. This is a much longer period than I've experienced in recent times (menus typically disappear on me every several minutes; hence, my aggressiveness in trying to help "working the problem" :) ). I'm not sure this tells us much, but it seemed worth mentioning, and I promised to report back.

Sigh. I'm beginning to run out of ideas, short of compiling debug versions of compiz and firefox, and I just don't know if I'm for that anytime soon. :)

Thane (byd) wrote :

I seem to have stopped my Thunderbird menus from disappearing after right clicking on them, after having this problem on Thunderbird and sometimes Firefox for quite a while now. All I did was (in ubuntu 10.10) click on System-Preferences-Appearance-Visual Effects-None. Crossing my fingers, but after over two days now I've had a problem free Thunderbird. I would have normally had many occurances of the problem by now. Would there be some sort of Compiz settings configuration file, that I could post, which might have my old settings still and would help? I don't recall making any fancy changes to the settings. But maybe there's something there. If so what file would you need and where would it be found in 10.10? Cheers

Doug Morse (dm-dougmorse) wrote :

@Thane: This is potentially very helpful information, thanks!

I'm not entirely certain, but I think that selecting System -> Preferences -> Appearance -> Visual Effects -> None disables Compiz entirely, which, if so, would confirm that Compiz is implicated (which we already suspected). However, if changing this setting does NOT disable Compiz entirely, but only certain parst of it, then is could be quite helpful diagnostic information indeed, especially if changing the setting only effects a few aspects of Compiz.

So, does anyone know exactly what changing this setting does? Perhaps disable OpenGL w/in Compiz?

I'm pretty sure that in 10.10 and earlier, this meant running Ubuntu with Metacity as the window manager instead of Compiz (i.e. no compiz at all). I could be wrong though.

Anders Hall (kallebolle) wrote :

I think I had compiz on 10. It is perhaps not default?

Might narrow down your search Doug:

1) The right menu does appear - but vanishes quickly when the bug is active - i.e., it vanishes when the mouse/mouse pointer is moved on the screen. If you are careful you can always access the right menu by using arrow keys instead of mouse. So it probably related to mouse interaction in some way, right?

2) My guess is that the right menu either times out or is removed when another event occurs. Cant these events be logged (for instance how long is the menu in display, if it is removed too fast it might be related to this bug)?

Doug Morse (dm-dougmorse) wrote :

@Sean: Thanks for the input and yes, that's my recollection, too. I read through Thane's post so quickly I missed that he's still on 10.10. and that there's is no such setting in 11.04 / 11.10.

Doug Morse (dm-dougmorse) wrote :

@Anders: Very helpful, input -- thanks!

I'm 99% certain that both Thunderbird and Firefox render their menus with Javascript -- this is how plug-ins / add-ons are able to change the contents of menus -- and this is rather unique when compared to most other Linux apps. So, thanks again for the tip: I think you have indeed help me narrow down a good path to investigate further.

Thane (byd) wrote :

Hi guys;
     I had one other thought. Yes I am using ubuntu 10.10. But I am also using Linux Mint 12 Gnome RC and Lubuntu 11.10 Desktop amd64 on virtualbox, trying them out to see if I might prefer them for my next OS. My emails that come in to my ubuntu 10.10 are also present, when I check my email in Thunderbird on lubuntu and mint (I installed Tbird on lubuntu.) In neither of those systems do I have the disappearing menus in Thunderbird - at all. Somehow those systems seem immune. Doesn't seem likely to me, since they are both ubuntu-based. However this does seem to be the situation and I've been using both of them for about 2 weeks now.

Tim Penhey (thumper) wrote :

I believe that Sam may have fixed this bug already.

Thane - neither LDXE nor Gnome Shell run compiz, so it's not surprising that you don't see it there.

Doug Morse (dm-dougmorse) wrote :

@Tim: Fantastic! It'd be great to get confirmation of that, as well as I for one am quite curious as to what the problem was and where it resided (e.g., Compiz, Mozilla, both, something else?). In hunting around for a fix, I noticed similar problems have been reported on other (non-Linux) platforms, but I don't recall the symptoms being exactly the same.

Thane (byd) wrote :

Thanks for the info Sean. Maybe thats one more small reason for me to settle on Mint for my next installation in a couple of weeks or so. Hope this problem has been or will shortly get sorted though. Cheers

zzarko (zzarko-gmail) wrote :

Currently, on my machine it's very deterministic, every time I use CTRL+ALT+Cursor keys to switch workspaces, Firefox menus start to disappear (I can re-enable them by minimizing and maximizing). And it's not just menus, all drop-down lists, including awesome bar functionality (I cannot search history, because there isn't history drop-down list), also don't work. If I use ALT-TAB to switch between applications on different workspaces, menus don't disappear (I'm not sure for this; I'll try to use ALT-TAB exclusively to see if this is true). The problem is that I often use CTRL+ALT+Cursor keys (and the answer that I just don't use them I don't consider as an answer).

zzarko (zzarko-gmail) wrote :

Small clarification: every time I use CTRL+ALT+Cursor keys to switch workspaces, when switching from/to Firefox window, menus start to disappear. If I move away from Firefox with ALT+TAB and then use CTRL+ALT+Cursor, avoiding Firefox's workspace, and return to it with ALT-TAB, menus work.

Vishnu V (vvishnu-e) wrote :

Whenever the bug occurs . just minimize and then restore firefox. Then menu works

Anders Hall (kallebolle) wrote :

This bug seemed (probably was) resolved for me until I got Firefox 9 recently, when it reappeared.

Domingos86 (domingos86) wrote :

I have firefox 9 and it still happens to me, but apparently not as frequently.

Sam_ (and-sam) wrote :

Randomly with firefox 10+ on precise.

tags: added: precise
James (bistromathic1) wrote :

For me, the bug appears at random (firefox 9, oneiric). Any menus only stay open until I move the mouse; switching to another window and back generally seems to stop it. I have noticed a couple of other things that might be relevant, though.

Firstly, I use firefox's autoscroll feature (preferences->advanced->browsing). Normally, when I middle click, the autoscroll icon appears, then doesn't disappear until I click again, but whenever the menu bug occurs, the autoscroll icon disappears (and autoscrolling stops) if I point at the autoscroll icon. As far as I can see, the two issues always happen together.

Secondly, when I open a new window using tkinter in a python application, any open firefox and thunderbird menus close - menus in other applications I have tried are unaffected.

For example, the following python 3.x code (replace tkinter with Tkinter for python 2.x) simply opens a window, waits a second, closes the window, waits a second, and repeats. Every time the window opens, open firefox and thunderbird menus close, regardless of whether this bug is in effect.

from tkinter import Tk
from time import sleep
while True:
    tk.after(1000, tk.destroy)

Doug Morse (dm-dougmorse) wrote :

On 2011-12-05 (Comment #37) Tim Penhey (thumper) wrote:
> I believe that Sam may have fixed this bug already.

Any further word on this? It's been over a month since Tim wrote this, and I still have to deal with this issue constantly re: menus either never appearing or disappearing immediately upon the slightest mouse movement. In direct contrast to zzarko (Comments #42 and #43), I do _not_ seem to have the problem when using CTRL-ALT-<Arrow> to switch workspaces, but rather when I enter Expo VIew to switch workspaces.

I understand the holidays slow things down and all, and I appreciate that most of the work is voluntary, but it'd be nice to have some information re: is the problem really fixed and, if so, what's at the root of it, when we can expect an update to correct it, and will the fix appear in ubuntu-backports or will we need to upgrade to Precise.

Thanks as always. --Doug

Hey folks,
Take a look at Bug #896762 and see if that resolves things for you.
It sounds plausible enough and since I've updated I haven't had problems.

Doug Morse (dm-dougmorse) wrote :

@Sean: Thanks for the tip re: upgrading Compiz from oneiric-proposed (c.f., Bug #896762).

I've done so (i.e., upgraded Compiz) and, although so far the problem seems to occur less often, for me at least it FAR from fixes it. Of course, my version of the problem occurs more (perhaps exclusively) when I go into Expo view (either by mouse button or keyboard shortcut) and occurs less -- or perhaps not at all, I'm not sure -- when I use Ctrl-Alt-<Arrow> to change workspace. [This is in contrast to other folks who seem to have the problem under the opposite conditions (i.e., menus disappear more when switching with Ctrl-Alt-<Arrrow>, but not so much or at all when switching viz a viz Expo view).] Bug #896762 is specifically in reference to switching with Ctrl-Alt-<Arrow>, so I guess, given the form in which I'm experiencing the problem, it's perhaps not surprising this upgrade did not fully work for me so.

So, at least for one user (me), the problem remains UNRESOLVED.

Thanks, --Doug

Domingos86 (domingos86) wrote :

I also upgraded compiz from oneiric-proposed and it hasn't solved anything. Menus keep disappearing after I do CTRL+ALT+Arrow

Yeah, it was too good to be true, I guess. Things seemed better for a few hours but today I'm experiencing the same problems as before.

Tom Haddon (mthaddon) wrote :

I'm still experiencing this issue on precise.

psypher (psypher246) wrote :

I am running unity 5.2 on precise and this issue is solved for me

Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority

On 02/19/2012 07:34 PM, Tim Penhey wrote:
> ** Tags added: distro-priority
Thanks, the problematic site works on Chromium. I need the site more
than I need Firefox.

Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
Doug Morse (dm-dougmorse) wrote :

@Sam: Any word on this re: firefox/thunderbird menus not appearing of disappearing after workspace switching? It's been 4 months since the first report on this issue without any resolution or workaround, and it's a constant irritation. I appreciate that most of the work here is voluntary contributed time -- and I'm happy to debug / code / contribute as well (as I'm very motivated to see this fixed) -- but communication is obviously essential for community-driven software and there's been very little feedback re: who's taken ownership of this issue, what they've tried and discovered, what should be tried next, and so forth. I'd love to help, but don't want to duplicate effort, and a little guidance on where to start would be most helpful. I'd hate to see this issue persist into 12.04, especially since it will be a LTS release.

Thanks, --Doug

Anders Hall (kallebolle) wrote :

This right click problem happens frequently for us (several users). It might related to more than firefox. I get the same/similar problem when using other programs too (one on a daily basis).

TortoiseHg (phyton i think) have problem with right clicks too... cant say for sure if it is related. However, it is very easy to reproduce.

Love to help out also... any good (fast) guides for setting up debugging environments for unity/ubuntu - related to desktop cases?? For instance for capturing events/exceptions /warnings etc while i use the computer?

A dream would be a "one-click debug environment" :-)

Anders Hall (kallebolle) wrote :

Important note.. the other guys here not using Unity, though using other types of Ubuntu, are NOT experiencing these kind of problems reg. right click.

Other programs affected by this (or a similar) issue are editors like Kile and TexMaker for LaTeX. I've noticed this with both programs: maximize the window, use Ctrl-Alt-Arrows to navigate away (perhaps to look something up) and then return. The window won't be properly focused, meaning that it won't accept further text input until re-focused.
If the window is not maximized I can usually regain focus by clicking on the text area.

@Doug, I'm not into development, but I believe the right place to interact with developers is at the appropriate IRC channels for the different teams, you can get (in my experience) a fast exchange on any issue with them overthere. I don't think there is usuarlly much interaction of that type here in a bug report.

@Sean, I experience the same problem as you, with texmaker and gedit. Happens only after I change workspace with ctr-alt-arrows, but quite randomly.

Didier Roche (didrocks) wrote :

We are not seeing anymore issues since the update to Unity 5.6 and latest compiz. Did anyone still experience it?

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
Changed in firefox (Ubuntu):
status: Confirmed → Incomplete
affects: compiz → compiz-core
Changed in compiz-core:
status: Confirmed → Incomplete
Borim (borim) wrote :

I can not tell for Unity 5.6, but with the current Oneiric version it still happen. To be more precise Unity 4.28.0-0ubuntu2 and Compiz 1:0.9.6+bzr20110929-0ubuntu6.1

I would be grateful, if this bug get fixed for Oneiric ;)

Anders Hall (kallebolle) wrote :

Can confirm on Unity 4.28.0-0ubuntu2 and Compiz 1:0.9.6+bzr20110929-0ubuntu6.1

Charles Kerr (charlesk) wrote :

Running unity 5.8.0 here, I haven't seen this bug in months but used to encounter it literally daily.

Fixed IMO

Chris Coulson (chrisccoulson) wrote :

Indeed, this doesn't seem to be an issue now in Precise. Does anyone have any idea what fixed it? It would be a shame to leave it unfixed in oneiric too

Changed in unity-distro-priority:
status: Fix Committed → In Progress
status: In Progress → Fix Committed
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → High
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

Closing since that seems fixed in precise

Changed in compiz (Ubuntu):
status: Incomplete → Fix Released
Changed in compiz-core:
status: Incomplete → Fix Released
Changed in compiz:
status: Incomplete → Fix Released
Changed in firefox (Ubuntu):
status: Incomplete → Invalid

It's a whole lot less frequent on Precise, but it happened again here yesterday :(

Sebastien Bacher (seb128) wrote :

are you sure it's the exact same bug described here? could you describe what you did and what happened? do you use unity3d?

Well, the same symptoms as I was getting (a lot more frequently) on Oneiric. I only regraded this machine to Precise last week.

We use the Cookie Swap extension, which has a popup menu to facilitate swapping between cookie sets. Clicking on the toolbar item to trigger the menu exhibits the same symptoms as this described in this bug. When this particular menu has been exhibiting these symptoms in the past, I also noticed other Firefox menus suffering from the same fate. Though yesterday evening I did not test any other menus, I just went for the workaround.

The same workaround worked: dragging the Firefox window from Maximized and releasing it (and then re-Maximizing it and continuing to browse as normal).

So I'm fairly sure this is the same bug. Obviously if (when) it happens again, I'll try to remember to test other menus and post the results.

Oh, sorry. Yes to unity 3D. Gotta love Compiz :¬)

bartje (bart-deruyter) wrote :

I have a similar problem, right clicking shows a menu, but the menu's are unresponsive. Clicking on the shown options doesn't do anything. Running ubuntu 12.04, firefox 12. Running in KDE it works fine. I'm not sure if it's the same issue, but it seems like it is.

Sebastien Bacher (seb128) wrote :

@bartje: that doesn't seem a similar problem no, in the case of this bugs the menus are closed, they are not shown and unresponsive

Didier Roche (didrocks) on 2012-12-11
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Carl Michael Skog (cmskog) wrote :

When will this fix be released ?

At least in 11.10, the bug is extremely prevalent.
I would estimate the probability of running into it as 60-70% 11.10, when e.g. changing search engine in Firefox, or droping down a menu in the "Bookmarks Toolbar".

Stephan Diestelhorst (syon) wrote :

I am experiencing a similar issue on Ubuntu 12.04.2 LTS with KDE 4.10 installed and Firefox 20.0a2 (2013-02-10) (Aurora). After a while, right-click menus and those from extension will just draw a frame briefly and then disappear. Toggling HW accel in both Firefox, and kwin din not help. Also, starting Firefox with an empty profile did not help either.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions