Shortcuts not recognized on attempt to switch workspace after closing an application window

Bug #871277 reported by Sam_ on 2011-10-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Happens with conky either enabled
- own_window_type normal
or
- own_window_type desktop

Setup is unity with wall-plugin.

Test case.
Open a terminal window.
Switch to different workspace.
Open gedit.
Close gedit via window button or alt+f4.
Switch workspace back to terminal with ctrl+alt+arrow left (or wherever terminal window resides).
Result: nothing happens, although global menu shows desktop has focus.
Workaround: Left click on desktop or conky enables to switch workspace.

Expected.
Recognize shortcuts and switch workspaces, don't interfere with conky setup.

## Similar unexpected behaviour described in Bug #851989 - please ign, this is fixed.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: compiz 1:0.9.6+bzr20110929-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,obs,grid,gnomecompat,vpswitch,mousepoll,wall,compiztoolbox,move,resize,place,imgpng,snap,regex,animation,expo,session,screenshot,unitymtgrabhandles,ezoom,fade,winrules,workarounds,scale,unityshell]
CompositorRunning: compiz
Date: Sun Oct 9 14:22:08 2011
DistUpgraded: Log time: 2011-07-30 23:24:18.623159
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 3.0.0-10-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.0.0-11-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.0.0-12-generic, x86_64: installed
GraphicsCard:
 ATI Technologies Inc M880G [Mobility Radeon HD 4200] [1002:9712] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:1475]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
MachineType: Hewlett-Packard HP 625
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=C
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=4a760393-cea9-45d3-88c0-841b7a37104d ro
SourcePackage: compiz
UpgradeStatus: Upgraded to oneiric on 2011-08-01 (68 days ago)
dmi.bios.date: 12/07/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68DVA Ver. F.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1475
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 72.0E
dmi.chassis.asset.tag: CNU1080QP1
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68DVAVer.F.06:bd12/07/2010:svnHewlett-Packard:pnHP625:pvr:rvnHewlett-Packard:rn1475:rvrKBCVersion72.0E:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP 625
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Sam_ (and-sam) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Sam_ (and-sam) on 2011-12-09
description: updated
Sam_ (and-sam) wrote :

Different outcome on desktop-pc.
Setup: unity with cube-plugin, focus follows mouse and conky.
compiz 1:0.9.6+bzr20110929-0ubuntu6

Open a terminal window.
Switch to different workspace.
Open gedit.
Close gedit via window button or alt+f4.
Switch workspace back to terminal with ctrl+alt+arrow left (or wherever terminal window resides).
Result: nothing happens, global menu still displays 'gedit' as focused, although it's closed.
Workaround: switch workspaces with mouse wheel. (left click on desktop doesn't help in this scenario.)

Switching workspaces is possible when firefox was in full screen mode, closing it allows to switch workspace via shortcut.
After closing gedit in full screen mode it doesn't allow to switch workspace via shortcut.

Another test-case:
Open a terminal and gedit on the same workspace.
Gedit has focus on top of terminal.
Close gedit, leaving terminal window open allows to switch workspace via shortcut.

Sum.
After closing a window leaving only the desktop it isn't possible to switch workspaces via shortcut.
Except after closing firefox in full screen mode.
After closing one window, leaving another open it's possible to switch workspaces via shortcut.

Sam_ (and-sam) on 2011-12-14
description: updated
Sam_ (and-sam) wrote :

Tested with Precise.
Still interferes with conky 'window_type normal'.
After closing e.g. gedit, the desktop doesn't get automatically focus, it needs a left click in order to focus the desktop, then switching the workspace via shortcut is possible.

I'd expect desktop gets focus after closing an application in order to switch workspaces via shortcut.
In guest-session it works as expected, but of course conky isn't running there.

compiz:
  Installed: 1:0.9.6+bzr20110929-0ubuntu8
  Candidate: 1:0.9.6+bzr20110929-0ubuntu8
  Version table:
 *** 1:0.9.6+bzr20110929-0ubuntu8 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Sam_ (and-sam) wrote :

Addendum regarding #3
setup:
desktop-pc
unity with cube-plugin, focus follows mouse and conky window_type normal.
compiz 1:0.9.6+bzr20110929-0ubuntu6

Workaround after closing an application window, left click on conky (instead of desktop) allows shortcuts in order to switch workspaces.

Sam_ (and-sam) on 2011-12-24
description: updated
Sam_ (and-sam) wrote :

There is different focus management.
Setup: laptop, unity and wall-plugin, conky window_type normal.
By left click on conky global menu says 'desktop' or 'workspace' (can use both terms when translated from german 'Arbeitsfläche'.)

Setup: desktop-pc, unity and cube, conky window_type normal.
By left click on conky global menu says 'conky'.

Sam_ (and-sam) wrote :

Recent Oneiric update of unity 4.28.0-0ubuntu2 fixed the focus issue.
Now it's possible to close an application and without mouse click intervention it accepts shortcut ctrl+alt+arrow in order to switch the workspace. After closing an application global menu automatically toggles to 'desktop'.
Thank you.

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers