Comment 181 for bug 862430

Soos Gergely (sogerc1) wrote :

I do agree with some of the stuff that had been said in the previous comments (mainly because the bug report is more than 1 year old and affects two releases) but let's not forget that life is not that simple. If you take the time to check it you can see that a lot of bugs must be fixed before 0.9.7.10 can be released, and most of them already are. In the meantime we just have to be patient and maybe use the vanvugt PPA, which is by the way up again (thanks Daniel). Others can do what s.ray did, and use something else. I myself have never liked gnome. I stick with KDE+Compiz+Emerald which is sometimes hard to put together but imho it's state of the art.

Enough philosophy. The reason of my comment is that some time ago we were talking about holding packages to a specific version to prevent upgading to a version that still has the bug. While that works, it's not the best solution, so I thought I should prioritize the vanvugt PPA. Because I'm no expert it took me quite a while to put these few lines together so I thought I'd share it with anyone who's in the same boat as I am:

/etc/apt/preferences :

Package: *
Pin: release o=LP-PPA-vanvugt-compiz-preproposed
Pin-Priority: 1001

You've gotta love APT! I work with RPM based systems too but nothing beats debian.