Comment 172 for bug 862430

I am writing to confirm that after allowing Ubuntu 12.04 to upgrade I experience exactly the
same error as mia1dolfan (mia1dolfan). When this took place Unity did not work correctly
and all of the menu bars, etc. were not visible. I can also confirm that mia1dolfan (mia1dolfan)'s
suggestion for resolving the problem does return Unity to a usable state. However, now I am
back to the flickering screen that takes place when I run the Expo plugin in Ubuntu 12.04. Note
that I can no longer correctly use the unmaintained PPA that previously solved the problem.

At this point, is the only way to resolve this problem to upgrade to Ubuntu 12.10?

What is the timeline for having the fix appear in Ubuntu 12.04?