compiz crashed with signal 5 in Glib::exception_handlers_invoke()

Bug #808007 reported by Nicholas Allam on 2011-07-09
458
This bug affects 64 people
Affects Status Importance Assigned to Milestone
Compiz Core
Medium
Alan Griffiths
compiz (Ubuntu)
Medium
Unassigned

Bug Description

11.10
Happened jut after restarting from first update install

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: compiz-core 1:0.9.4+bzr20110606-0ubuntu6
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic i686
Architecture: i386
Date: Sat Jul 9 15:46:45 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: compiz
StacktraceTop:
 Glib::exception_handlers_invoke() () from /usr/lib/libglibmm-2.4.so.1
 Glib::Source::dispatch_vfunc(_GSource*, int (*)(void*), void*) () from /usr/lib/libglibmm-2.4.so.1
 g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: compiz crashed with signal 5 in Glib::exception_handlers_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
Nicholas Allam (njallam) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 glibmm_unexpected_exception () at exceptionhandler.cc:71
 Glib::exception_handlers_invoke () at exceptionhandler.cc:150
 Glib::Source::dispatch_vfunc (callback=0x8e9dc0 <(anonymous namespace)::glibmm_dummy_source_callback(void*)>, user_data=0x8b1f4a0) at main.cc:896
 g_main_dispatch (context=0x8a71cc0) at /build/buildd/glib2.0-2.29.10/./glib/gmain.c:2473
 g_main_context_dispatch (context=0x8a71cc0) at /build/buildd/glib2.0-2.29.10/./glib/gmain.c:3046

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
tags: added: compiz-0.9
visibility: private → public
Changed in compiz (Ubuntu):
status: New → Confirmed
Revision history for this message
Francesco Muriana (f-muriana) wrote :

This bug has happened to mee too (more than once) on 12.04 Precise x64

Revision history for this message
matthew symes (matt-symes) wrote :

Me also on 12.04 Precise x64.

tags: added: bugpattern-needed
tags: added: apport-request-retrace
Revision history for this message
Apport retracing service (apport) wrote : Updated stack trace from duplicate bug 955096

Package: compiz-core 1:0.9.7.0+bzr3035-0ubuntu1
ProcCmdline: compiz

Revision history for this message
Apport retracing service (apport) wrote : Dependencies.txt
Revision history for this message
Apport retracing service (apport) wrote : ProcMaps.txt
Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
tags: removed: apport-request-retrace
Revision history for this message
Petr Herynk (pherynk) wrote :

Compiz crashed continuously after start system.

Changed in compiz (Ubuntu):
status: Confirmed → In Progress
Changed in compiz (Ubuntu):
assignee: nobody → Alan Griffiths (alan-griffiths)
Revision history for this message
MarkS (mark-marksyms) wrote :

I can't believe this is only medium importance. Compiz dies every time I right click thus rendering a lot of operations completely impossible to execute.

Revision history for this message
Kalsan (info-kalsan) wrote :

I agree. This should be changed to high importance.
Mark: Disable the ring switcher, that saves your nerfs while they're fixing it :-)

Revision history for this message
pablomme (pablomme) wrote :

@Kalsan: thanks for the tip. The Shift Switcher also seems to be causing the right-click problem.

The problem with this bug report is that is corresponds to a crash with the same error message but under different conditions and with a different compiz version, whereas the right-click problem is in fact a regression in the last compiz upload to precise (compiz 1:0.9.7.0+bzr3035-0ubuntu1). All duplicates after and including #953228 refer to this version of compiz.

Revision history for this message
Nick Barcet (nijaba) wrote :

Clearing my compiz settings did solve the problem for me:
gconftool-2 --recursive-unset /apps/compiz-1

Revision history for this message
MarkS (mark-marksyms) wrote :

Thank you all, it does appear to have been the shift switcher in my case, now disabled.

Revision history for this message
aloctavodia (aloctavodia) wrote :

I tried nick´s suggestion (gconftool-2 --recursive-unset /apps/compiz-1) and now I don´t have unity (even after reinstalling unity and compiz) I have Unity-2d

Revision history for this message
Nick Barcet (nijaba) wrote : Re: [Bug 808007] Re: compiz crashed with signal 5 in Glib::exception_handlers_invoke()

On 03/17/2012 05:17 PM, aloctavodia wrote:
> I tried nick´s suggestion (gconftool-2 --recursive-unset /apps/compiz-1)
> and now I don´t have unity (even after reinstalling unity and compiz) I
> have Unity-2d

What is happening when you select Unity at the login screen? Crashes?
Nothing?

Revision history for this message
Alan Griffiths (alan-griffiths) wrote :

I can't prove that all instances of this fault have the same cause, but there is an issue that the shift switcher exposes when right click is processed.

There's a fix committed by Łukasz to the shift switcher to remove an unused "Terminate" option, and I'm working on core to prevent plugins that expose options that don't exist causing a crash.

If you see this problem with other plugins let me know.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3060

Changed in compiz-core:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Alan Griffiths (alan-griffiths)
status: In Progress → Fix Committed
milestone: none → 0.9.7.2
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: Fix Committed → In Progress
assignee: Alan Griffiths (alan-griffiths) → nobody
status: In Progress → Confirmed
Changed in compiz-core:
status: Fix Committed → Fix Released
Revision history for this message
ltbrunt (daytomay) wrote :

Unity always restart and runs at login. After logging in unity is just very slow. I ran command in terminal unity --reset. Everything is now working fine. I believe that this has something to do with the nvidia 7100. I do not receive the unity slowness issue workstations with nvidia 8400, AMD HD 5000, 4000, think pad t42.

Courtney Benton

On Mar 19, 2012, at 4:54 AM, Nick Barcet <email address hidden> wrote:

> On 03/17/2012 05:17 PM, aloctavodia wrote:
>> I tried nick´s suggestion (gconftool-2 --recursive-unset /apps/compiz-1)
>> and now I don´t have unity (even after reinstalling unity and compiz) I
>> have Unity-2d
>
> What is happening when you select Unity at the login screen? Crashes?
> Nothing?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (955644).
> https://bugs.launchpad.net/bugs/808007
>
> Title:
> compiz crashed with signal 5 in Glib::exception_handlers_invoke()
>
> Status in “compiz” package in Ubuntu:
> In Progress
>
> Bug description:
> 11.10
> Happened jut after restarting from first update install
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: compiz-core 1:0.9.4+bzr20110606-0ubuntu6
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic i686
> Architecture: i386
> Date: Sat Jul 9 15:46:45 2011
> ExecutablePath: /usr/bin/compiz
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
> ProcCmdline: compiz
> ProcEnviron:
> LANGUAGE=en_GB:en
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> Signal: 5
> SourcePackage: compiz
> StacktraceTop:
> Glib::exception_handlers_invoke() () from /usr/lib/libglibmm-2.4.so.1
> Glib::Source::dispatch_vfunc(_GSource*, int (*)(void*), void*) () from /usr/lib/libglibmm-2.4.so.1
> g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
> ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
> g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
> Title: compiz crashed with signal 5 in Glib::exception_handlers_invoke()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/808007/+subscriptions

Revision history for this message
DrPaulaner (dr-paulaner) wrote :

crashes in 12.04 last update when using right mouse buttom. reproducable

Revision history for this message
Sasja de Vries (sasja-de-vries) wrote :

^^ dr-paulaner
just what I had, but if you use ctrl+rightclick it will give you a context menu.

my pc can't login, I can but without the taskbar. so I can only boot in recovery mode,
I tried gnome classic mode and it has no taskbar; ubuntu 2d -no taskbar; recovery -no taskbar(logic, it's command line)

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.2-0ubuntu1

---------------
compiz (1:0.9.7.2-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream snapshot:
    - Fix global menu not being ergonomical on large screens (LP: #682788)
    - Fix Alt+Right arrow key (LP: #943612)
    - Fix key bindings for actions while doing tap detection (LP: #944631)
    - Window movement is erratic and buggy, backport (LP: #923683)
    - CompScreenImpl::addAction(CompAction*): Assertion `priv->initialized'
      failed (LP: #946118)
    - gtk-window-decorator crash with SIGSEGV in max_window_name_width()
      (LP: #937815)
    - Finish the implementation of the locally integrated menubars
      (LP: #931245)
    - Unity/compiz intercepts keystrokes from grabbed windows (LP: #806255)
    - Pressing alt doesn't show the menu title bar in top panel (LP: #943194)
    - Fix Alt stealing focus from widgets (LP: #943851)
    - Fix Alt + drag (LP: #945373)
    - lp:compiz-core fails parallel builds (make -jN) (LP: #938417)
    - Changing the HUD shortcut disables all Alt-based combinations. And
      changing the Dash shortcut disables all Super-based shortcuts
      (LP: #945816)
    - Fix key bindings (such as Super) not working on empty workspace or on
      slow/loaded systems (LP: #953089)
    - compiz crashed with signal 5 in Glib::exception_handlers_invoke()
      (LP: #808007)
    - Fix segfault caused by r3043 (LP: #958540)
  * Removed cherry-picked patches:
    - debian/patches/fix_806255.patch
    - debian/patches/fix_923683.patch
    - debian/patches/fix_943194.patch
    - debian/patches/fix_944631.patch
    - debian/patches/fix_alt_pressing.patch
    - debian/patches/additional_alt_tapping_fix.patch

  [ Didier Roche ]
  * pick upstream fix, debian/patches/fix_953839.patch:
    [regression] Invisible resize border is now only 1px wide (LP: #953839)
  * debian/patches/revert_lim.patch:
    - revert the integrated menu patch. It won't be released in precise and
      triggers a regression (in bug #962085)
  * debian/patches/fix_953089_2.patch:
    - second trial to fix remaining corner cases
  * debian/patches/exit_1_if_composite_cant_init.patch:
    - try to workaround a crasher which seems to happen when the composite
      plugin failed to initialize. Hopefully exiting 1 will make gnome-session
      respawning compiz and then the init will work. (LP: #833729)
  * debian/patches/always_replace.patch:
    - right now, always replace the current WM as it seems that some people
      got another compositor running at the start of the session. This will
      hopefully workaround the issue that some people experience.
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 09:13:51 +0100

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.