Wrong windows position on reopening

Bug #777299 reported by skalka on 2011-05-04
76
This bug affects 24 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Some windows have a strange behavior, while reopened they shift right on the screen, it seems to happen with windows that don't have a fixed position. To reproduce this bug just start for example Empathy from Messaging Menu than close it to tray, when reopened it will be some pixels shifted on the right and after various iterations it goes of screen. I've noted the same behavior with Gwibber, Skype (right and bottom shifted), Gwibber. This doesn't happen with Ubuntu One or with the Terminal (I assume that it's due to their forced position).

I'm running a fully upgraded Natty with Compiz active, this bug is present even with classic interface (effects active). Everything works just fine with Metacity.

skalka (skalka) wrote :

Behavior is different and it depend on different programs. Empathy and Gwibber go off screen. Skype, Nautilus, Transmission end their run on the right border.

Changed in compiz (Ubuntu):
status: New → Confirmed
Achim (ach1m) wrote :

This problem is not reproducible for me on Oneiric.

compiz:
Installed: 1:0.9.5.92+bzr2791-0ubuntu1
Candidate: 1:0.9.5.92+bzr2791-0ubuntu1
Version table:
*** 1:0.9.5.92+bzr2791-0ubuntu1 0
500 http://archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
100 /var/lib/dpkg/status

If someone else can confirm this, I think we can mark this bug as fixed.

Kieran Hogg (xerosis) wrote :

It's still there for me on Oneiric.

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

This issue should have been fixed on later versions of compiz.

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
Achim (ach1m) wrote :

I can't reproduce this bug any more. Thanks for fixing it.

compiz:
  Installiert: 1:0.9.9~daily13.04.10-0ubuntu1
  Installationskandidat: 1:0.9.9~daily13.04.10-0ubuntu1
  Versionstabelle:
 *** 1:0.9.9~daily13.04.10-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

Changed in compiz (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers