compiz no longer able to drive my external monitor on upgrade to 11.04; does not recover

Bug #776565 reported by Christopher Barrington-Leigh on 2011-05-03
This bug affects 17 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)

Bug Description

Binary package hint: compiz

I upgraded from 10.10, under which my Lenovo T410s has had no trouble running, autodetecting, etc, an extended desktop over the laptop and an external LG Flatron W241T.

In fact, if the external monitor is plugged in when the computer boots, the login screen won't even come up!
And if I log in with it not plugged in, and then plug the monitor in once logged in, compiz freaks out trying to talk to it (it auto-detects the plugging-in event, so I don't need to bring up a Display dialog), and fails to come back. If I then unplug the monitor to try to recover, I get a blank screen, with a cursor but no activity. I have to reboot.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.4+bzr20110415-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic
Uname: Linux 2.6.38-9-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
 status: disconnected
 enabled: disabled
 dpms: Off
 status: disconnected
 enabled: disabled
 dpms: Off
 status: disconnected
 enabled: disabled
 dpms: Off
 status: disconnected
 enabled: disabled
 dpms: Off
 status: disconnected
 enabled: disabled
 dpms: Off
 status: disconnected
 enabled: disabled
 dpms: Off
 status: connected
 enabled: enabled
 dpms: On
 modes: 1440x900 1440x900
 status: disconnected
 enabled: disabled
 dpms: Off
Date: Tue May 3 09:56:04 2011
DistUpgraded: Log time: 2011-05-02 16:47:24.190283
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: vboxhost, 3.2.12, 2.6.35-29-generic, x86_64: installed
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21c1]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: LENOVO 2901CTO
PackageArchitecture: all
 PATH=(custom, user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-9-generic root=UUID=d0016fa3-07cc-4d97-b503-70b7398d0e72 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-9.43-generic
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: Upgraded to natty on 2011-05-03 (0 days ago) 09/16/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6UET54WW (1.34 ) 2901CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6UET54WW(1.34):bd09/16/2010:svnLENOVO:pn2901CTO:pvrThinkPadT410s:rvnLENOVO:rn2901CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable: 2901CTO
dmi.product.version: ThinkPad T410s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Dave Cooper (cooper144) wrote :

I'm able to run my external monitor on resolutions of 1024x768 or less, but the refresh rate or something is off -- it's moving all fuzzy.

For me, it's not just compiz, in that Unity also fails terribly if I start up with an external monitor attached, or plug one in after logging in. The extended portion of the desktop does crazy stuff, like having a second status bar and maybe second set of launcher icons, but they don't work normally, and only part of the screen being drawn on, and any windows dragged onto that display become black (invisible)... Probably this requires a separate report. But it looks like Unity has not even been designed to deal with extended desktops!?

Riceh8r0512 (locy001) wrote :

I can also confirm this bug. I am having issues with desktop redraw with an external monitor. When only having a single monitor everything work great, plug in the second monitor and I have inconsistent results. These range from the monitor on the laptop having a distorted and unusable picture to no desktop redraw to both screens being unresponsive.

eastmad (david-eastman) wrote :

Pretty much the same for me with Unity.

Lenovo T410
Attempt to plug in another screen leads to corruption on laptop screen (black horizontal bars along top of screen) and failure to extend in second monitor. I can see mouse pointer but not anything it pulls with it.

(After recent updates) Ubuntu Classic, ie with compiz, is working okay again. Well, at least enough that my original bug report no longer holds. It seems to be a complaint just about Unity now. Others?

I can confirm this - seems Unity related.

I've got a BenQ G2320HDB monitor, and I have exactly the same issue.

Black bar on laptop screen, can't move windows to the external monitor, in fact not even mouse clicks work properly..

Geoff (gbrowne) wrote :

Similar problem here. Dell Inspiron 9300, ATI Radeon X300 chipset.
Internal 1920x1200 LCD and Samsung 1600x1200 ext LCD on DVI-0.
Using Open-source ATI drivers.

Dual head worked perfectly in V9 and V10, now broken in V11 if resolution set above 1280x1024, or anything other than 'Ubuntu Classic' desktop is selected. Also apps like etracer now report "*** etracer error: Couldn't initialize video: Couldn't find matching GLX visual (Resource temporarily unavailable)"

Changed in compiz (Ubuntu):
status: New → Confirmed
Michael Sharman (msharman) wrote :

Yep, having the same problems here also, with a dual monitor set up. Works fine without compiz, but with compiz the screen gets corrupts. Symptoms including random garbage over monitors, to just a black screen where the background should be, and dragging windows leaves a trail of artifacts as if the background is not being rendered at all.

My graphics card chipset is ATI Radeon X800XT.

Axx83 (axx83) wrote :

I have the same problem with intel graphics card on my samsung nc150 plus and an external lcd screen, while on normal 11.04 with unity the external monitor canßt be plugged in

mycl (415fox) wrote :

I am also experiencing this on my Lenovo X200. I have tried with external 1920x1600 and 1920x1080 monitors. I get the black bar across part of the external monitor thing.

It works fine with compiz and without unity. It works fine with unity 2d (without compiz). But the combination of compiz and Unity is bad.

I've tried running:
* compiz --replace
* unity --restart

And sometimes the desktop is fixed, but not always.

If I select different resolutions for the monitors, the band sometimes goes away or appears in a different location.

Weirdly, when I have the black bars, the mouse cursor can go over the black bars and you see it. Anything else can go into the black region and it's like, it goes there, but it is behind a black mask.

When I use the super-S "expo" feature I can see all the desktops and they do not have black bars on them (though the black bar remains on the external monitor.

Also, if I start from login with the external monitor, I do not have the problem. It is only when I try to plug the running system in that it occurs. Starting from login and unplugging the external monitor creates a similar problem. Only this time it is a thin blue band across the middle of the laptop screen and all of the windows are arranged below the band. However, I can drag the windows above the band or half way with the band covering the middle of the window. The point is, that it seems to recognize that the two sides of the band are two different regions. Almost as if it is treating the two sides of the blue band as separate monitors.

mycl (415fox) wrote :

I get many messages in my .xsession-errors like:

Window 0x3800057 created on ReparentNotify, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0

could be a clue?

Dinesh (linux-future) wrote :

I am on a Lenovo X200 Tablet. I see the exact symptoms as mycl[1] described in Comment #11. I have an external monitor - Dell 2209wa.

Heres an important clue. This might be a regression as the stock install of natty worked fine. But after I applied the latest updates, I started seeing this issue. Curiously, if I leave the external monitor plugged in and reboot the machine, the login screen mirrors the displays. But post login, unity is able to expand & setup correctly without any black bands or artifacts on the screen.

Natty so far has been great for me and I really hope you guys can fix this bug as it is an extremely important feature for me! :)


After the latest update (but not necessarily strictly/immediately; ie, I haven't tried in some weeks), including backports:

I just booted with my external plugged in. gdm (or whatever it is) came up perfectly. I logged in under Unity, and the external came up in the right place, working more or less as it should: no black / invisible areas, no crash, etc.

That is, the bug appears fixed. Other subscribers, can you confirm?

(Now, on to deal with all the other more general failures of Unity to handle extended desktops properly...)

After yet another, update, it has reverted and more: it's now worse than ever. It's back to completely unusable external monitor. If I boot with it plugged in, I get multicolor flashing screen / unusable. If I plug it in after logging, the screen goes black and useless. If I unplug it to recover, I get a black responseless screen with an arrow cursor. I cannot recover and must reboot.
Even if I log in with Classic, no effects, I get flashing junk screen if I plug in an external monitor.
I'm back to early 1990s functionality now under the latest Natty updates. (Very very discouraged)

This reversion may be the result of multiple bugs, since the window behaviour in compiz is messed up as is recognition of a external monitor hardware. Anyway, for a while things were definitely a bit better.

Thank you for reporting this bug to Ubuntu. 11.04 has reached End of Life (EOL).
See this document for currently supported Ubuntu releases:

Please upgrade to the latest version and re-test. If the bug is still reproducible, increase the verbosity of the steps to recreate it so we can try again.

Do feel free to report any other bugs you may find.

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for compiz (Ubuntu) because there has been no activity for 60 days.]

Changed in compiz (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers