Ubuntu

Random GUI "freezes" in Natty (can only move the cursor) (might be a segfault)

Reported by Nick Guletskii on 2011-05-01
178
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg

My screen "freezes" from time to time in Natty (didn't happen in Maverick). All I can do is move my cursor. I have tried going into the terminal and restarting the gdm, but
that doesn't do anything.

This occurs at random periods, it can happen multiple times in a day or once in a week.
This started when I installed a clean install of Natty. Maverick and Lucid work fine.
I haven't tested this without Unity.
Pidgin, Dropbox and Chrome(or Firefox, as it happened before I got Chrome too) are the apps that are running during the lockup. Sometimes accompanied by Minecraft (Java + native libraries for JOGL [Java OpenGL]).

Note: I am not sure if it is a X.org issue, although I was told that it probably is on askubuntu.com...
Tried service gdm restart. Gives black screen (some network related text on the 7th screen). Same with killall compiz. Even pskill X...

Okay. So now as I changed sync to VBlank to false and refresh rate to my screen's, instead of being all calm, everything starts flashing as if I was minimising and unminimising windows, commonly with colour issues (such as grey being displayed as a random colour).

Right, so I have output of unity 2>&1 | tee unity.log.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAw5AHPAAAAAAASAQOAIhN4Cqu1n1lUliYWUFQAAAABAQEBAQEBAQEBAQEBAQEBPhxWoFAAFjAwIDUAWMIQAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMRyBEaXNwbGF5CiAgAAAA/ABMUDE1NldIMi1UTEUxANw=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Sun May 1 19:29:42 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0205]
   Subsystem: Acer Incorporated [ALI] Device [1025:0205]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: Acer Aspire 5738
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=faf7bc23-ba6d-41e2-a829-41aa81e08626 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/20/2009
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.03
dmi.board.name: JV50
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.03:bd02/20/2009:svnAcer:pnAspire5738:pvr0100:rvnAcer:rnJV50:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 5738
dmi.product.version: 0100
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

description: updated
Timo Aaltonen (tjaalton) wrote :

When it happens, log in from the console (ctrl-alt-F1) and run 'killall compiz' and change back to X (ctrl-alt-F7/F8/F9). Does it revive the session?

Changed in xorg (Ubuntu):
status: New → Incomplete

Nope, makes the 7th screen black with text about networking, 8th and 9th black.

description: updated
bugbot (bugbot) on 2011-05-02
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
description: updated
bugbot (bugbot) on 2011-05-02
tags: added: kubuntu

Why was this added to Kubuntu? :/

description: updated
Bryce Harrington (bryce) wrote :

heh, "askubuntu.com" == "as"+"kubuntu"+".com".
silly bugbot

tags: removed: kubuntu

Also, what other info should I add?

bugbot (bugbot) on 2011-05-03
tags: added: kubuntu
Osama I. Al-Dosary (dosary) wrote :

I confirm this bug. Running a clean install of Ubuntu Natty 11.04 on Lenovo w510. Freezing seems random. And mouse motion continues to work when machine frozen.

Jimmy Merrild Krag (beruic) wrote :

I have seen it a few times on mine too.
Dell M1330 with Intel graphics

Jimmy Merrild Krag (beruic) wrote :

Sorry, didn't see the buplicate note.

Hans-Olof Nordin (h-o-nordin) wrote :

I can see the same freez on my Acer Acpire 1810tz with intel graphics. It happens only in Unity 3D, not in Unity 2D. I can reproduce it as follows: When I close the lid on my laptop, I have set it to do nothing (screen black). If I close the lid once and open it, it works as expected. If I close it an second time and open it, it will freeze and all I can do is move my cursor.
Ubuntu 11.04 32 bit.

Osama I. Al-Dosary (dosary) wrote :

Its a different bug than #740126. This bug is not compiz related. I'm running "Ubuntu Classic" not running Unity nor compiz.
What files should I submit to help narrow down this bug?

I also think it isn't. Although it definitely got better, I still get this.

I have the exact same problem, using an Ati HD3650 graphics card on a HP EliteBook. As #740126 seems to be related to Intel only I can't see that this is a duplicate.

In my case, this will happen very randomly and in Ubuntu Classic only, I have so far not experienced the bug in Unity. The screen will freeze, normally as I am working on something (no discernable pattern) and I'm left with a mousepointer which is context-sensitive even though I'm unable to interract with the OS. Shifting to a different display/console (Ctrl-Alt-F#) while using external dual-screens will result in black screens. Changing back I have a graphical glitch covering a square around where the mouse-pointer is at the moment that does not move arount with the mouse-pointer. While on my laptop-screen only I can change to a different terminal and restart gdm, that will usually "fix" the problem and I can start a new session.

I'm using the comercial Catalyst 11.5 drivers, older drivers seemed veeeery slow for some reason, resulting in stuttering and tears..

doppel hammer (doppelhammer) wrote :

I am experiencing the same bug, no matter if running kde or ubuntu classic in kubuntu 11.04.

Please repopen this bug - it isn't a duplicate. Proposed kernel which contains the fix for bug #740126 didn't fix this issue, while it did fix bug #740126

Chris Halse Rogers (raof) wrote :

From the symptoms this sounds like a GPU lockup bug. Once it occurs, could you please grab the information listed on https://wiki.ubuntu.com/X/Troubleshooting/Freeze#Reporting_GPU_lockup_Bugs - you might need root privs to look in /sys/kernel/debug - and attach the information here? Thanks.

Okay, I'll do that.

description: updated

Okay, attached the logs. Also did some testing - simulating high CPU load doesn't trigger that behaviour. Loading the GPU also doesn't trigger this.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
description: updated
Kiril (kiril-mik-os) wrote :

This bug affects me aswell. I'll attach logs next time.

I noticed next: I had same bug (100% same) with maverick + new kernel config.

Kiril (kiril-mik-os) wrote :

Sorry, graphics: Intel 4500MHD.

Kiril (kiril-mik-os) wrote :

bad copypaste... sorry again:
#22:
This bug affects me aswell. I'll attach logs next time.

I noticed next: I had same bug (100% same) with maverick + new kernel (2.6.39).

@Kiril (kiril-mik-os)
Was it happening wihtout the new kernel? Do you think it might be a kernel bug?

Kiril (kiril-mik-os) wrote :

Kernel bug or xorg userspace driver bug...

Booted up with maverick's kernel. WIll report later.
And I think I need to test once more case: new kernel but no opengl application.

The bug happens to me after screen goes sleeping for a while (timeout or laptop lid closed).
As I understand log driver can't reenable video chip.

@Kiril (kiril-mik-os)
Weird, this happens to me while I am actively working.

Kiril (kiril-mik-os) wrote :
Kiril (kiril-mik-os) wrote :
Kiril (kiril-mik-os) wrote :

40min on 2.6.35 - ok.
10min on 2.6.38 with closed lid and open lid after - frozen display.
i915_error_state says: no error state collected

Kiril (kiril-mik-os) wrote :

Strange, both logs are broken. sorry, here real (with errors):

Kiril (kiril-mik-os) wrote :
Kiril (kiril-mik-os) wrote :

I can't reproduce this bug with 3.0.1 in a short time...
Will report tommorow but I hope it is fixed.

Kiril (kiril-mik-os) wrote :

One day without freezing. Seems it was a kernel-side issue and it has been already fixed.
Try: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.1-oneiric/
You need new network manager for new kernel: ppa:network-manager/trunk

@Kiril (kiril-mik-os)

I had a time when the issue wouldn't show up for a week or so. Maybe it is a coincidence? I really don't want to get the kernel from other repos for now.

Kiril (kiril-mik-os) wrote :

With stock kernel I can reproduce my issue less then in a hour.
And this is ubuntu's mainline repo.

Seems I have a bit different error with same result, but you may try. You can always boot to stock kernel.

I hope this testing result will point ubuntu kernel team to backport driver changes.

@Kiril (kiril-mik-os) Upgrading to kernel 3.0 changes the problem. This still happens, but I can no longer move my mouse. Exiting to tty and going back into GUI brings me to the login screen. I log in into Ubuntu classic session, all data is lost.

Kiril (kiril-mik-os) wrote :

I didn't have new freezes yet. But my error in Xorg.0.log is different, maybe your problem still exists.

Ugh, disregard my last comment. Seems to be a second issue. The same issue as with previous kernel occurred to me right now. Managed to kill X. Always dispatched me into Ubuntu Classic, even with "Ubuntu" selected. So there are two issues now...

What other info has to be added for the inactive status to be dropped?

Aha! Hopefully found the cause! Output of "unity 2>&1 | tee unity.log" attached!

description: updated
summary: - Random GUI "freezes" in Natty (can only move the cursor)
+ Random GUI "freezes" in Natty (can only move the cursor) (might be a
+ segfault)

I'm having a similar problem, the screen freezes an I can only manipulate the mouse curser. I can see that the curser still is context sensitive (changes to I-beam shape over text-fields etc), but there is no other response from X. Attaching to a different console (ctrl-alt-#) gives me only a black screen, but I can carefully log in blindly and get back into X by restarting the gdm service.

I can reliably reproduce the problem by starting DavMail Gateway and a mail client (tested with Thunderbird and Evolutuion). If I mouse over the DavMail client icon in my status-bar, which would normally give me a status pop-up, the screen will freeze if not running in Classic without effects.

I'm running the 2.6.38-11 kernel and Ati Mobility radeon HD3650 with catalyst version 11.5.

Please ignore my comment, as I see this bug is only related to Inte-cards and there is a separate bug-listing for ati.

Heidrich Attila (heidrich) wrote :

My screen freezes several times a day - if I am present, and use the GUI. The machine runs fine for weeks, if no one is logged in locally on the GUI.

Sometimes I can exit from GUI, but still no way to restart it - only the complete system!

Heidrich Attila (heidrich) wrote :

Sometimes it does not freeses, just get fooled, so practically impossible to use, partial client area redraws, dead and invisible task- and menubars... More or less unusable. Worked with no problem witm 10.04!!

Heidrich Attila (heidrich) wrote :

Sorry, I always forget stg:

00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)

Paul Tagliamonte  (paultag) wrote :

We have 14 "This affects me too" marks, and a bunch of comments confirming this. I'm not ready to call it triaged, though. Can we get exact steps to reproduce and a bit more work tracking down where the issue is, exactly?

Marking medium - looks like an uncomon issue, but renders the system unusable.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium

@paultag
I can't actually give any exact steps to reproduce this as this happened out of the box. I did a clean install of Natty from a CD a week after it came out (or somewhere around that), and I instantly started experiencing this. I will try making a clean install of Natty to see where the cause might be. Thank you for your time :)

Sorry, but I think I will not be able to make a clean install. What steps should be done?

Okay. Here is an update. Currently running: Linux AccessDenied 3.0.0-0300rc7-generic #201107120911 SMP Tue Jul 12 10:15:32 UTC 2011 i686 i686 i386 GNU/Linux

I had a freeze half an hour ago. I ran compiz --replace --display :0, Segmentation fault occurred like stated in unity.log (unity launches compiz). So I tried metacity --replace --display :0, which resulted in a usable desktop (but without the panels, but still, I could save my work). I couldn't replace metacity before because I didn't use the --display param.

Therefore, I think it is a bug in compiz. I also wanted to point out that Maverick wasn't using compiz by default, and I didn't use it either. This means that compiz is the perfect candidate for the cause of this bug.

Paul Tagliamonte  (paultag) wrote :

Ah, cool.

Can you SSH in when this happens and do a `top`? See if it uses up 100% of CPU, if so, I might have this same issue (freeky).

In the meantime, I'm also pushing this on compiz. Thanks!

affects: xserver-xorg-video-intel (Ubuntu) → compiz (Ubuntu)
Stefan (stefan-tobe) wrote :

I have the same issue with freezing in Natty, occasionally once/twice a day

My video card is: Geforce GT430
compiz installed:
ii compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2 OpenGL window and compositing manager
ii compiz-core 1:0.9.4+bzr20110606-0ubuntu1~natty2 OpenGL window and compositing manager
ii compiz-gnome 1:0.9.4+bzr20110606-0ubuntu1~natty2 OpenGL window and compositing manager - GNOME window decorator
ii compiz-plugins 1:0.9.4+bzr20110606-0ubuntu1~natty2 OpenGL window and compositing manager - plugins
ii compiz-plugins-main 0.9.4+bzr20110527-0ubuntu1~natty1 Compiz Fusion plugins - main collection
ii compizconfig-backend-gconf 0.9.2.4-0ubuntu1 Compiz Fusion configuration system - gconf backend
ii libcompizconfig0 0.9.4-0ubuntu2 Settings library for plugins - OpenCompositing Project

however Compiz is not selected as display mode. I use normal

Stefan

@paultag Okay, I will!

Paul Tagliamonte  (paultag) wrote :

P.S. - nVidia GeForce 8800 GT here

@paultag Nope, top didn't show 100% CPU usage. However, zeitgeist-datahub was a zombie. What is more confusing is that I booted in into Linux AccessDenied 2.6.38-11-generic #48-Ubuntu SMP Fri Jul 29 19:05:14 UTC 2011 i686 i686 i386 GNU/Linux, and compiz --repl... did the same thing but metacity --replace didn't actually appear - the freeze was still there. It is confusing because with one kernel it looks like a fault with compiz, while with another it looks like a fault with Xorg. It is seriously bugging me.

Paul Tagliamonte  (paultag) wrote :

It's OK. Let's let the compiz buggers see if they can isolate this.

@paultag Thank you.

Kiril (kiril-mik-os) wrote :

So my issue is completely different because it's affects me on maverick + 2.6.39 kernel, natty + stock kernel, and don't affects on natty + 3.0.3 kernel...

Kiril (kiril-mik-os) wrote :

P.S. Never faced freezes with on Natty and NVidia GeForce 9800GT (proprietary driver).

E. Lewis (ed-lewis) wrote :

This bug seems to have something to do with gv (ghostview). gv will freeze my screen every time, whether I invoke from command line or from Unity GUI, or call it through another program (emacs). The bug is also present if I run Natty in 'classic mode'. I am running Natty 64-bit.
I have no problems with gv in Fedora 15 64-bit (this machine dual boots) nor in Lucid (32-bit) on another machine.
Hope this helps.

@ed-lewis I don't use ghostview.

E. Lewis (ed-lewis) wrote :

I have noted random freezing as reported in this bug ever since installing Natty in May. It was not until today that I could reproduce it consistently. Screen freezes, mouse remains active, but cannot do anything. Keyboard also becomes inactive. The only way to restore operation is to do a hard shutdown.
Perhaps there is something in common with gv code base and code base that affects other programs causing the problem.

@ed-lewis
It is probably in its dependencies.

@ed-lewis
May I also point out that for some time I thought it was some application too. Now it looks as if it isn't any particular applications fault, because it also happens without anything running.

More information! It is indeed a bug in Compiz (or maybe Unity)!

I get a fully usable desktop (in fact, I am using it right now) if I quit to a TTY and replace unity with metacity.

More info on the segfault: it appears to be happening while loading unityshell, because with verbose output it is very easy to see the pattern.

juan caldas` (ju-da-ca-ve-col) wrote :

hey i have something similar,
the screen is black but i can move the cursor...
is there anything to do?

@ju-da-ca-ve-col
Please try switching to a TTY using Ctrl+Alt+F1 and run metacity --replace --display=:0

@ju-da-ca-ve-col
Oh, and also try running the command unity after that.

TsFox (thuener) wrote :

This bug also affects me. The bug is annoying but the trick with "metacity --replace --display=:0" helped me a lot.

TsFox (thuener) wrote :

This message could help:
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x3c0021f (Debug - Ma)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

When i run "metacity --replace --display=:0" and the screen freeze again this message is shown.

Kurt Taylor (kurt-r-taylor) wrote :

I am also seeing this problem on an IBM ThinkCentre. I am using "Ubuntu Classic" as Unity was not supported. I just completed a fresh 11.04 install and updated and thought I had the problem fixed, but it is very random. It seems to be somewhat reproducible with browser use, but I have seen the problem with both chromium and firefox browsers. The frequency is every hour to once a week without a clear pattern.

My graphics card: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev c1) with the experimental 3D support driver from NVIDIA.

I will see if I can post some logs.

Kurt Taylor (kurt-r-taylor) wrote :
Download full text (4.6 KiB)

Well, it happened while entering details on this bug :) I can still access the box remotely, just as noted in other reports.

Here is a tail of dmesg:

[ 8384.590661] [drm] nouveau 0000:01:00.0: PFIFO_DMA_PUSHER - Ch 1 Get 0x1f800000 Put 0x00019558 State 0xc0002054 Push 0x00000000
[ 8384.592488] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: DATA_ERROR nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592500] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/4 class 0x0099 mthd 0x02fc data 0x00000003
[ 8384.592508] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592517] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x0208 data 0x00000108
[ 8384.592523] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592532] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x020c data 0x06800680
[ 8384.592538] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592547] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x0210 data 0x00e4e000
[ 8384.592553] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592562] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x0218 data 0x00864000
[ 8384.592568] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592577] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x0230 data 0x10000000
[ 8384.592583] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592592] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x0240 data 0x04000140
[ 8384.592598] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592607] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x0220 data 0x33a81951
[ 8384.592613] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592622] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x0228 data 0x40000000
[ 8384.592627] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592636] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x0248 data 0x11000000
[ 8384.592642] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592651] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x0260 data 0x18300000
[ 8384.592657] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592666] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x0268 data 0x08300000
[ 8384.592672] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEGAL_MTHD nstatus: BAD_ARGUMENT PROTECTION_FAULT
[ 8384.592681] [drm] nouveau 0000:01:00.0: PGRAPH - ch 1/7 class 0x004a mthd 0x0344 data 0x00000001
[ 8384.592687] [drm] nouveau 0000:01:00.0: PGRAPH - ERROR nsource: ILLEG...

Read more...

TsFox (thuener) wrote :

This time the freeze was different, i still enable to move the mouse but now i can't get TTY1 using Ctrl+Alt+F1. I still can access the remote the machine but the trick with "metacity --replace --display=:0" didn't work. This time i was using a extend monitor. With the remote connection i get the Xorg.0.log i think it should help to solve the problem.

@thuener It happens to me too sometimes.

Kurt Taylor (kurt-r-taylor) wrote :

Same environment as before - This just happened again.

Since the desktop was frozen, of course, except for the mouse, I sshed and looked at the running processes. All normal except for a defunct process for firefox, although, the X server had consumed a lot of time. Firefox may be a clue, but this happens with Chrome as well.

None of the above workarounds work for me.

Seems to be fixed in 11.10. :D

Not for me. Having this issue on two separate machines with 11.10. In fact, I'm seeing it more often with Oneiric than I did with Natty.

@czheng Maybe you are having a different issue? :S

Kurt Taylor (kurt-r-taylor) wrote :

Updated to 11.10 and have not seen the problem for several days now, where it would have locked up within hours before. I installed Oneric with the nVidia recommended driver and it seems to be fixed, or at least much better.

Eric Feliksik (milouny) wrote :

Not fixed for me either... :-(
I am running the 32 bits 3.0.0-12-generic-pae kernel on 11.10, and this happens twice a day.
I always switch to tty1 and kill X, but this is very bad.

Michael Nagel (nailor) wrote :

I am possibly affected by this as well. Here is my description, maybe it is helpful to someone:

This is a laptop running natty with 2.6.38-13-generic (x86_64) kernel with a integrated Intel HD Graphics 3000 processor (kernel module: i915).
Occassionally the display stops refreshing (e.g. clock applet does not refresh), only the mouse pointer can be moved (even so in some cases the mouse pointer cannot be moved). The laptop does not react on mouse-clicks and keyboard events (so switching to a tty is not possible). The laptop is still running and responding, however. Logging in via SSH is still possible and does not show any suspicious cpu/memory usage and no entries in dmesg/kern.log.
If I "kill -9" X, gdm recovers, I can log in again and everything works as it should (except that all unsaved work is lost). Mouse and keyboard work again in the newly spawned session.

The problem does not happen deterministically, but I found that copying data from a LibreOffice calc spreadsheet causes it nearly every time (90% chance). It does not happen every time, and it happens for other reasons as well.
I have a table with 1000 rows, 30 columns, and copy 2 colums to Firefox, gedit, ... via CTRL-C/V.

Best Regards
Michael

Pippin (pippin) wrote :

I've been able to confirm this same bug. I'm running 12.04 with an nVidia GeForce 8600, Intel 6core.

Johannes (jo.hannes) wrote :

The same happens for me since the last upgrade. It also happens quite randomly, but also often when I use LibreOffice...

Thomas N (konstigt) wrote :

I have also had this a couple of times on 12.04. I have updated my intel driver to latest stable. I'm using cinnamon instead of Unity though.

$ apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installed: 2:2.19.0-0ubuntu1~xup1
  Candidate: 2:2.19.0-0ubuntu1~xup1
  Version table:
 *** 2:2.19.0-0ubuntu1~xup1 0
        500 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

ctrl-alt-f1 or remote always works but I haven't found any way to restore the GUI. Can only move the mouse cursor.

Eric G. Stern (egstern1) wrote :

I just clean installed 12.04 on my Dell D620 with nvidia graphics. Previously I had been running 10.04 with no problems. I get freezes quite often. I just had two happen just at the greeter login screen, and they also happen frequently after waking up from a suspend. When it happens, I can't switch virtual terminals with ctrl-alt-fn. I can log in remotely but that is it. I was able to get back to a login screen by killing the lightdm process.

Aly-casus (aly-casus) wrote :

Well I found the problem at least in my case.

Connected phone by MTP with Android 4.3 on board. On UI freeze, as soon as I disconnect phone from usb or shutdown my phone, ui unfreezes. Didn't test it with other devices with Android.

Hope that helps.

Alex Urbano (asgaroth-belem) wrote :

I am on 12.10 64bit with kernel = 3.11.4-031104-generic, and have this issue as well:

modinfo i915:

filename: /lib/modules/3.11.4-031104-generic/kernel/drivers/gpu/drm/i915/i915.ko
srcversion: CAB985B3C2AF9F216978683

To post a comment you must log in.