compiz edge bindings doesn't work in 11.04

Bug #772251 reported by Dmitry K on 2011-04-28
This bug report is a duplicate of:  Bug #761616: Mouse edge + button doesn't work. Edit Remove
82
This bug affects 17 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Just upgraded to 11.04, switched to classic view and configured compiz move within wall bindings for mouse (some_edge+button3).
But the flipping between desktop walls with mouse doesn't work (it was working in 10.10). Switching with keyboard or edge flipping with mouse pointer works perfect.
Has anyone same problem? I tried different combinations with edges and buttons, but none of them work.

Dmitry K (dkekel) wrote :

The problem seems to be with edge detection.
Tried to bind edge+mousebutton to rotate cube, but it also failed.
The idea from the ubuntu forums is to use wmctrl and to bind commands in compiz also failed
 [commands]
as_command3 = wmctrl -o 0,0
as_command4 = wmctrl -o 1152,0
as_command5 = wmctrl -o 0,864
as_command6 = wmctrl -o 1152,864
as_run_command3_button = <LeftEdge><TopEdge>Button1
as_run_command4_button = <RightEdge>Button1
as_run_command5_button = <BottomEdge><BottomLeftEdge>Button1
as_run_command6_button = <BottomRightEdge>Button1

Dmitry K (dkekel) on 2011-04-28
summary: - compiz mouse wall flip doesn't work in 11.04
+ compiz edge bindings doesn't work in 11.04
Changed in compiz (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers