Bitcoin top-level window unmapped

Bug #758398 reported by Vasile Rotaru on 2011-04-12
178
This bug affects 38 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Compiz Core
High
Sam Spilsbury
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

When I launch bitcoin linux client (bitcoin.org) the GUI does not pop up. It does when the window manager is metacity (Ubuntu classic - no effects)

xlsclients finds bitcoin and wininfo tells me that:

xwininfo: Window id: 0x4600001 "bitcoin"

  Absolute upper-left X: 10
  Absolute upper-left Y: 10
  Relative upper-left X: 10
  Relative upper-left Y: 10
  Width: 10
  Height: 10
  Depth: 24
  Visual: 0x23
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsUnMapped
  Override Redirect State: no
  Corners: +10+10 -1900+10 -1900-1060 +10-1060
  -geometry 10x10+10+10

The problems seems to be: 'Map State: IsUnMapped' from the above.

the system:

Description: Ubuntu Natty (development branch)
Release: 11.04

compiz:
  Installed: 1:0.9.4+bzr20110411-0ubuntu1
  Candidate: 1:0.9.4+bzr20110411-0ubuntu1
  Version table:
 *** 1:0.9.4+bzr20110411-0ubuntu1 0
        500 http://md.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status
     1:0.9.4+bzr20110408-0ubuntu2+r2745+201104111049 0
        500 http://ppa.launchpad.net/unity/daily/ubuntu/ natty/main amd64 Packages

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.4+bzr20110411-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Tue Apr 12 07:46:40 2011
DistUpgraded: Log time: 2011-04-01 14:43:51.543573
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 fglrx, 8.840, 2.6.38-7-generic, x86_64: installed
 fglrx, 8.840, 2.6.38-5-generic, x86_64: installed
 fglrx, 8.840, 2.6.38-8-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited Device [174b:e990]
JockeyStatus: xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: MICRO-STAR INTERANTONAL CO.,LTD MS-7302
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=cebc3ffc-36be-4027-9d0e-bca8c97ded0f ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: Upgraded to natty on 2011-04-01 (10 days ago)
dmi.bios.date: 04/16/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V2.0
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MS-7302
dmi.board.vendor: MICRO-STAR INTERANTONAL CO.,LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERANTONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV2.0:bd04/16/2008:svnMICRO-STARINTERANTONALCO.,LTD:pnMS-7302:pvr1.0:rvnMICRO-STARINTERANTONALCO.,LTD:rnMS-7302:rvr1.0:cvnMICRO-STARINTERANTONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-7302
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERANTONAL CO.,LTD
version.compiz: compiz 1:0.9.4+bzr20110411-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs 20090808ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Vasile Rotaru (vrotaru-md) wrote :
Changed in compiz (Ubuntu):
status: New → Confirmed
Todd Lyons (tlyons) wrote :

The client I had built under 10.10 a few months ago stopped working after the 11.04 upgrade. By downloading the latest bitcoin gui client snapshot build from:
http://bitcoin.bluematt.me/bitcoin-nightly/ubuntu-11.04/
dated May 1 2011, it now works fine on my 11.04 with Gnome, with no changes to the libs or to the desktop.

Further info found here:
http://www.bitcoin.org/smf/index.php?topic=6299.0

cako (goldencako) wrote :

I can confirm this bug on 10.10 with bitcoin version 0.321.

Daniel Holbert (dholbert) wrote :

cako: This didn't previously affect Ubuntu 10.10. As I understand it, this was due to wxwidgets (bitcoin's widget toolkit) having a bad interaction on Ubuntu 11.04. See discussion in the thread from Comment #2 here.

If you're hitting problems with Bitcoin not showing up on Ubuntu 10.10, I'd guess that you're hitting a different underlying bug.

Vasile Rotaru (vrotaru-md) wrote :

Quoting from: http://trac.wxwidgets.org/ticket/13146

"... workaround for broken window managers which claim to support _NET_REQUEST_FRAME_EXTENTS, but don't respond to it"

If this is the case that it is an (upstream) compiz bug. If not than it is a wxwidgets bug, (which seem to be already fixed) and then this bug can be closed.

Salih EMIN (salih-emin) wrote :

I can confirm that bitcoin-0.3.22 on Ubuntu 11.04 64bit doesn't have this bug and the gui starts see the attachment

Uli Tillich (utillich) wrote :

I can not confirm this with the latest client (0.3.23-beta).

Guillermo Lo Coco (glococo) wrote :

Version 0.3.24-beta is working well in Unity 3D, ( also enabled many default disabled compiz effects)

Using Ubuntu 11.04 with experimental 3d nvidia support.

Changed in compiz-core:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.6
Changed in compiz-core:
status: Confirmed → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Any details of which commit fixed this bug, Sam?

This is no longer an issue.

Daniel van Vugt (vanvugt) wrote :

Fix released in:
compiz (1:0.9.7.0~bzr2995-0ubuntu1) precise; urgency=low

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Changed in compiz-core:
status: Fix Committed → Fix Released
Changed in compiz:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.