[natty-alpha3] [LiveCD] compiz crash on boot, unity fails to start, installation impossible

Bug #729597 reported by jerrylamos on 2011-03-05
70
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Casper
Fix Released
Undecided
Unassigned
Unity
Fix Released
Undecided
Rob Taylor
compiz (Ubuntu)
Undecided
Rob Taylor
unity (Ubuntu)
Undecided
Rob Taylor

Bug Description

Binary package hint: compiz

Compiz crash on assertion failure. "Apport does not report on this type of failure"
Occurs just after boot. This is Acer aspire 1 netbook which runs Unity 3D

I have seen this type of failure on Compaq Presario ati radeon xpress 200 which runs Unity 3D

Jerry

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.4-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600
 edid-base64: AP///////wAGr9JhAAAAAAATAQOAFg14ChWFl1hTiiYlUFQAAAABAQEBAQEBAQEBAQEBAQEBdBMAOkFYFCAwICYA3n0AAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTAxQVcwNiBWMSAKACk=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Sat Mar 5 06:58:59 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0349]
   Subsystem: Acer Incorporated [ALI] Device [1025:0349]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110228.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110228.1)
MachineType: Acer AOD255E
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=9490ee56-c0d0-43a0-9a90-be4d0aeb2088 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/16/2010
dmi.bios.vendor: Acer
dmi.bios.version: V3.12(DDR3)
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JE02_PT
dmi.board.vendor: Acer
dmi.board.version: V3.12(DDR3)
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V3.12(DDR3)
dmi.modalias: dmi:bvnAcer:bvrV3.12(DDR3):bd12/16/2010:svnAcer:pnAOD255E:pvrV3.12(DDR3):rvnAcer:rnJE02_PT:rvrV3.12(DDR3):cvnAcer:ct10:cvrV3.12(DDR3):
dmi.product.name: AOD255E
dmi.product.version: V3.12(DDR3)
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.4-0ubuntu3
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1~git20110215.cc1636b6-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu9
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

jerrylamos (jerrylamos) wrote :
Eugene San (eugenesan) on 2011-03-09
summary: - Natty A3 compiz crash on boot
+ [natty] Alpha3 compiz crash on boot
Changed in compiz (Ubuntu):
status: New → Confirmed

Segfaults also on Intel g945 and g965.
Daily snapshots from 8Mar2011 are still affected.

tags: added: casper unity
Eugene San (eugenesan) on 2011-03-09
summary: - [natty] Alpha3 compiz crash on boot
+ [natty-alpha3] [LiveCD] compiz crash on boot, unity fails to start,
+ installation impossible
tags: added: iso-testing
Hansen (moteprime) wrote :

I have his bug alpha testing Natty on Asus eee 1005P.

Starting live session of Natty alpha 3, two out of 3 time i get:
Sorry, the program "Compiz" closed unexpectedly .
Your computer does not have enough memory to automatically analyze the problem and send a report to the developers.

The 1 out of the 3 times i get a desktop with functioning Unity. (i dont know if its 3D)

As far as i have been able to figure out googling, the Asus eee 1005p uses "Integrated Intel GMA 3150 Graphics Controller"

lspci reports:
mads@mads-1005P:~$ lspci
00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller
00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)

Alex Launi (alexlauni) on 2011-03-09
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-03-11
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-03-17
tags: added: unity-priority
Eugene San (eugenesan) wrote :

Daily Live from 17mar2011 is no more affected.

I am planning marking bug as fixed, anyone one still experience the error?

Changed in casper:
status: New → Fix Released
Hansen (moteprime) wrote :

I am on desktop i386 iso date 17. march. haven't seen the bug yet.

Rob Taylor (robtaylor) on 2011-03-21
Changed in compiz (Ubuntu):
assignee: nobody → Rob Taylor (robtaylor)
Changed in unity (Ubuntu):
assignee: nobody → Rob Taylor (robtaylor)
Changed in unity:
assignee: nobody → Rob Taylor (robtaylor)
Rob Taylor (robtaylor) wrote :

This is proving a difficult one to catch. If you see this regularly happening, and you're feeling brave, please try this:

sudo gedit /usr/share/applications/compiz.desktop
and change the line

Exec=compiz

to

Exec=compiz --debug

Then, when you see the bug occur, please paste the contents of ~/.xsession-errors here.

Thanks!

Rob Taylor (robtaylor) wrote :

I've managed to log this compiz crash. Unfortunatly it's rather tricky to reproduce - it almost always happens for the first login, then works from then on. I managed to reproduce it by creating new users and logging into them until the issue reappeared.

Log of .xsession-errors with gnome-session in debug mode is attached.

Rob Taylor (robtaylor) wrote :

As this crash is a bug in plugin load, attached is a work around patch that registers compiz with the session manager *before* loading the plugins. Hence if a crash does occur during plugin load, the session manager should restart us.

Changed in compiz (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
tags: added: patch
jerrylamos (jerrylamos) wrote :

27 March Daily Build USB key booted O.K. on the Acer. The failure in this bug 729597 did not occur, so I assume it's fixed.

I also didn't get a ubiquity failure on boot, #742102, is it related to the patch in Brian Murray's post 2011-03-24?

Starting Install gets failure with Ubiquity code 10 which is a different bug, #742125.

Thanks for the patch.

Jerry

David Barth (dbarth) on 2011-03-28
tags: removed: unity-priority
Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
milestone: none → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Bryce Harrington (bryce) wrote :

[From comments looks like this should be closed as fixed, but the compiz task was missed. If there is indeed some compiz work still needed please review, reopen, and clarify.]

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers