unity-window-decorator crashed with SIGSEGV in g_closure_invoke()

Bug #727041 reported by Per-Inge on 2011-03-01
838
This bug affects 166 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
High
Sam Spilsbury

Bug Description

Binary package hint: compiz

I was scanning my music library in Banshee. There was a problem with the scanning and Banshee hanged. The crash happened when I forced a close of Banshee.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-gnome 1:0.9.4-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Tue Mar 1 09:57:12 2011
ExecutablePath: /usr/bin/unity-window-decorator
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110228.1)
ProcCmdline: /usr/bin/unity-window-decorator
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x415c70: mov 0x310(%rax),%rdi
 PC (0x00415c70) ok
 source "0x310(%rax)" (0x00000310) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? ()
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/libgobject-2.0.so.0
Title: unity-window-decorator crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (nautilus:5119): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (<unknown>:5117): dee-WARNING **: Transaction from com.canonical.Unity.ApplicationsPlace.SectionsModel is in the past. Ignoring transaction.
 (<unknown>:5117): dee-WARNING **: Transaction from com.canonical.Unity.ApplicationsPlace.GroupsModel is in the past. Ignoring transaction.

Per-Inge (per-inge-hallin) wrote :
visibility: private → public
tags: added: compiz-0.9

StacktraceTop:
 window_closed (screen=<value optimized out>, win=0x194a500) at /build/buildd/compiz-0.9.4/unity/unity_window_decorator/src/wnck.c:725
 g_closure_invoke (closure=0x188e330, return_value=0x0, n_param_values=2, param_values=0x195e590, invocation_hint=0x7fffc7fa7e20) at /build/buildd/glib2.0-2.28.1/./gobject/gclosure.c:767
 signal_emit_unlocked_R (node=<value optimized out>, detail=0, instance=0x188f030, emission_return=0x0, instance_and_params=0x195e590) at /build/buildd/glib2.0-2.28.1/./gobject/gsignal.c:3252
 g_signal_emit_valist (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>, var_args=<value optimized out>) at /build/buildd/glib2.0-2.28.1/./gobject/gsignal.c:2983
 g_signal_emit (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>) at /build/buildd/glib2.0-2.28.1/./gobject/gsignal.c:3040

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
wilfred_com (wilfredcom) wrote :

For me that happens in other cases such as web browsing or opening a terminal

ec (ecroes) wrote :

In my case the crash occurred when opening an odp-presentation.

ZhengPeng Hou (zhengpeng-hou) wrote :

mine happens when press Alt+TAB frequently

fred schneider (pa4tim) wrote :

Banshee was scanning the music directory. In the Alpha before this one, banshee finaly worked, now again problems

José A. Muñiz (josemuniznyc) wrote :

This happened to me while re-authorising an account under Gwibber.

BlackYeLL (blackyell) wrote :

This happens randomly, when I'm doing many different things.

Elias K Gardner (zorkerz) wrote :

Compiz is also crashing for me in many different situations causing the window borders of unmaximized windows to disappear. Have not yet found a way to reliably reproduce this though it happens nearly every time I run natty.

tags: added: bugpattern-needed
David Barth (dbarth) on 2011-03-09
tags: added: unity
Changed in compiz (Ubuntu):
importance: Medium → High
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → ubuntu-11.04-beta-1
Changed in compiz (Ubuntu):
status: New → Fix Committed
Richard Senior (r-senior) wrote :

Sufficiently similar to my case that I suspect it's the same problem. I have Banshee open and was changing the volume using the "panel" applet when Compiz crashed. Lost all my window title bars but everything else carried on OK, including the Unity Launcher.

Zoltan Arnold Nagy (zoltan) wrote :

this is still happening. why is it "fix committed"?

crys (schaefec) wrote :

for me, too. Happened today after closing a wine-app.

ngsupb (ngsupb) wrote :

still happing for me too. Everything is updated today though.

Zoltan Arnold Nagy (zoltan) wrote :

does "fix committed" mean there's a fix in upstream, but not yet released as a package in the repos, or it means we shouldn't see the error?

Mauricio Pretto (pretto) wrote :

Means that the person assigned to fix the bug is commited to fix
the time to fix is set on the milestone

zzeroo (co) wrote :

Crash again on different actions e.g. change window size

Changed in compiz (Ubuntu):
status: Fix Committed → New
status: New → Confirmed
Jennifer (jendie) wrote :

Crashed while opening the appearance preferences window. The window title bars disappeared.

I just entered my information in bug 750550 and marked as duplicate of this one. In my case the screen starts flickering, but eventually the X server starts again and everything seems to come back to normal.

Changed in compiz (Ubuntu):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
Loïc Molinari (loic.molinari) wrote :

zzeroo: Please test with the last version of u-w-d, the fix has been released now in natty.

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released

* on some Java application (IntelliJ) when a error dialog dispose.

Giupino (pegar1982) wrote :

Hi for me also now systematically crashes when I close a Java application (Hattrick Organizer)
in dmesg I read:
[19248.480592] show_signal_msg: 24 callbacks suppressed
[19248.480596] unity-window-de [1508]: segfault at 228 ip 0805be37 sp bf923d60 error 6 in unity-window-decorator [8048000 +17000]

tulskiy (tulskiy) wrote :

Still happens in natty after closing java applications (not always)

kernel: [12062.558925] unity-window-de[7089]: segfault at 228 ip 0805be37 sp bfdaade0 error 6 in unity-window-decorator[8048000+17000]

Still happens in natty after closing java dialogs (not always)

[ 5930.267653] unity-window-de[2312]: segfault at 228 ip 0805be37 sp bfcf1500 error 6 in unity-window-decorator[8048000+17000]

kimus (kimus) wrote :

Same here after java dialogs:
[20489.146599] unity-window-de[2182]: segfault at 318 ip 0000000000415d6f sp 00007fff2f7c5890 error 6 in unity-window-decorator[400000+1b000]

Elmar Zeeb (elmar-zeeb) wrote :

Still happens for me too, especially for java dialogs.

I use a bibtex tool called jabref and can reproduce the crash simply by opening the dialogs of jabref.

Troy Kinsella (troy-kinsella) wrote :

Still happens for me, again with java dialogs.

Matt Hellige (hellige) wrote :

Same here, also Java dialogs. (Intellij IDEA 10.0.3, in my case.)

Maybe it's a regression of some sort? Because when I used emerald in older
versions of ubuntu, it also used to crash quiet often after closing java
windows.

On Tue, May 17, 2011 at 2:52 AM, Matt Hellige <email address hidden>wrote:

> Same here, also Java dialogs. (Intellij IDEA 10.0.3, in my case.)
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/727041
>
> Title:
> unity-window-decorator crashed with SIGSEGV in g_closure_invoke()
>
> Status in “compiz” package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: compiz
>
> I was scanning my music library in Banshee. There was a problem with
> the scanning and Banshee hanged. The crash happened when I forced a
> close of Banshee.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: compiz-gnome 1:0.9.4-0ubuntu2
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic x86_64
> Architecture: amd64
> CrashCounter: 1
> Date: Tue Mar 1 09:57:12 2011
> ExecutablePath: /usr/bin/unity-window-decorator
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110228.1)
> ProcCmdline: /usr/bin/unity-window-decorator
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x415c70: mov 0x310(%rax),%rdi
> PC (0x00415c70) ok
> source "0x310(%rax)" (0x00000310) not located in a known VMA region
> (needed readable region)!
> destination "%rdi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: compiz
> StacktraceTop:
> ?? ()
> g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
> ?? () from /usr/lib/libgobject-2.0.so.0
> g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
> g_signal_emit () from /usr/lib/libgobject-2.0.so.0
> Title: unity-window-decorator crashed with SIGSEGV in g_closure_invoke()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
> XsessionErrors:
> (nautilus:5119): GConf-CRITICAL **: gconf_value_free: assertion `value !=
> NULL' failed
> (<unknown>:5117): dee-WARNING **: Transaction from
> com.canonical.Unity.ApplicationsPlace.SectionsModel is in the past. Ignoring
> transaction.
> (<unknown>:5117): dee-WARNING **: Transaction from
> com.canonical.Unity.ApplicationsPlace.GroupsModel is in the past. Ignoring
> transaction.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/727041/+subscribe
>

--
--------------------------------
Best,
Denis Tulskiy

mauros (g-angeletos) wrote :

This is happening for me quite often - can't determine the actual steps to replicate. The interesting thing is that on the workstation that this bug occurs I have the ATI catalyst driver installed. On my laptop with the nvidia driver is has never happened.

The above happens with both the Ubuntu and Ubunt Classic themes. In the Ubuntu (unity) them I also loose the top panel (pixel corruption).

I have added an up-to-date crash report on https://bugs.launchpad.net/bugs/789513.

There are cases where compiz crashes, too. See https://bugs.launchpad.net/bugs/789498.

Christopher (soft-kristal) wrote :

It seems to have resurfaced in 14.10. Mine crashes on boot, then restores itself.

Stephen M. Webb (bregma) wrote :

It's highly unlikely you're seeing a three-year-old bug resurface in a component that has not been shipped for at least two years.

It's more likely you're seeing bug #1366351.

To post a comment you must log in.