sometimes, restored window placed too high.

Bug #716521 reported by Oleksij Rempel on 2011-02-10
66
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Sam Spilsbury
Unity
Fix Released
Medium
Sam Spilsbury
compiz (Ubuntu)
Medium
Sam Spilsbury
unity (Ubuntu)
Medium
Sam Spilsbury

Bug Description

Binary package hint: compiz

If i switch some window from maximized to window mode it will be placed partially hidden under unity-menu-panel. See screencast for more details.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.2.1+glibmainloop4-0ubuntu10
ProcVersionSignature: Ubuntu 2.6.38-2.29-generic 2.6.38-rc3
Uname: Linux 2.6.38-2-generic i686
Architecture: i386
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600
 edid-base64: AP///////wAiZOkDD2wAABwTAQOAFg14CoA2ml5dkSggT1QAAAABAQEBAQEBAQEBAQEBAQEB7BMA4kBYUCBdIxUE3IEAAAAZAAAA/gAAAAAAAAAAAAAAAAAAAAAA/ABIU0QxMDBJRlcxCiAgAAAAEAAKICAgICAgICAgICAgAM0=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Thu Feb 10 17:15:20 2011
DistUpgraded: Yes, recently upgraded Log time: 2011-01-04 16:25:11.828022
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Subsystem: ASUSTeK Computer Inc. Device [1043:8340]
   Subsystem: ASUSTeK Computer Inc. Device [1043:8340]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: ASUSTeK Computer INC. 1005HA
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 LANG=de_DE.UTF-8
 LC_MESSAGES=de_DE.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2-generic root=UUID=425014a2-7247-459c-8e13-9595b8fc5507 ro quiet splash vt.handoff=7
SourcePackage: compiz
dmi.bios.date: 02/26/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1401
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1005HA
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1401:bd02/26/2010:svnASUSTeKComputerINC.:pn1005HA:pvrx.x:rvnASUSTeKComputerINC.:rn1005HA:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1005HA
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu10
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

Oleksij Rempel (olerem) wrote :
tags: added: compiz-0.9
Download full text (3.4 KiB)

Gravity adjustment is bugged it seems. Confirmed.

On Fri, Feb 11, 2011 at 12:35 AM, fishor <email address hidden> wrote:
> Public bug reported:
>
> Binary package hint: compiz
>
> If i switch some window from maximized to window mode it will be placed
> partially hidden under unity-menu-panel. See screencast for more
> details.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: compiz 1:0.9.2.1+glibmainloop4-0ubuntu10
> ProcVersionSignature: Ubuntu 2.6.38-2.29-generic 2.6.38-rc3
> Uname: Linux 2.6.38-2-generic i686
> Architecture: i386
> CompositorRunning: compiz
> DRM.card0.LVDS.1:
>  status: connected
>  enabled: enabled
>  dpms: On
>  modes: 1024x600
>  edid-base64: AP///////wAiZOkDD2wAABwTAQOAFg14CoA2ml5dkSggT1QAAAABAQEBAQEBAQEBAQEBAQEB7BMA4kBYUCBdIxUE3IEAAAAZAAAA/gAAAAAAAAAAAAAAAAAAAAAA/ABIU0QxMDBJRlcxCiAgAAAAEAAKICAgICAgICAgICAgAM0=
> DRM.card0.VGA.1:
>  status: disconnected
>  enabled: disabled
>  dpms: Off
>  modes:
>  edid-base64:
> Date: Thu Feb 10 17:15:20 2011
> DistUpgraded: Yes, recently upgraded Log time: 2011-01-04 16:25:11.828022
> DistroCodename: natty
> DistroVariant: ubuntu
> GraphicsCard:
>  Subsystem: ASUSTeK Computer Inc. Device [1043:8340]
>   Subsystem: ASUSTeK Computer Inc. Device [1043:8340]
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
> MachineType: ASUSTeK Computer INC. 1005HA
> PackageArchitecture: all
> ProcEnviron:
>  LANGUAGE=de_DE:de:en_GB:en
>  LANG=de_DE.UTF-8
>  LC_MESSAGES=de_DE.utf8
>  SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2-generic root=UUID=425014a2-7247-459c-8e13-9595b8fc5507 ro quiet splash vt.handoff=7
> SourcePackage: compiz
> dmi.bios.date: 02/26/2010
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 1401
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: 1005HA
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: x.xx
> dmi.chassis.asset.tag: 0x00000000
> dmi.chassis.type: 10
> dmi.chassis.vendor: ASUSTeK Computer INC.
> dmi.chassis.version: x.x
> dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1401:bd02/26/2010:svnASUSTeKComputerINC.:pn1005HA:pvrx.x:rvnASUSTeKComputerINC.:rn1005HA:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
> dmi.product.name: 1005HA
> dmi.product.version: x.x
> dmi.sys.vendor: ASUSTeK Computer INC.
> version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu10
> version.libdrm2: libdrm2 2.4.23-1ubuntu3
> version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
> version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu3
> version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
> version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu6
> version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4
>
> ** Affects: compiz (Ubuntu)
>     Importance: Undecided
>         Status: New
>
>
> ** Tags: apport-bug i386 natty running-unity ubuntu unity-2d
>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in ubuntu.
> https://bugs.launchpad.net/bugs/716521
>
> Title:
>  sometimes, restored window placed too high.
>
> ___...

Read more...

Omer Akram (om26er) wrote :

This is still an issue for me with latest natty.

Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Alex Launi (alexlauni) on 2011-04-05
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium

This is probably the same bug, so I'll post here rather than opening a new report (feel free to correct me on this).
The behaviour I noticed is the following:

Use Ctrl-Alt-T to open a terminal. Terminal will appear with its window decorations 90% underneath the top panel.

This also occurs with other windows that don't automatically maximise on netbook; for example, the System Settings.

Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-core:
milestone: none → 0.9.5.96
Changed in unity:
milestone: none → 4.16.0
Didier Roche (didrocks) on 2011-09-15
Changed in unity:
milestone: 4.16.0 → 4.18.0
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
Jason Smith (jassmith) on 2011-09-29
Changed in compiz-core:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
Didier Roche (didrocks) on 2011-09-29
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Fix Released
Changed in compiz-core:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.6+bzr20110929-0ubuntu1

---------------
compiz (1:0.9.6+bzr20110929-0ubuntu1) oneiric; urgency=low

  * New upstream snapshot:
    - Workspace switcher makes windows lose decorations (LP: #853951)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #861793)
    - sometimes, restored window placed too high (LP: #716521)
    - can't maximize windows on second monitor and Qt windows displayed in
      wrong place (LP: #861341)
  * 091_no_use_gnome_but_desktop_file.patch:
    - partially committed upstream, no more needed
 -- Didier Roche <email address hidden> Thu, 29 Sep 2011 09:21:42 +0200

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Changed in compiz-core:
milestone: 0.9.5.96 → 0.9.7.0
Changed in unity (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers