enable commands plugin

Bug #355018 reported by Cameron Braid on 2009-04-04
56
This bug affects 9 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned
metacity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: compiz

I have manually specified these gconf keys

/apps/metacity/global_keybindings/run_command_1
/apps/metacity/keybinding_commands/command_1

They used to work in compiz in intrepid, however after installing jaunty they are ignored

$ lsb_release -rd
Description: Ubuntu jaunty (development branch)
Release: 9.04

$ dpkg -l | grep compiz
ii compiz 1:0.8.2-0ubuntu6 OpenGL window and compositing manager
ii compiz-core 1:0.8.2-0ubuntu6 OpenGL window and compositing manager
ii compiz-fusion-plugins-extra 0.8.2-0ubuntu1 Collection of extra plugins from OpenComposi
ii compiz-fusion-plugins-main 0.8.2-0ubuntu2 Collection of plugins from OpenCompositing f
ii compiz-gnome 1:0.8.2-0ubuntu6 OpenGL window and compositing manager - GNOM
ii compiz-plugins 1:0.8.2-0ubuntu6 OpenGL window and compositing manager - plug
ii compiz-wrapper 1:0.8.2-0ubuntu6 OpenGL window and compositing manager, wrapp
ii compizconfig-backend-gconf 0.8.2-0ubuntu1 Settings library for plugins - OpenCompositi
ii libcompizconfig0 0.8.2-0ubuntu1 Settings library for plugins - OpenCompositi

Related branches

Irfan Adilovic (irfy) wrote :

I can confirm this behavior. Adding metacity as an affected package, since the key bindings belong to metacity.

Irfan Adilovic (irfy) wrote :

Cameron, fire up your ccsm and have a look at the very first plugin, it should be "Commands". Check out if your metacity custom commands are here to be found, and then check if the plugin itself has been activated, and tell me if it helped.

I would suggest activating this plugin by default.

Cameron Braid (cameron-braid) wrote :

ccms wasn't installed, so I installed that first.

The Commands plugin wasn't enabled, so I enabled that.

That fixed my issue.

I agree that the Commands plugin should be installed by default.

aliencam (cameronk) wrote :

I can confirm that the commands plugin fixes this. kind of disappointing that it wouldn't be installed by default if the update somehow removes the capacity for metacity keybindings.

Strange though that it was able to import or recognize the shortcut keys that I already put it into the gconf-editor. I wonder if there is another setting that will re-enable the shortcut keys in gconf-editor instead?

woxidu (egwynn-gmail) wrote :

I had this same problem but it looks like the "Commands" plugin in CompizConfig Settings Manager (ccsm) was 1. responsible for activating those settings and 2. disabled by default in Jaunty. Enabling that plugin fixed things for me.

Eli

crashcookie (crashcookie) wrote :

$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

$ dpkg -l | grep compiz | sed 's/\s\{2,\}/ /g'
ii compiz 1:0.8.2-0ubuntu8 OpenGL window and compositing manager
ii compiz-core 1:0.8.2-0ubuntu8 OpenGL window and compositing manager
ii compiz-fusion-plugins-extra 0.8.2-0ubuntu1 Collection of extra plugins from OpenComposi
ii compiz-fusion-plugins-main 0.8.2-0ubuntu2 Collection of plugins from OpenCompositing f
ii compiz-gnome 1:0.8.2-0ubuntu8 OpenGL window and compositing manager - GNOM
ii compiz-plugins 1:0.8.2-0ubuntu8 OpenGL window and compositing manager - plug
ii compiz-wrapper 1:0.8.2-0ubuntu8 OpenGL window and compositing manager, wrapp
ii compizconfig-backend-gconf 0.8.2-0ubuntu2 Settings library for plugins - OpenCompositi
ii compizconfig-settings-manager 0.8.2-0ubuntu1 Compiz configuration settings manager
ii emerald 0.7.2-0ubuntu2 Decorator for compiz-fusion
ii libcompizconfig0 0.8.2-0ubuntu1 Settings library for plugins - OpenCompositi
ii libemeraldengine0 0.7.2-0ubuntu2 Decoration engines for compiz-fusion
ii python-compizconfig 0.8.2-0ubuntu1 Compiz configuration system bindings

i'm having this same issue but the "commands plug in enabled" didn't solve it

same modified keys...
/apps/metacity/keybinding_commands/command_1
/apps/metacity/global_keybindings/run_command_1

and commands plug in enabled, when i checked, the settings are there but nothing happens

i also found this but there but they are not changed at all
/apps/compiz/plugins/commands/allscreens/options/command0
/apps/compiz/plugins/commands/allscreens/options/run_command0_key

i tried every possible combination with those 4 entries but nothing happens

Jeremy A (jtheoof) wrote :

The solution provided by Irfan Adilovic fixed the issue on my jaunty as well. Thanks.

Changed in compiz (Ubuntu):
importance: Undecided → Low
Changed in metacity (Ubuntu):
importance: Undecided → Low
Changed in compiz (Ubuntu):
status: New → Invalid
importance: Low → Medium
status: Invalid → Triaged
Changed in metacity (Ubuntu):
status: New → Invalid
summary: - metacity keybindings for global commands don't work in compiz
+ enable commands plugin
Travis Watkins (amaranth) wrote :

This is fixed in the compiz packaging bzr repo. The fix will be included in the next upload of compiz to karmic.

Changed in compiz (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.3+git20091005-0ubuntu5

---------------
compiz (1:0.8.3+git20091005-0ubuntu5) karmic; urgency=low

  * New snapshot from upstream stable git:
     - compiz.real crashed with SIGSEGV in blurDrawWindow()
       (LP: #353236)
     - Windows disappear if resolution is changed to something smaller
       than window size (LP: #414134)
     - compiz.real crashed with SIGSEGV in handleEvent() (LP: #430518)
     - Windows that span screen width or height cannot be resized
       in that dimension (LP: #137134)
     - Reducing number of workspaces leaves windows inaccessible
       (LP: #189259)
     - "Snap Inverted" in Wobbly Windows compiz plugin broken
       (LP: #366822)
     - Problem when resizing and the Panels
       (LP: #408030)
  * debian/control:
    - make compiz package depend on compiz-gnome | compiz-kde (LP: #172385)
  * debian/patches/015_draw_dock_shadows_on_desktop.patch:
    - fix clock/calendar shadow not going away (LP: #428783)
      thanks to Erkin Bahceci
  * debian/patches/029_default_options:
    - add a focus prevention match to allow polkit windows to steal focus
      otherwise they never get focus (LP: #436852)
  * debian/compiz-gnome.gconf-defaults:
    - change /apps/gwd/blur_type to all since it only does anything if blur
      is enabled and is usually what is wanted (LP: #158376)
    - turn constrain_y back on (LP: #82654)
  * debian/rules:
    - add commands plugin to default active_plugins (LP: #355018)

 -- Travis Watkins <email address hidden> Mon, 05 Oct 2009 15:42:00 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
singh (singh-arsh) wrote :

Thanks enabling commands in compiz manage (first icon in compiz manager ), and giving commands in there solved it.
:) thanks

randomubuntuguy (john4lists) wrote :

Since 8.04->10.04, this was the greatest usability f-up i've experienced with Ubuntu. Maybe that is because i used xubuntu until I recently got a new computer and never turned on the visualizations.

However, if this is not considered an "urgent" bug, it seems like some user hints in the keyboard settings would be very important. (like hey buddy, your keyboard may act crazy due to the appearance changes you made)

I think this should be an URGENT issue due to the likelihood that many novice users would give up on Ubuntu before they made it to the smart work around above.

They could get locked out of any program that required entering capital letters or symbols. What a turn off to beginners.

System->Appearance->Visual Effects->Normal

Toggling visual effects from default to Normal should not eliminate the ability to do everyday tasks.

I could see a scenario where a user becomes locked out of their computer, website, email or whatever because they can no longer type the symbols or capital letters in their password.

The natural place to try to fix this would be the "keyboard" settings. However, the bug is really only avoided by turning off the "normal" visual effects.

Turning this on has also led to minor annoyances like inability to type due to loss of the proper focus.

A proper fix for now would be to have a button "restore default key bindings" for this device and user profile. keyboard (or input device settings) preferences.

WoW! Incredible how such a thing can persist.
I'm on Ubuntu 10.10 (so the beta); shift key stopped to work; after a compiz' configuration reset through compizconfig-settings-manager it restarted to work properly.
Compiz at the moment is at verison 0.8.6.

Cheers

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers