Evince sticks at "Loading..." on start

Bug #210313 reported by Hew on 2008-04-01
This bug report is a duplicate of:  Bug #256048: Loading PDF file hang on Loading.... Edit Remove
8
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned
evince (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

Evince displays the "Loading..." screen when it starts upon opening a document, and it doesn't show the document unless the window is either minimised and maximised, or unmaximised. This only happens when running compiz; metacity works fine.

I'm unsure how common this occurrence is for me yet because my testing keeps triggering bug #189257, causing an immediate resize.

Running evince 2.22.0-0ubuntu2 and compiz 1:0.7.2-0ubuntu2 on hardy.

ProblemType: Bug
Architecture: amd64
Date: Wed Apr 2 02:39:28 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: evince 2.22.0-0ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
SourcePackage: evince
Uname: Linux 2.6.24-12-generic x86_64

Hew (hew) wrote :
Sebastien Bacher (seb128) wrote :

seems to be a rendering issue

Erik Hill (thepurr) wrote :

I can confirm this bug.

Acer Aspire 5630 - Intel 945 video chipset, Hardy with latests 4/9/2008 updates.

Hew (hew) on 2008-04-11
Changed in compiz:
status: New → Confirmed
Cinar Sahin (csahin) wrote :

I confirm this bug.

hardy
nvdia 8800GT (169.12)
compiz enabled

Hew (hew) wrote :

Still an issue with evince 2.22.2-0ubuntu1 and compiz 1:0.7.4-0ubuntu7 on Hardy.

Changed in compiz:
importance: Undecided → Low
status: Confirmed → Triaged
Hew (hew) wrote :

I don't remember seeing this issue on Intrepid; can anyone confirm this?

compiz/intrepid uptodate 1:0.7.7+git20080807-0ubuntu2
evince/intrepid uptodate 2.23.6-0ubuntu1

Cian Davis (davisc) wrote :

Confirmed on Hardy x86_64 and i386. Only started with Hardy. Here is the relevant strace output (message repeats indefinitely)

gettimeofday({1219525692, 914970}, NULL) = 0
stat64("/home/cian/.recently-used.xbel", {st_mode=S_IFREG|0644, st_size=409167, ...}) = 0
read(3, 0x80be83c, 4096) = -1 EAGAIN (Resource temporarily unavailable)
gettimeofday({1219525692, 915664}, NULL) = 0
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN, revents=POLLIN}, {fd=8, events=POLLIN|POLLPRI}, {fd=11, events=POLLIN|POLLPRI}, {fd=12, events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}, {fd=15, events=POLLIN}, {fd=14, events=POLLIN}, {fd=10, events=POLLIN|POLLPRI}], 9, 4999) = 1
read(3, "\241 \226\6\3\0\0\4\36\1\0\0%\1\0\0\6\34\0\0\3\0\0\4\0"..., 4096) = 32
read(3, 0x80be83c, 4096) = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], [3], NULL, NULL) = 1 (out [3])
writev(3, [{"\31\0\v\0W\0\0\0\0\0\30\0! \0\0W\0\0\0\36\1\0\0%\1\0\0"..., 44}], 1) = 44
read(3, 0x80be83c, 4096) = -1 EAGAIN (Resource temporarily unavailable)
read(3, 0x80be83c, 4096) = -1 EAGAIN (Resource temporarily unavailable)

Hew (hew) wrote :

This only happens with compiz, so it is assumed to be a compiz issue. Closing for evince.

I still have not seen this on Intrepid, so I'm pretty sure this has been fixed in compiz 0.7.7. I am therefore closing this issue against compiz (it does not qualify for Hardy SRU). Please reopen against compiz if you experience the problem on Intrepid.

Changed in evince:
status: New → Invalid
Changed in compiz:
status: Triaged → Invalid
exzemat (exzemat) wrote :

i confirm this bug
i have installed acrobat reader
no probleme with acrobate

exzemat (exzemat) wrote :

when you tape "F5" (full screen) the probleme disapear

Hew (hew) wrote :

I can now reproduce this issue with evince in metacity, so it's not a compiz issue.

evince/intrepid uptodate 2.23.92-0ubuntu1

Changed in evince:
importance: Undecided → Low
status: Invalid → New
Chris Coulson (chrisccoulson) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 256048, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Changed in evince:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers