Ubuntu

Window open animation should be glide 2 instead of glide 1

Reported by David Prieto on 2008-02-26
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
compiz (Ubuntu)
Wishlist
Unassigned
compiz-fusion-plugins-main (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: compiz

Related to https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/139933

Many users in http://ubuntuforums.org/showthread.php?t=670388 agree that glide 1 is not a suitable animation for opening windows, as it results obstrusive. Glide 2 would make a better default.

Changed in compiz:
importance: Undecided → Wishlist
Murat Gunes (mgunes) on 2008-02-27
Changed in compiz:
status: New → Triaged
summary: - "open" animation should be set to glide 2, not glide 1
+ Set "open" animation to glide 2, not glide 1

Duplicate bug 387429 was confirmed as a papercut

Changed in hundredpapercuts:
status: New → Confirmed
seanh (seanh) wrote :

+1 for just having windows quickly fade in and out when opened and closed, no glide animation at all (as suggested by someone on the duplicate bug 387429). A subtle fade is classy, it's attention to detail. Windows flying around in three dimensions is over the top and distracting.

I think this is an example of when a detail is done right it improves your experience of the interface but you might not consciously notice it. It's like in Winamp when you stop playing the track or close Winamp. Instead of suddenly stopping it quickly fades out. It's subtle so you might not even notice it at first, but nonetheless it makes the user experience smoother, and when you do notice it you really appreciate the attention to detail. It also fades in when you start and crossfades between tracks.

The audio equivalent of a glide animation would be if Winamp played a loud "Whoooosshh!" and "Shhhhooooooppp!" each time you started and stopped playing :)

Changed in hundredpapercuts:
milestone: none → round-1
status: Confirmed → Triaged
Michael Rooney (mrooney) wrote :

Yeah, I'd personally suggest either changing Open to "Glide 2" or changing both Open and Close to "Fade". I agree that fading is more elegant and subtle, but that is likely subjective. The current is a little distracting / in your face.

Dries Harnie (dharnie) wrote :

Attached is a patch to change the default animation for open from "Glide 1" to "Glide 2". I noticed that an earlier patch reset the open behavior from Zoom to Glide 1.

This patch has to be applied after that one (01-animation-defaults.patch), hence the name.

This patch has been tested on my desktop (Jaunty) and the default behavior is "Glide 2", but only for new users, which is normal.

I'm having it tested on a Karmic box but that will take a while..

Changed in hundredpapercuts:
status: Triaged → In Progress
Changed in compiz-fusion-plugins-main (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Robert Ancell (robert-ancell) wrote :

Thanks for the patch Dries. I have tested it on Karmic and it works and have proposed this change for upload to Karmic.

Robert Ancell (robert-ancell) wrote :

Sean, Michael, I have opened bug 392368 which is a wishlist request to change the default animation from glide to fade.

Changed in compiz-fusion-plugins-main (Ubuntu):
status: Triaged → In Progress
Martin Pitt (pitti) on 2009-06-29
Changed in compiz (Ubuntu):
status: Triaged → Invalid
Martin Pitt (pitti) wrote :

This is confusing me. This bug and bug 392368 both ask for changing the default animation, but here to "glide2" and there to "fade". What to do here?

Martin, I think most people here have agreed that fade is even better and less obstrusive than glide2. I proposed glide2 because I found it better than glide1, but even I think that fade would be better.

summary: - Set "open" animation to glide 2, not glide 1
+ Make window open animation the same as close animation (glide 2)

On Mon, Jun 29, 2009 at 12:17 AM, David Prieto wrote:
> Martin, I think most people here have agreed that fade is even better
> and less obstrusive than glide2. I proposed glide2 because I found it
> better than glide1, but even I think that fade would be better.

Yes, maybe we should just mark that as a dupe of this and alter the
descriptions / patch to fade.

The Fiddler (stapostol) wrote :

Personally, I prefer the glide 2 animation for windows. Fade feels like
a better fit for 'transitive' windows, like menus or dialogs. The glide
2 animation is a tweaked fade with slightly more impact - which
conceptually fits application windows (they have more impact than simple
menus).

The difference is subtle though and I don't feel strongly for it. I just
felt a strange vibe when I used the KDE compositor, which I eventually
linked to the fade-in animation: application windows behaved exactly
like menus!

The design decision is to use glide 2 for both Open and Close to complete this paper cut. Please do not change to fade.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-fusion-plugins-main - 0.8.2-0ubuntu5

---------------
compiz-fusion-plugins-main (0.8.2-0ubuntu5) karmic; urgency=low

  * debian/patches/01-animation-defaults.patch: Set open animation to Glide 2,
    patch from Dries Harnie (LP: #195737)

 -- Robert Ancell <email address hidden> Fri, 26 Jun 2009 10:24:30 +1000

Changed in compiz-fusion-plugins-main (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) on 2009-07-03
Changed in hundredpapercuts:
status: In Progress → Fix Released
summary: - Make window open animation the same as close animation (glide 2)
+ Window open animation should be glide 2 instead of glide 1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers