apt-get install ubuntu-desktop doesn't work

Bug #1749840 reported by Gary Gatling
294
This bug affects 56 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

So I used mini.iso from:

http://archive.ubuntu.com/ubuntu/dists/xenial-updates/main/installer-amd64/curre
nt/images/netboot/mini.iso

Installed a minimal ubuntu install.

sudo to root and run

apt-get install ubuntu-desktop

This is the output:

root@ubuntu:~# apt-get install ubuntu-desktop
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ubuntu-desktop : Depends: unity but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

We noticed this on our foreman server today so I tried it in a minimal install from iso and it gives the same error. We suspect this was a recent change that was made.

We think there is a dependency problem with compiz-core

See:

https://pastebin.com/Z4cpydeZ

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: compiz-core 1:0.9.12.3+16.04.20171116-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-112.135-generic 4.4.98
Uname: Linux 4.4.0-112-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
Date: Thu Feb 15 18:19:15 2018
ProcEnviron:
 SHELL=/bin/bash
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Gary Gatling (gsgatlin) wrote :
tags: added: compiz-0.9
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Revision history for this message
Seth Arnold (seth-arnold) wrote :

I believe this bug was fixed when this package was released to the archive mirrors:

https://launchpad.net/ubuntu/+source/unity/7.4.5+16.04.20171201.3

Thanks

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Gary Gatling (gsgatlin) wrote :

Its working now. Thanks a lot.

Revision history for this message
Mike Van Pelt (mvp-d) wrote :

Same here - I ran the update just now, and it worked fine.

Revision history for this message
Lance Lascari (consulting-1) wrote :

same here

Revision history for this message
ironmikezero (ironmikezero) wrote : Re: [Bug 1749840] Re: apt-get install ubuntu-desktop doesn't work

It's been working for over 24 hours--Great! Many thanks!

On Fri, Feb 16, 2018 at 10:52 AM, Lance Lascari <email address hidden>
wrote:

> same here
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1749847).
> https://bugs.launchpad.net/bugs/1749840
>
> Title:
> apt-get install ubuntu-desktop doesn't work
>
> Status in compiz package in Ubuntu:
> Fix Released
>
> Bug description:
> So I used mini.iso from:
>
> http://archive.ubuntu.com/ubuntu/dists/xenial-updates/
> main/installer-amd64/curre
> nt/images/netboot/mini.iso
>
> Installed a minimal ubuntu install.
>
> sudo to root and run
>
> apt-get install ubuntu-desktop
>
> This is the output:
>
> root@ubuntu:~# apt-get install ubuntu-desktop
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
> ubuntu-desktop : Depends: unity but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
>
>
> We noticed this on our foreman server today so I tried it in a minimal
> install from iso and it gives the same error. We suspect this was a recent
> change that was made.
>
>
> We think there is a dependency problem with compiz-core
>
> See:
>
> https://pastebin.com/Z4cpydeZ
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: compiz-core 1:0.9.12.3+16.04.20171116-0ubuntu1
> ProcVersionSignature: Ubuntu 4.4.0-112.135-generic 4.4.98
> Uname: Linux 4.4.0-112-generic x86_64
> ApportVersion: 2.20.1-0ubuntu2.15
> Architecture: amd64
> Date: Thu Feb 15 18:19:15 2018
> ProcEnviron:
> SHELL=/bin/bash
> TERM=xterm
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SourcePackage: compiz
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/
> 1749840/+subscriptions
>

Robie Basak (racb)
tags: added: regression-update
To post a comment you must log in.