Ubuntu

gtk-window-decorator does not react to GNOME DPI changes

Reported by Mike Basinger on 2007-09-19
84
Affects Status Importance Assigned to Milestone
Compiz
Fix Released
Unknown
compiz (Ubuntu)
High
Unassigned
Nominated for Hardy by Benjamin Drung

Bug Description

compiz and gtk-window-decorator are started before gnome-settings-daemon and thus do not get the same DPI as other GNOME apps. It also does not react to DPI changes after both are started.

Jan Mynarik (jan-mynarik) wrote :

Same here, it appears for me in let's say 1 of 3 logins. Faster work-around is to run 'gtk-window-decorator --replace &' from terminal.

It is pretty annoying bug :-)

Current compiz version: 1:0.5.2+git20070918-0ubuntu3 but it happened with earlier version as well.

Changed in compiz:
status: New → Confirmed
Markus Jonskog (omljud) wrote :

Yes, I have that problem too. It's always like that on first login. I kept adjusting the font size, which sometimes suddenly became too small instead. Silly me. Then I got it that it was simply something with the desktop effects or just gtk-window-decorator.

Yes, it's annoying. :-)

Tim Hull (thully) wrote :

Here is a picture of the large fonts in question...

Tim Hull (thully) wrote :

And here is a picture of normal fonts to compare...

Martin Brunthaler (mbrunthaler) wrote :

I can confirm this behavior on my machine, too. Running on fglrx + compiz in gutsy. Restarting the decorator service fixes the problem temporarily.

Tim Hull (thully) wrote :

This seems to have been fixed with recent uploads. Closing.

Changed in compiz:
status: Confirmed → Fix Released
Martin Brunthaler (mbrunthaler) wrote :

The issue still persists. All recent updates are installed, upon rebooting the machine the titles are being displayed using large fonts again.

I still can't reproduce anymore here - maybe your mirror is behind or this
issue is one that is very hardware/settings specific.
One question - could you try changing the desktop effects settings to
maximum, then back to normal effects, and then rebooting? That may have
been what fixed it for me instead of a package update.

On 10/12/07, mbrunthaler <email address hidden> wrote:
>
> The issue still persists. All recent updates are installed, upon
> rebooting the machine the titles are being displayed using large fonts
> again.
>
> --
> Large fonts in window titles
> https://bugs.launchpad.net/bugs/141001
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Already tried changing the configuration but did not help either. Here's a list of compiz related packages that are installed.

compiz 1:0.6.0+git20071008-0ubuntu1
compiz-core 1:0.6.0+git20071008-0ubuntu1
compiz-fusion-plugins-extra 0.5.2+git20070928-0ubuntu1
compiz-fusion-plugins-main 0.5.2+git20070928-0ubuntu2
compiz-gnome 1:0.6.0+git20071008-0ubuntu1
compiz-plugins 1:0.6.0+git20071008-0ubuntu1
compizconfig-settings-manager 0.5.2+git20070912-0ubuntu1
gnome-compiz-manager 0.10.3-0ubuntu2
libcompizconfig-backend-gconf 0.5.2+git20071010-0ubuntu1
libcompizconfig0 0.5.2+git20070919-0ubuntu3
libdecoration0 1:0.6.0+git20071008-0ubuntu1
libgnome-compiz-manager0 0.10.3-0ubuntu2
python-compizconfig 0.5.2+git20070912-0ubuntu1

Tim Hull (thully) wrote :

Reopening since it started happening again...

Changed in compiz:
status: Fix Released → New
Tim Hull (thully) wrote :

This also happens, independently of when it happens in other applications, in OpenOffice.org. As is the case with the title bar fonts, it occurs sporadically.

jasbur (jasbur) wrote :

Not sure if this is related. But, I have VERY large fonts (screenshot attached). It seems to be about a 10x increase from the set font size. If I set the size to 1pt it look like a 10pt font. This effects window titles and the login window.

Jan Mynarik (jan-mynarik) wrote :

My guess is that it's related to DPI. I think the DPI is probably changed during gnome startup and if compiz gets started before this change, it has got big fonts in titles. If it's started later, it's OK.

Also note that I've got this problem on a new computer with Gutsy RC installed too.

jasbur (jasbur) wrote :

It is a dpi problem. Apparently it has something to do with compiz starting before gdm ( or the other way around). drvista on the ubuntu forums managed to find a fix though. It worked for me at least.

In /etc/gdm/gdm.conf change:

[server-Standard]
name=Standard server
-command=/usr/bin/X -br -audit 0

to

[server-Standard]
name=Standard server
-command=/usr/bin/X -br -audit 0 -dpi 96

Tim Hull (thully) wrote :

Any way we could get a patch for this in Gutsy? It seems like the patch would simply have to ensure compiz starts in the right order...

joris (joris-dobbelaer-gmail) wrote :

Can conform this bug and the work around suggested in the forums worked for me as well

Jimmygoon (jimmygoon) wrote :

I was having a somewhat similar problem in the beta and I just kind of waited it out. The problem seemed to come and go with updates. I even had the problem on the very first run after my new install. My resolution was to set the font to '1' which worked for a while. Then (maybe an update) caused it to remedy itself until I restarted again today... and when it booted back up it was messed up again...

anyhow, here's a screenshot with the large window title bar font and the font appearance dialog so you can see what I'm saying.

btw, this isn't large fonts compared to y'alls screenshots... they are huge!

Mikael Nilsson (mini) wrote :

Has been confirmed enough....

Changed in compiz:
status: New → Confirmed
Mikael Nilsson (mini) wrote :

I also see this problem, and it's most likely due to bad interaction between gtk-window-decorator and gnome-settings-daemon. I think gtk-window-decorator does not react to changes in DPI the way it should.

Try opening Settings->Appearance->Fonts->Details... and modify the DPI. All fonts change, except window title fonts.

Changing the title *font* does trigger an update though, so gwd is provably capable of handling it.

Benjamin Drung (bdrung) wrote :

I have this bug too. I also think that this problem is due to bad interaction between gtk-window-decorator and gnome-settings-daemon.

I have changed the DPI from 125 to 96 in Settings->Appearance->Fonts->Details... All fonts change, except window title fonts.

But if I restart gtk-window-decorator the window title font size gets normal.

uname -a
Linux hammy 2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU/Linux

same problem here and compiz is not the reason. I have huge GDM font so far before to start compiz (if I'm want to do it). It's a little bit better in the sessio I'm login in but some software like firefox does have big fonts for the menu.

Nicolas,

It seems to me you're experiencing a different bug, probably due to wrong dpi settings.

This bug is about gtk-window-decorator not acting on dpi *changes*.

Please report a new bug.

------- Original message -------
From: Nicolas Gruel <email address hidden>
Sent: 30/10, 17:10

> same problem here and compiz is not the reason. I have huge GDM font so
> far before to start compiz (if I'm want to do it). It's a little bit
> better in the sessio I'm login in but some software like firefox does
> have big fonts for the menu.
>
> --
> Large fonts in window titles
> https://bugs.launchpad.net/bugs/141001
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Hi all.

An update to state that (very) large fonts are also present in window titles in Hardy Heron 8.04.

They are apparent upon first install but disappear immediately upon changing Visual Effects from "Normal" to "None" in System / Preferences / Appearance.

Note. I can also confirm that, as mentioned before, very large fonts are used by default on the Ubuntu login screen such that the boxes into which I type the login and password are like a "window" to a font that is 5 times larger than the box will show.

My screen resolution is (widescreen) 1280x800 and my display hardware is as follows:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Hope this helps, Rob

Thanks Rob that helped!

I had the same problem with the same hardware.

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

- AOK

Michiel Sikma (msikma) wrote :

I have this too. The window title font is slightly larger than it should be. I actually thought this was a feature! To be honest, I like it; the window title is important on-screen information, so it made sense to me that it would be a little bigger.

Maybe once you fix this bug, I'll go talk to the Ubuntu Artwork team to make the title font a bit larger for everybody for the next release cycle. ;)

montaropdf (r-everaert) wrote :

I have the same problem with the following hardware:

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

The problem is even worst with KDE, where every fonts are huge.

montaropdf (r-everaert) wrote :

After trying the fix to gdm.conf, proposed above, the problem doesn't appear anymore even in KDE.

Rockallite (rockallite-wulf) wrote :

I confirm that jasbur's fix works for me. Title fonts will never become larger or smaller after I log in.
(Ubuntu Gutsy + compize + emerald)

freedumb (freedomflynn) wrote :

I have tried the fix to the gdm.conf suggested here and it does not fix this for me. I have the same

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

On a Toshiba A105-4047

I have resolution set at 1280x800 with Gusty install. This has been a problem since I did complete install of Gutsy 2 days ago I am new to linux and love it. I would like to ¨show it off¨ to people and this would not be a very good thing with the titlebars showing extremely huge (this is intermittent) but the splash login screen is always that way with the login and password being very huge in the login box and I cannot click options etc on the screen since it makes them very huge as well. Can post screen shots if needed it looks the ones already posted with the really huge title bars. Help would be mush appreciated.

Travis Watkins (amaranth) wrote :

Oops, changed the wrong bug. Moving back to compiz.

description: updated
Changed in compiz:
importance: Undecided → High
Benjamin Drung (bdrung) wrote :

The bug is also in the current version of hardy. Testet with compiz 1:0.6.99+git20080102-0ubuntu3 und a Intel graphics card.

mark (powerofslack) wrote :

Confirmed in nvidia g70 (geforce7300T) 1152x864 w compiz 1:0.6.2+git20071119-0ubuntu1~gutsy1 64 bit, using emerald. Mine makes the font bigger or alternately smaller on every other reboot, so that I have to switch it in the emerald (0.3~git20070717-0ubuntu1) theme prefs from about 18 pt to 10 pt or vice versa every reboot to keep it normal looking. Haven't tried the --replace yet thx.

Youssef (that-y-guy) wrote :

I had the same problem too on my friend's laptop. But i don't understand why a fix hasn't been released yet ?! Must we wait for hardy to deal with the issue ? shouldn't compiz-fusion be supported by canonial ?

Changed in compiz:
status: Unknown → Confirmed
Changed in compiz:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

Fixed upstream, thanks for reporting.

Changed in compiz:
status: Confirmed → Fix Committed
Changed in compiz:
status: Fix Committed → Fix Released
Ahmed Saeed (ah-seed) wrote :

Hi every one

did any one found fixed this problem ??
i face the same problem also but currently i solve it by logging out and login again ..
or .. some times enable or disable the assistive technology <just make the opposite of the current case> i don't know the relation with it !!!

Travis Watkins (amaranth) wrote :

Yes, it is fixed in Ubuntu 8.04 (as noted in the bug status).

Mike Basinger (mike.basinger) wrote :

Fixed for me since Hardy Alpha 3.

Still an issue for me (slightly)....gdm is not fixed (logging in), however upon logging in everything works, EXCEPT for applications such as r-base when plotting graphics, etc. The solution for me is to adjust gdm.conf through System->Administration->Login Window->Security->Configure X Server and adding "-dpi 96" to the end of the line "Command"

Travis Watkins (amaranth) wrote :

That is a generic "X has the wrong DPI" and "applications don't get DPI from gnome-settings-daemon" thing. The first should be fixed, the second is not a bug because only GTK+ apps will do that.

This bug is specific to gtk-window-decorator not listening to gnome-settings-daemon which is a bug because it is a GTK+ application.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.