Compiz mouse functions mapped to horizontal scrolling buttons do not work

Bug #1311303 reported by dominus_sapiens on 2014-04-22
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Christopher Townsend
0.9.11
Medium
Christopher Townsend
compiz (Ubuntu)
Medium
Christopher Townsend
Trusty
Undecided
Unassigned

Bug Description

[Impact]

Users who have the horizontal scroll button mapped to other functions using CCSM no longer have working mapped functions. This breaks the user's workflow.

[Test case]

* Need a mouse with horizontal scrolling, ie, click the mouse wheel left and right.
* Open CCSM.
* Map a function to the horizontal scroll buttons, ie, buttons 6 & 7. For example:
  * Enable workspaces.
  * CCSM->Viewport Switcher->Desktop-based Viewport Switching
  * Set "Move Next" to button 6 and "Move Prev" to button 7.

[Regression potential]

When a user has a function mapped to the horizontal scroll buttons, horizontal scrolling in windows that support horizontal scrolling will no longer work. The user must recognize that when they map the function, they loose the original functionality. This is the same case in previous versions of Ubuntu before this regression occurred, so no real regression potential.

* Debdiff is found at https://launchpadlibrarian.net/178439518/compiz-trusty-sru-2.debdiff *

Original Description:

Running Ubuntu 14.04 and compiz 0.9.11.

Upon upgrading to 14.04 I can no longer use mouse buttons to switch between desktops in the Desktop Wall when a maximised window is focussed. It works as expected when using keyboard functions, or when the desktop is focussed.

Related branches

Christopher Townsend (townsend) wrote :

Hi,

Thank you for reporting this bug. Which mouse buttons are you using to switch workspaces? Are you using any modifier, such as Alt or Control, to do this as well?

Thanks!

Changed in compiz (Ubuntu):
status: New → Incomplete
description: updated
description: updated

Thanks for getting in touch.

I'm using buttons 6 and 7, which on my mouse are on the sides of the scroll wheel. This is without any keyboard modifiers.

Using keyboard shortcuts to do the same thing (ctrl+alt+left/right) works as expected whether a window is focussed or not.

There's something odd I discovered today while testing things a bit more: it works as expected when the window is minimised, but the problem occurs again where the window is maximised or when it is minimised and snapped to the top left corner. This is rather bizarre, and I wonder whether it may have something to do with the way windows are handled in 14.04.

The problem also occurs when there are no active windows and the desktop is not focussed, but since keyboard shortcuts also fail to work in this situation, I suspect this is a different bug.

I have updated the bug description accordingly.

Christopher Townsend (townsend) wrote :

Thanks for the additional info. This is due to a fairly recent change I put in to make scrolling in unfocused Gtk window work. I was a little too heavy handed on horizontal scrolling, ie, buttons 6 & 7.

I don't think horizontal scrolling is used too much and besides, if someone explicitly maps those buttons to Compiz functions, then they shouldn't expect horizontal scrolling in windows to work any more.

I'll work on a fix and hopefully get it landed in an upcoming Compiz SRU for 14.04

summary: - Unable to switch desktops using compiz mouse functions
+ Compiz mouse functions mapped to horizontal scrolling buttons do not
+ work
Changed in compiz (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Christopher Townsend (townsend)

I thought it might have been Gtk related; very many thanks for working on a fix.

I notice now that horizontal scrolling inside windows is behaving better, but as you say, if someone is going to map functions themselves, they probably want those functions to take precedence.

Changed in compiz:
status: Triaged → In Progress
Changed in compiz (Ubuntu):
status: Triaged → In Progress
Changed in compiz:
milestone: none → 0.9.11.0
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.10.20140606-0ubuntu1

---------------
compiz (1:0.9.11+14.10.20140606-0ubuntu1) utopic; urgency=low

  [ Chris Townsend ]
  * Only ungrab the Mod2Mask modifier on buttons 4-7 to allow scrolling
    in unfocused Gtk windows while still allowing keybinding modifiers
    to other scroll wheel actions. (LP: #1311788)
  * Fix issue where window decorations would be placed under the Panel
    when opening a new window from an already open window. This is due
    to the already open window being taller or just as tall without be
    maximized than the workspace. (LP: #1303462)
  * Only constrain the non-modifier scrolling to the vertical scrolling
    buttons - buttons 4 & 5. (LP: #1311303)
  * Fix issue where maximized windows would get moved to different
    workspaces when disconnecting/connecting an external monitor.
    Windows should stay in the same workspace they are in when the
    monitor event occurs. (LP: #1304531)
  * Fix issue where custom keyboard shortcuts would get reset to
    defaults when rebooting or restarting Compiz. (LP: #1063617)
  * Fixes issue in the Expo plugin where a gap is shown in the place
    where the Launcher and Panel should be when windows are maximized.
    This was originally removed in rev. 3481. (LP: #1087090)
  * Fix issue where horizontal and vertical keyboard resizing could not
    happen at the same time. (LP: #347390)

  [ Marco Trevisan (Treviño) ]
  * Scale: use XShape extension to exclude dnd input in the screen-parts
    outside workArea This will work property also in multi-monitor,
    without requiring multiple X windows for each output device. Also
    don't terminate the scale unless a drag-n-drop action is not really
    over. Add a spinner that shows up over a window, during the DnD
    timeout. Plus, make sure we terminate the scale without focusing the
    selected icon when cancelling it and some code cleanup (LP: #607796)
  * Event: set the screen grabbed also when we get a NotifyWhileGrabbed
    Focus{In,Out} event (LP: #1305586)
 -- Ubuntu daily release <email address hidden> Fri, 06 Jun 2014 09:43:06 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in compiz:
milestone: 0.9.11.0 → 0.9.12.0
status: In Progress → Fix Committed
description: updated

Hello dominus_sapiens, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.1+14.04.20140617-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
description: updated
Chris J Arges (arges) wrote :

Hello dominus_sapiens, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.1+14.04.20140623-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Christopher Townsend (townsend) wrote :

Hello dominus_sapiens, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.1+14.04.20140701-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Stephen M. Webb (bregma) wrote :

Verified this change works for me, using buttons 8 and 9 (reported by my mouse instead of buttons 6 and 7).

tags: added: verification-done
removed: verification-needed

I can confirm that this change works for me also.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11.1+14.04.20140701-0ubuntu1

---------------
compiz (1:0.9.11.1+14.04.20140701-0ubuntu1) trusty; urgency=medium

  [ Chris Townsend ]
  * Bump version to 0.9.11.1.

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Tue, 01 Jul 2014 11:51:26 +0000

Changed in compiz (Ubuntu Trusty):
status: Fix Committed → Fix Released
Jack Choy (choyj2000) wrote :

I'm using compiz 1:0.9.11.2+14.04.20140714-0ubuntu1.

In Ubuntu 12.04, we were able to map buttons 6 and 7, but with the latest changes in 14.04, I am only able to map buttons 6 and 7 with a keyboard modifier.

Is there a way to get the past behavior back, i.e. using buttons 6 and 7 without a modifier?

Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers