Update manager is really small and not resizeable

Bug #1301776 reported by Oscar Tiderman on 2014-04-03
164
This bug affects 49 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Marco Trevisan (Treviño)
7.2
Fix Released
High
Marco Trevisan (Treviño)
compiz (Ubuntu)
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Trusty
High
Unassigned

Bug Description

[ Impact ]
update-manager 1:0.196.9, Ubuntu Trusty

Update manager's window, and especially its fields inside the window, are way too small and also it's not resizeable, making it almost useless at least on my HiDPI screen (3200 x 1800).
https://launchpadlibrarian.net/171657786/update-manager-is-small.png

<https://wiki.ubuntu.com/SoftwareUpdates#expanded>: "The Updates Available window should be manually resizable only when it is in this expanded state."

[ Test Case ]

Run the Ubuntu update manager and attempt to resize the window. See above.

[ Regression Potential ]

Any code change to the Unity desktop shell has the potential to introduce new crashes or lockups.

[ Additional Info ]

The Unity SRU fix for Ubuntu 14.04 LTS was cherry-picked from Ubuntu 14.10 where it has been in production use for some time without apparent regressions.

Related branches

Oscar Tiderman (oscar-tiderman) wrote :
Oscar Tiderman (oscar-tiderman) wrote :
Sebastien Bacher (seb128) wrote :

Confirmed on trusty, not sure if the issue is with compiz or update-manager though. Michael, could you have a look?

Changed in update-manager (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → High
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Hey Marco, could you have a look.

We discussed that before and you said it was probably a compiz/unity issue (see http://irclogs.ubuntu.com/2014/03/11/%23ubuntu-desktop.html#t18:52)

"so, I guess it's something like that it doesn't notify us properly when it changes its alowed actions, or, we don't update when it asks (afaik I ignored some changes that were duplicated)"

Changed in compiz (Ubuntu Trusty):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
status: New → Triaged
Changed in unity:
importance: Undecided → High
status: New → Triaged
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
description: updated
Jan Henke (jhe) wrote :

Not sure it is Compiz, the same problem also happens with Xubuntu, which does not use Compiz if I remember correctly.

Anyway it is severely affecting the usability of the application.

x (xyzx-deactivatedaccount) wrote :

As a workaround, right click on the title bar and choose the "Resize" entry.

Changed in unity:
milestone: none → 7.3.0
no longer affects: unity/7.3
Changed in unity:
status: Triaged → In Progress
Changed in update-manager (Ubuntu):
status: Confirmed → Invalid
Changed in update-manager (Ubuntu Trusty):
status: Confirmed → Invalid
apsaras (c-launchpad1) wrote :

I agree with comment #5. I am using Xubuntu 14.04, and I'm not using compiz as far as I know, but I am still experiencing this non-resize problem with update-manager. Can someone explain why this has been marked as a compiz problem and why it has been marked as Invalid for Trusty? Thanks.

Re comment #6: the workaround does not work for me.

Jan Henke (jhe) wrote :

I support comment #7.

Metta Crawler (metta-crawler) wrote :

Re comment #6

With a mouse or tracball etc. (not a touchscreen):

1. Right click on the title bar of the window to be resized.
2. A menu will pop up. Choose "resize" from it.
3. The pointer will jump (warp) to the center of the window.
4. Do not click yet. Move the pointer past the edge of the window in the direction you wish to resize (enlarge).
5. Once the desired resize has been achived then click the mouse or tracball etc.

Metta Crawler (metta-crawler) wrote :

Re comment #6

The reason this titlebar menu resize contraption exists is that it is part of UI accessibility. You can use the keyboard to control the resize procedure.

Jan Henke (jhe) wrote :

Re: comment #10 & #6

Exactly this menu item is deactivated (greyed out), it really seems like the window is made non-resizeable. So the bug is still far from being fixed.

Metta Crawler (metta-crawler) wrote :

@Jan Henke - the titlebar resize menu item is not grayed out on my 14.04 system. I'm not using Xubuntu. I have the "ubuntu-desktop" meta package installed.

Jan Henke (jhe) wrote :

@Metta Crawler: But this bug report is about the fact, that in some circumstances it becomes greyed-out (deactivated). This bug was filed to raise the issue and get somebody to look into the reason for it.

That is works on your system is fine, but is not helpful here. It reproducibly does not work on my system, and it would really be helpful to get it fixed.

My last post simply pointed out that the work around you describe does not work for those affected by the bug.

Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
milestone: 7.3.0 → 7.3.1
Greg Whiteley (greg-whiteley) wrote :

A workaround that works for me under Unity is to double-click the title-bar - which causes the window to maximise. In its maximised state it has the three window operator buttons (close, minimise, restore/maximise). Hit restore and the window will pop back to its previous size, but now be resizable.

Prior to the workaround the title-bar only has two operator buttons (close, minimise), after maximising it acquires the third and resizability.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Trusty):
status: New → Confirmed
Leonel (leonelsalazar) wrote :

Workaround #6 and #14 worked fine for me.
I'm using Ubuntu 14.04 fresh install and I have this issue from the very beginning.
Also, I don't know if somebody else has noticed but whenever the Updater icon appears on launcher bar doesn't work when you click on it. So I have to right click and select Quit and then open it again.
Sorry if this is not about the same issue.

Metta Crawler (metta-crawler) wrote :

Just out of curiosity has anyone tried:

sudo apt-get install gnome-packagekit
gpk-update-viewer

as a work-around? When I get some time to play in a VM I'll do it myself.

Adolfo Jayme (fitojb) on 2014-08-15
no longer affects: update-manager (Ubuntu)
no longer affects: update-manager (Ubuntu Trusty)
Changed in unity (Ubuntu Trusty):
status: Confirmed → Triaged
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
HenMan (a-ubuntuone-r) wrote :

Adolfo could you please explain why you think that this bug doesn't affect update-manager? As several people stated (and I can confirm) it is reproducible in Xubuntu -> no Unity and no Compiz involved...

Arnaud Thevenet (aeromousse) wrote :

Another workaround that may help find the reason of the bug :
in the non-resizable window, click on Settings, that will open "Software and Updates" window.
After closing this window, the software updater window will be resizable.

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Released

Hello Oscar, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.4+14.04.20141217-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.4+14.04.20141217-0ubuntu1

---------------
unity (7.2.4+14.04.20141217-0ubuntu1) trusty; urgency=medium

  [ Andrea Azzarone ]
  * Share lockscreen password between screens (lp: #1308540)
  * Allow a distinct pam config file for greeter and for lock-screen.
    (lp: #1305440)
  * Add an arrow activator in the lockscreen. (lp: #1332509)
  * Make sure GetScreenGeometry returns the correct value (lp: #1374785).
  * unmapped all windows prior to shutdown (lp: #1370017) (lp: #1375271)

  [ Brandon Schaefer ]
  * fix tooltip for the "Show Desktop / Restore Windows" icon in the Alt-Tab
    switcher (lp: #1237132)
  * Use CONFIG instead of CACHE to store the first_run.stamp (lp: #1328677)

  [ Eleni Maria Stea ]
  * LayoutSystem: make sure the exposed open windows are displayed in the
    preserved order (lp: #1349281).

  [ handsome_feng ]
  * added support for getting the distro name from /etc/os-release
    (lp: #1329584)

  [ Iain Lane ]
  * When grabbing keys, try prefixing "XF86" if the key isn't found. GNOME
    gives us unprefixed keys sometimes (lp: #1302885).

  [ Marco Trevisan (Treviño) ]
  * make the Launcher icon count badge width depend on the text value width
    and scaling (lp: #1353070) (lp: #1354498) (lp: #796527) (lp: #1066971)
    (lp: #1361713)
  * DecoratedWindow: make edges independent from borders and properly update
    them on actions change (lp: #1276177), (lp: #1299741), (lp: #1301776),
    (lp: #1324104), (lp: #1364225), (lp: #1373695)
  * Lockscreen: scale the UI elements based on current monitor scaling
    (lp: #1292218)
  * UnityScreen: when filtering out windows in spread, make sure we unscale
    them (lp: #1316265).
  * PanelMenuView: ensure that proper window tiles and buttons are shown at
    the right place (lp: #1384910) (lp: #1384958) (lp: #1385285)
  * SearchBar, ActionButtons, IconRenderer: include the font scaling when
    scaling textual items (lp: #1332947) (lp: #1361751) (lp: #1362162)
    (lp: #1362346).
  * ApplicationLauncherIcon: make sure we close the dash if DnD is accepted
    and the application window is about to be focused (lp: #1350331).
  * SwitcherView: set progress on icon render args (lp: #1361679).
  * LockScreenController: wait for the primary shield to get the grab
    before setting the session locked (lp: #1368427) (lp: #1371764).
  * added decorations to windows in non-focused workspaces (lp: #1383468)

  [ Stephen M. Webb ]
  * updated the unity(1) manpage to match the actual command (lp: #1059275)
  * bumped package version to match upstream

  [ Marco Trevisan (Treviño) ]
  * Preparing for unity 7.2.4
 -- Ubuntu daily release <email address hidden> Wed, 17 Dec 2014 20:52:10 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu):
status: Triaged → Invalid
no longer affects: compiz (Ubuntu Trusty)
Jason (beatme101) wrote :

I don't know why this bug was only fixed in unity and not in update-manager, but here's a workaround for those of us not using unity (since all the other workarounds posted here don't work):

sudo apt-get install wmctrl
wmctrl -F -r "Software Updater" -e 0,0,10,600,700

xenus (xenus) wrote :

As per #13 resize greyed out on Ubuntu 16.10 xfce 4.12

Rostislav Navrátil (signy13) wrote :

Problem persists on XUbuntu 16.04.02 with update-manager: version 1:16.04.5.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers