[regression] CCSM > Composite > Refresh Rate is blank and cannot be set

Bug #1194009 reported by Daniel van Vugt on 2013-06-24
78
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Compiz
High
Unassigned
compiz (Ubuntu)
High
Unassigned

Bug Description

[regression] CCSM > Composite > Refresh Rate is blank and cannot be set.

Other settings can be set and remembered. Just not Refresh Rate.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
ProcVersionSignature: Ubuntu 3.9.0-6.14-generic 3.9.6
Uname: Linux 3.9.0-6-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.10.2-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Mon Jun 24 14:14:34 2013
DistUpgraded: Fresh install
DistroCodename: saucy
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21da]
InstallationDate: Installed on 2013-06-11 (12 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130611)
MachineType: LENOVO 4286CTO
MarkForUpload: True
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.9.0-6-generic root=UUID=25c27832-0efa-4fc4-8a14-41af68d008dc ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/11/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET68WW (1.38 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4286CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET68WW(1.38):bd04/11/2013:svnLENOVO:pn4286CTO:pvrThinkPadX220:rvnLENOVO:rn4286CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4286CTO
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.45-2ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2~git20130611.761320b1-0ubuntu0+mir3-jenkins81saucy0
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2~git20130611.761320b1-0ubuntu0+mir3-jenkins81saucy0
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3+xmir1-0
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0+xmir2504-0~saucy1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.9+xmir5862-0~saucy1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.8+xmir2338-0~saucy1
xserver.bootTime: Mon Jun 24 13:49:26 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.13.3+xmir1-0

Daniel van Vugt (vanvugt) wrote :
tags: added: regression-release
MC Return (mc-return) wrote :

Reminds me of:

bug #1027868 - Changing "Composite > Detect Refresh Rate" is ignored initially
bug #1192028 - Compiz refresh rate resets to 50 Hz automatically

and also:

bug #1009338 - composite refresh rate falls back to 50Hz, which is wrong in most cases

but this says "Fix Released".

so... I do not think that this is actually a regression on Saucy and I do not remember anyone doctoring on the refresh rate code recently.
What I remember from reading the code there is some ugly workaround/hack for Nvidia in the code, but I see you are using Intel gfx.

Does this: https://bugs.launchpad.net/compiz/+bug/1027868/comments/9 work ?

Changed in compiz:
milestone: none → 0.9.10.0
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

It looks related to bug 1192028. But they are different bugs. At least appear so for now.

And yes I am aware of most of these bugs already, because I logged them.

Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Piotr Stefanczyk (sashx) on 2013-09-30
Changed in compiz:
status: New → Confirmed
Piotr Stefanczyk (sashx) wrote :

https://bugs.launchpad.net/compiz/+bug/1027868/comments/9 unfortunately doesn't work
If I check refresh rate setting by

dconf read /org/compiz/profiles/unity/plugins/composite/refresh-rate

it seems ok (return value 60) but doesn't work at all.

This bug needs to be forwarded upstream (https://wiki.ubuntu.com/Bugs/HowToTriage#Forwarding_upstream).

Changed in compiz (Ubuntu):
importance: Undecided → High
WoodyEckelzone (bcr497) wrote :

Just upgraded to 13.10 and I have this issue now.

Worse, and maybe related, I have a screen flicker on one of two monitors every time I open System Settings , and when I click the `Detect Refresh Rate` checkbox in CCSM -> Composite.

Ipeacocks (ipeacocks) wrote :

I can confirm this problem.

@ipeacocks:

If you click on the option " This bug affects 6 people. Does this bug affect you?", the bug will be just confirmed.

I believe this bug is no longer an issue with the latest Compiz update on 14.04 & 14.10. Could someone please confirm this?

Laurence Potter (lp85bath) wrote :

The setting sticks now in CCSM.

However, "dconf read /org/compiz/profiles/unity/plugins/composite/refresh-rate" does not return a value if the refresh rate is manually set to 60Hz. Also, my compiz refresh rate is still detected as 50Hz by default using nvidia 331.38 from nvidia-331-updates with Ubuntu 14.04 LTS and latest updates on an Nvidia GTX 690. In this case "dconf read /org/compiz/profiles/unity/plugins/composite/refresh-rate" returns a value of 50.

I don't know if this is a regression in my case as I first checked it a few days ago.

Changed in compiz (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers