gtk-window-decorator crashed with SIGSEGV in wnck_window_get_actions()

Bug #1191853 reported by Jean-Baptiste Lallement on 2013-06-17
368
This bug affects 74 people
Affects Status Importance Assigned to Milestone
Compiz
Critical
Marco Trevisan (Treviño)
compiz (Ubuntu)
Medium
Marco Trevisan (Treviño)
libwnck (Ubuntu)
Undecided
Unassigned

Bug Description

gtk-window-decorator crashes each time I close a firefox window in which I had a google hangout.

TEST CASE:
(Note: There is probably a shorter or more obvious test case, but that's how I reproduce it systematically on several systems)
1. Open a new tab in Firefox and start a Google hangout
2. Detach the tab to new window (right-click on the tab, and select "Move to new window" in the contextual menu)
3. Right-click to title bar of the newly open window and select "Always on top" and "Always on visible workspace" in the contextual menu.
4. Chat with your friends for a bit
5. Close the window

ACTUAL RESULT
This crash and windows decorations are gone. To recover the decoration, open a terminal and run "gtk-window-decorator &" then close the terminal with CTRL+D (not the close button of the terminal, that'd kill the decoration too)

EXPECTED RESULT
The window closes without crash

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: compiz-gnome 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
ProcVersionSignature: Ubuntu 3.9.0-5.12-generic 3.9.5
Uname: Linux 3.9.0-5-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.10.2-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CrashCounter: 1
Date: Mon Jun 17 17:43:36 2013
DistUpgraded: 2012-02-01 00:15:24,616 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.2.10, 3.9.0-2-generic, x86_64: installed
 virtualbox, 4.2.10, 3.9.0-3-generic, x86_64: installed
 virtualbox, 4.2.10, 3.9.0-4-generic, x86_64: installed
 virtualbox, 4.2.10, 3.9.0-5-generic, x86_64: installed
 virtualbox, 4.2.10, 3.9.0-6-generic, x86_64: installed
ExecutablePath: /usr/bin/gtk-window-decorator
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Juniper XT [Radeon HD 5770] [1002:68b8] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited Device [174b:1482]
MachineType: Gigabyte Technology Co., Ltd. GA-890GPA-UD3H
MarkForUpload: True
ProcCmdline: /usr/bin/gtk-window-decorator
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.9.0-5-generic root=UUID=cf89ba34-108b-404d-9804-32d54a1df2ea ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7fd3396dbe56 <wnck_window_get_actions+22>: cmp %rax,(%rdx)
 PC (0x7fd3396dbe56) ok
 source "%rax" ok
 destination "(%rdx)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 wnck_window_get_actions () from /usr/lib/libwnck-1.so.22
 ?? () from /usr/lib/libwnck-1.so.22
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: gtk-window-decorator crashed with SIGSEGV in wnck_window_get_actions()
UpgradeStatus: Upgraded to saucy on 2012-01-31 (502 days ago)
UserGroups: adm admin cdrom dialout kvm libvirtd lpadmin plugdev sambashare sbuild vboxusers
dmi.bios.date: 07/23/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: FD
dmi.board.name: GA-890GPA-UD3H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrFD:bd07/23/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-890GPA-UD3H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-890GPA-UD3H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-890GPA-UD3H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.45-2ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.3-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.3-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu12
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.8-0ubuntu1
xserver.bootTime: Mon Jun 17 08:18:21 2013
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu11
xserver.video_driver: radeon

Related branches

Jean-Baptiste Lallement (jibel) wrote :

StacktraceTop:
 wnck_window_get_actions (window=0x1c5b540) at window.c:2171
 update_menu_state (menu=0x1fb6460) at window-action-menu.c:408
 g_main_dispatch (context=0x1aec4d0) at /build/buildd/glib2.0-2.37.1/./glib/gmain.c:3058
 g_main_context_dispatch (context=context@entry=0x1aec4d0) at /build/buildd/glib2.0-2.37.1/./glib/gmain.c:3634
 g_main_context_iterate (context=0x1aec4d0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.37.1/./glib/gmain.c:3705

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
fantab (fantab) wrote :

The same crash here.
Ubuntu development release, 'Saucy Salamander'
Kernel: 3.10.0-3-generic

description: updated
Don Forigua (ingforigua) wrote :

Hello i have this problem when i was trying to print a "head cleaning" here my screenshot

tags: added: rls-s-incoming
Petar Sredojevic (perosredo) wrote :

crashed by VirtualBox Powering Off a virtual #! machine - lost Titlebars in Unity.

Simplehuman (simplehuman) wrote :

Crashed after closing Totem (was watching a movie)

Dahna (dahna) wrote :

Mine crashes from time to time while working with different windows

Ubuntu development release, 'Saucy Salamander', 3.11.0-5-generic

I'm using Nvidia proprietary drivers 319

With default drivers probably problem wasn't exists or at least happens much less frequent.

Nick Moffitt (nick-moffitt) wrote :

All I was doing was switching terminals to run top to figure out why I had an apport process eating up a whole core. I'm not sure at what point during the crash I was observing, but it seems to have sent me to this bug.

Unfortunately I can hardly reproduce this, but all this should be caused by the missing finalization of the internal menu.

Changed in compiz:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in compiz (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in compiz:
milestone: none → 0.9.11.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision None, scheduled for release in compiz, milestone 0.9.11.0

Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: Confirmed → Fix Committed
Changed in libwnck (Ubuntu):
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/0.9.10 at revision None, scheduled for release in compiz, milestone 0.9.10.2

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libwnck - 1:2.30.7-0ubuntu3

---------------
libwnck (1:2.30.7-0ubuntu3) saucy; urgency=low

  * debian/patches/03_window_action_menu_dispose_events.patch:
    - Stop idles and disconnect from signals on dispose (LP: #1191853)
 -- Marco Trevisan <email address hidden> Fri, 27 Sep 2013 19:52:16 +0200

Changed in libwnck (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.10+13.10.20131004-0ubuntu1

---------------
compiz (1:0.9.10+13.10.20131004-0ubuntu1) saucy; urgency=low

  [ Chris Townsend ]
  * Fix issue where non-resizable windows and semi-maximized window
    would have an area near the top of the title bar that could not be
    grabbed. (LP: #1228507)

  [ Marco Trevisan (Treviño) ]
  * ActionMenu: weak ref the action menu on creation, and unref it on
    destroy Also, now the widget destruction automatically unset the
    menu. This makes the object to be correctly finalized (not only
    disposed) making sure the internal idle into WnckActionMenu gets
    stopped. (LP: #1191853)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3794
 -- Ubuntu daily release <email address hidden> Fri, 04 Oct 2013 05:23:02 +0000

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2014-11-04
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.