gtk-window-decorator crashed with SIGSEGV in wnck_window_get_actions()

Bug #1200988 reported by Tony Themelis on 2013-07-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

this crash occurs on startup

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: compiz-gnome 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-2.11-generic 3.10.0
Uname: Linux 3.10.0-2-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.10.2-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sat Jul 13 15:08:04 2013
DistUpgraded: Fresh install
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.2.10, 3.10.0-2-generic, x86_64: installed
 virtualbox-guest, 4.2.10, 3.10.0-2-generic, x86_64: installed
ExecutablePath: /usr/bin/gtk-window-decorator
GraphicsCard:
 NVIDIA Corporation G84GLM [Quadro FX 570M] [10de:040c] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Lenovo ThinkPad T61p [17aa:20d9]
InstallationDate: Installed on 2013-07-13 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130712)
MachineType: LENOVO 64608WU
MarkForUpload: True
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdline: /usr/bin/gtk-window-decorator
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.10.0-2-generic root=UUID=2034e8da-36f6-43be-93c8-2bd1dcd29daf ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7fb19ae30e56 <wnck_window_get_actions+22>: cmp %rax,(%rdx)
 PC (0x7fb19ae30e56) ok
 source "%rax" ok
 destination "(%rdx)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 wnck_window_get_actions () from /usr/lib/libwnck-1.so.22
 ?? () from /usr/lib/libwnck-1.so.22
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: gtk-window-decorator crashed with SIGSEGV in wnck_window_get_actions()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers
dmi.bios.date: 04/08/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 7LETC7WW (2.27 )
dmi.board.name: 64608WU
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7LETC7WW(2.27):bd04/08/2010:svnLENOVO:pn64608WU:pvrThinkPadT61p:rvnLENOVO:rn64608WU:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 64608WU
dmi.product.version: ThinkPad T61p
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.45-2ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.4-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.4-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.1-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.9-0ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.8-0ubuntu1.1
xserver.bootTime: Sat Jul 13 15:23:47 2013
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.14.1-0ubuntu1
xserver.video_driver: nouveau

Tony Themelis (tony-athemelis) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1191853, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers