Latest compiz update breaks Java Swing decorations

Bug #1138517 reported by Dmitry Pankratov on 2013-03-01
154
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Compiz
High
Sam Spilsbury
0.9.9
High
Sam Spilsbury
compiz (Arch Linux)
New
Undecided
Unassigned
compiz (Ubuntu)
High
Unassigned

Bug Description

Latest compiz update (1 March 2013) on Ubuntu 13.04 AMD64 breaks Java Swing applications UI.
Attached is a screenshot of the application: main menu is not visible and the bottom of the window is not rendered correctly. Also it's not possible to use window controls (move/maximize/close).

Related branches

Dmitry Pankratov (dremon) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Raymond Wells (rfw2nd) wrote :

I can confirm this occurs in OpenJDK 6 & 7. As an alternative, you can install Xephyr and a minimal WM

$ sudo apt-get install metacity

The following workaround works for me:

$ Xephyr :1 -screen 1280x800

inside your Xephyr you will have an xterm shell.. type:

$ metacity :1 &

You will see a titlebar appear on the enclosed xterm window.

Now just run your java applicaiton like you normally would from the terminal.

( if it is a jar file)
$ java -jar myjavaapp.jar

Sami Jaktholm (sjakthol) on 2013-03-02
Changed in compiz:
status: New → Confirmed
Julian Taylor (jtaylor) wrote :

caused by the fix for bug 1110138
reverting it fixes the issue

Changed in compiz (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
hadobac (hadobac333) wrote :

I am affted by this too.

MC Return (mc-return) wrote :

@everyone affected: Please disable the unityshell plugin in CCSM and then try to reproduce this bug. Is it reproducable without unityshell running as well ?

Dmitry Pankratov (dremon) wrote :

Yes it can be reproduced with Unity plugin disabled.

information type: Public → Public Security
information type: Public Security → Public
lanyuan (lan-yuan) wrote :

when will this problem be solved?

Dmitry Pankratov (dremon) wrote :

Because this bug breaks most of Java IDEs (Netbeans, IntelliJ, jEdit) it would be great to have it fixed asap.

Rocko (rockorequin) wrote :

Not only does this stop the swing decorations from working, popup windows (eg Netbeans project properties) respond really slowly to switching tabs, entering text, etc, to the point where they are pretty much unusable.

Changed in compiz:
importance: Undecided → High
Sam Spilsbury (smspillaz) wrote :

Has anyone got a sample application to reproduce the problem? That would be very useful for the people who are in a position to actually fix this.

Sebastien Bacher (seb128) wrote :

@Sam: sudo apt-get install jedit (list as an example in comment #9)

Dmitry Pankratov (dremon) wrote :

It is reproduceable with any Java application that uses Swing or AWT (for example jEdit from the Ubuntu repositories).

Example of the simplest one:

import javax.swing.*;
public class SwingWindowTest {
    public static void main(String[] args) {
        JFrame frame = new JFrame("Hello World");
        frame.setSize(320, 240);
        frame.show();
    }
}

Sam Spilsbury (smspillaz) wrote :

Thanks for the assistance. Got this figured out.

(BTW, JFrame.show () is deprecated, use JFrame.setVisible ())

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/raring at revision None, scheduled for release in compiz, milestone Unknown

Changed in compiz:
status: Confirmed → Fix Committed
Sam Spilsbury (smspillaz) wrote :

Actual fix proposed.

Changed in compiz:
status: Fix Committed → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.9.2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.03.06-0ubuntu1

---------------
compiz (1:0.9.9~daily13.03.06-0ubuntu1) raring; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * Latest compiz update breaks Java Swing decorations (LP: #1138517)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3631
 -- Automatic PS uploader <email address hidden> Wed, 06 Mar 2013 13:26:19 +0000

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
brainpower (brainpower) wrote :

confirmed fixed in 0.9.9~daily13.03.06-0ubuntu1 for me

Rocko (rockorequin) wrote :

1:0.9.9~daily13.03.06-0ubuntu1 fixes it for me too.

Colin Law (colin-law) wrote :

Fixed, thanks.

J (jsartti) wrote :

Fixed, thanks.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/raring at revision None, scheduled for release in compiz, milestone Unknown

Changed in compiz:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision None, scheduled for release in compiz, milestone 0.9.9.2

I can confirm that as of revision 3633 the issue is fixed for me.

Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0

@Daniel or Sam: Is there any PPA for Ubuntu 13.04 I could use to install compiz 0.9.10 with the fix for this bug? I would rather not want to install compiz from source, but this bug really is sort of a show-stopper...

Thanks! I installed 0.9.10 from the PPA.

Unfortunately, this does NOT fix the bug for me! (see screenshot: a dialog from IntelliJ IDEA)
I use IntelliJ a lot, and the problem frequently appears with dialog windows (note: sometimes they are displayed correctly, sometimes the are not).
While it is possible to use window controls in distorted dialogs, the bottom part of the window is not rendered correctly.
Also, dialogs are shifting down per title-bar height as they are closed and reopened several times.

... well, although the bug is not fixed completely with 0.9.10, it shows up much less often than before. If a dialog is displayed without distortion in its bottom area, its position will also remain stable.

I can also confirm that this bug still exists. It occurs about 20 - 30% of time I start jEdit. It also effect multiple line edit in dialog box. Its height is reduced from 3 lines to about 0.8 line.

jEdit 5.0.0
Java 1.6.0_45 (Sun's)
Ubuntu 13.04 (64 bit)

Stephen M. Webb (bregma) on 2013-07-23
Changed in compiz:
status: Fix Committed → Fix Released

I'm on Compiz 0.9.10.2/Ubuntu 13.10 64-bit and this doesn't work for me. Java popup windows render sometimes incorrectly.
Is there any other version of compiz I should try? Or hasn't this bug been really fixed?

Colin Law (colin-law) wrote :

This was fixed ages ago, assuming you are using compiz from the ubuntu repository. On 13.10 32 bit this is 0.9.10+13.10.20131011-0ubuntu1, I guess 64 bit will be similar. If you still see a problem report a new bug.

Actually this was never really fixed properly, you quite often have to move the pop-up slightly before you can activate any controls on a pop-up. You get used to doing that after a while and it easier than getting a bug fixed in compiz for anything that is not one of Canonicals pet applications.

Colin Law (colin-law) wrote :

That sounds like a different bug. The issue as described in the description at the top is fixed (for me anyway). My comment stands, if there are still issues then submit a new bug.

Stephen M. Webb (bregma) wrote :

Closing Compiz 0.9.9 task (0.9.9 series is obsolete)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers