[nvidia] Graphics freeze when I close or minimize a window

Bug #1032276 reported by Ruben Grimm on 2012-08-02
76
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Compiz
High
Unassigned
compiz (Ubuntu)
High
Unassigned

Bug Description

Often when I minimize or close the last open window so the desktop becomes visible the graphics freeze for several seconds up to 2 minutes.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.12-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Ist ein Verzeichnis: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 295.40 Thu Apr 5 21:37:00 PDT 2012
 GCC version: gcc-Version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Thu Aug 2 18:09:40 2012
DistUpgraded: 2011-10-09 20:46:50,221 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 295.40, 3.2.0-26-generic, x86_64: installed
 nvidia-current, 295.40, 3.2.0-27-generic, x86_64: installed
 virtualbox, 4.1.12, 3.2.0-26-generic, x86_64: installed
 virtualbox, 4.1.12, 3.2.0-27-generic, x86_64: installed
GraphicsCard: NVIDIA Corporation G92 [GeForce 9800 GT] [10de:0614] (rev a2) (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
JockeyStatus:
 xorg:nvidia_current - Beschleunigter Grafiktreiber von NVIDIA (Proprietär, Aktiviert, In Benutzung)
 xorg:nvidia_current_updates - NVIDIAs beschleunigte Grafiktreiber (Nachträgliche Aktualisierungen) (Proprietär, Deaktiviert, Nicht benutzt)
MachineType: Gigabyte Technology Co., Ltd. M56S-S3
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-27-generic root=UUID=2d70f1cc-b8b7-447f-b0ae-794e6acd901a ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2011-10-09 (297 days ago)
dmi.bios.date: 08/20/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F6h
dmi.board.name: GA-M56S-S3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF6h:bd08/20/2010:svnGigabyteTechnologyCo.,Ltd.:pnM56S-S3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-M56S-S3:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: M56S-S3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.7.8-0ubuntu1.2
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 8.0.2-0ubuntu3.1
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Ruben Grimm (pmk1c) wrote :
Daniel van Vugt (vanvugt) wrote :

Hi Ruben,

I would like to capture a stack trace of the compiz process while it it frozen. Sounds tricky, but here's an idea:

1. Download the attached dstack script to your home directory.
2. Open a terminal and...
3. chmod 700 dstack
4. sudo -s
5. sleep 5 && ./dstack compiz >> compizhang.txt
6. NOW QUICKLY trigger the freeze, to ensure it's frozen before step 5 completes.
7. chmod 644 compizhang.txt
8. Attach compizhang.txt to this bug.

If you're not sure you've caught it during the freeze, then please repeat step 5-6 several times.

Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Ruben Grimm (pmk1c) wrote :

Here's the compiz stack. I'm pretty sure I got it ;)

Ruben Grimm (pmk1c) wrote :

I also made a screenshot of when the freeze happens. It always happens in this situation (minimizing / closing the last open window). The screenshot was made after I had the stack. Didn't want things to interfere.

Daniel van Vugt (vanvugt) wrote :

Ruben,

The stack doesn't seem to give an obvious reason for the hang. But I notice in the screenshot that it's mid-animation. And since you're using the nvidia driver, that looks a lot like a known problem (hang) nvidia has with compiz mipmapping. Though as far as I know, the animation plugin does not use mipmapping. So it's not a very solid theory yet.

Have you changed any compiz settings at all in CCSM? Could you please try disabling the animation plugin in ccsm? You get it from package "compizconfig-settings-manager".

Daniel van Vugt (vanvugt) wrote :

Please also try removing the NVIDIA driver and test the default driver (nouveau) if possible.

Daniel van Vugt (vanvugt) wrote :

Also note: Your stack matches some of the stacks reported for freeze bug 815996. It's possible they're the same problem.

Ruben Grimm (pmk1c) wrote :

No I didn't change the default settings in CCSM.

I tried the nouveau driver --> The problem is gone. So it's a problem with nvidia.

Interesting though: Disabling the minimizing effect in CCSM doesn't fix the bug. It still freezes when minimizing.
As I said before the problem also occurs when closing.

Then I tried the updated version of the nvidia drivers (295.49) but the bug still occurs.

And last but not least i tried the nvidia drivers from x-updates ppa (302.17) and the bug still occurs.

Daniel van Vugt (vanvugt) wrote :

Please try disabling (un-ticking) the entire Animation plugin.

Ruben Grimm (pmk1c) wrote :

Yes when I disable the whole plugin the bug is gone.

I think I've seen the same freeze when using LLVMpipe, which tends to encounter the same mipmapping and freeze bugs as the NVIDIA driver.

summary: - Graphics freeze when I close or minimize a window
+ [nvidia] [animation] Graphics freeze when I close or minimize a window
affects: unity → compiz
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz:
status: Incomplete → Confirmed
Changed in compiz (Ubuntu):
status: Incomplete → Confirmed
Changed in compiz:
milestone: none → 0.9.8.0
tags: added: llvmpipe
Ruben Grimm (pmk1c) wrote :

I'm sorry but I have to revoke my last comment.
I had the animation plugin disabled for some time now, but the bug still appeared sometimes.

summary: - [nvidia] [animation] Graphics freeze when I close or minimize a window
+ [nvidia] Graphics freeze when I close or minimize a window
Ruben Grimm (pmk1c) wrote :

I got a new clue. I always disable nautilus for drawing my desktop (I don't use the desktop at all, since I got my beloved Unity ;) ). Now I reenabled it and it seems to solve the bug (maybe work around it since there's always a window left to draw?). I will keep you updated if the problem is really gone.

Changed in compiz:
importance: Undecided → High
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Daniel van Vugt (vanvugt) wrote :

I am hoping this was the same issue as bug 1006216 and bug 1023716, which are both now fixed in compiz 0.9.8.0.

Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Ruben Grimm (pmk1c) wrote :

Just wanted to say, that the problem still exists in 13.04 and that it will get more relevant, since some people might switch to Nautilus 3.8 through a PPA, which doesn't offer showing the desktop anymore. So, people won't use it to show the desktop and this bug will occur.

Of course, 13.04 is not supporting Nautilus 3.8, but I'm just saying this bug *will* be relevant going forward.

Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
ssavoy (ssavoy) wrote :

I am only experiencing this issue in 13.04, both in VirtualBox using Intel Graphics and on a Pentium 4 Dell Desktop with an ATI RV370 card. When minimizing a window, xorg seems to lock up mid-minimization. I am able to jump into the CLI and end the current gnome-session which will restart it and allow me to log in again.

Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0

I too have this bug and I can confirm that it's related to Compiz drawing the desktop (Nautilus show desktop disabled).

I have it in 13.04 and 13.10 running in VirtualBox and also booting the ISO image with Grub entry created by grml-rescueboot. It happens with NVIDIA drivers (tested on 13.04) and Nouveau, LLVMpipe and VirtualBox drivers (tested on 13.10).

The easiest way to reproduce this bug is to open terminal (it must be the only visible window). Then type nautilus -q which will temporarily kill Nautilus (desktop will be rendered with Compiz). The last step minimize or close terminal window.

This results in animation hang and entire desktop hang. Unity doesn't respond on keys being pressed (Super, Alt (Tap), Alt + F2 or F10). When the desktop finally returns to normal I see all those actions that I triggered before (Dash opening, HUD opening and so on).

arty (me-arty) wrote :

This bug affects me as well. I can add to the discussion that when compiz freezes and I kill it via ssh then ibus-daemon and ibus-ui-gtk3 processes start consuming 100% CPU and I have to kill them as well.

arty (me-arty) wrote :

Also I have noticed that pressing Alt or Meta key effectively unfreezes compiz.

I'm using the latest ubuntu 14.04.1 and Compiz 0.9.11.2 and unity 7.2.2.

arty (me-arty) wrote :

And another update: I have occasionally fixed that by reenabling desktop icons.

I have previously used Ubuntu Tweak to disable icons on desktop. Apparently this removes some kind of root nautilus window (which also draws the background BTW). It looks like Compiz expects this window to exist, and if it does not exist and all other windows are minimized then Compiz goes crazy.

To fix the missing desktop background I have reset this option to the original state, now Nautilus draws background and icons, and I can safely minimize all windows.

hamza alloush (hamzaalloush) wrote :

I had this until i read the previous reply of arty, i had Desktop items disabled, when i enabled them again the problem of freezing while attempting to minimize/close window, goes away.

Eleni Maria Stea (hikiko) wrote :

I can't reproduce this bug and it seems quite old, I was about to mark it as invalid but I've noticed that last comments are from 2015... Which Ubuntu release are you using?

Changed in compiz:
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Changed in compiz:
status: Invalid → Confirmed
Changed in compiz (Ubuntu):
status: Invalid → Confirmed
hamza alloush (hamzaalloush) wrote :

Ubuntu 14.04.3 LTS

it happens if i disable Desktop Item like so:

gsettings set org.gnome.desktop.background show-desktop-icons false

i have an updated system, my specs are Acer 4830tg laptop with discrete Nvidia Optimus technology, but the bug happens when i'm using integrated graphics as well.

each time i minimize or close a window it freezes, maybe i can come up with a more comprehensize bug report? but how do i debug the segfault of Nautilus?

btw, it got fixed when i re-enabled Desktop icons: gsettings set org.gnome.desktop.background show-desktop-icons true

I think Arty's comment has some merit.

hamza alloush (hamzaalloush) wrote :

This bug must be related to: https://bugs.launchpad.net/ubuntu/+bug/1171451
And, https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1314587

Since lots of users reported they fixed their problems using the solution, I.e enable desktop item.

So please look at it, and I'm waiting for propert report to this bug, like a way to instantiate co compiz from the command line, maybe compiled compiz in debug mode By isnatiating

To post a comment you must log in.