gnome-screenshot should not take a screenie of itself

Bug #93234 reported by x on 2007-03-17
106
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-utils
Expired
Medium
compiz-plugins-main (Ubuntu)
Low
Didier Roche

Bug Description

Binary package hint: gnome-utils

I took screenies with gnome-screenshot (via menu where it is set to "gnome-screenshot --interactive") and in the resulting screenies there is also gnome-screenshot shown itself

see screenie for details

PS. this does not happen with "ksnapshot"

x (xk2c-deactivatedaccount) wrote :

$ aptitude show gnome-utils
Package: gnome-utils
State: installed
Automatically installed: no
Version: 2.18.0-0ubuntu1

x (xk2c-deactivatedaccount) wrote :

since i feel this is a "upstream" thing if you want me i could open a bugreport at http://bugzilla.gnome.org

Sebastien Bacher (seb128) wrote :

opening GNOME bug on bugzilla.gnome would be nice, we don't have the manpower to deal with every little upstream bug at the moment

Changed in gnome-utils:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

The bug doesn't happen on my desktop, what window manager do you use?

x (xk2c-deactivatedaccount) wrote :

i use "plain" ubuntu (aka gnome) desktop.
without any beryl or anything.

$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 6
model name : AMD Athlon(tm) XP 2000+
stepping : 2
cpu MHz : 1684.414

+ 1gig RAM

x (xk2c-deactivatedaccount) wrote :

PS
as you can see i use a not ubuntu default gnome theme.
May that be a reason?

x (xk2c-deactivatedaccount) wrote :

I have switched back to default ubuntu theme

once it did not hapend
the second try then it also happend with this theme

x (xk2c-deactivatedaccount) wrote :
x (xk2c-deactivatedaccount) wrote :

PS.
it seems not to happen when started with:
gnome-screenshot

from cli

After playing a little with that it seems as when started only from menu it happens.
When started from cli (even with gnome-screenshot --interactive) it seems not to happen.

:/ strange

Confirming on Feisty.
The problem occurs when selecting "Grab the current window" and not when selecting "Grab the whole desktop".
Isn't this caused by the fact that the gnome-screenshot --interactive dialog is considered the current window because it has the focus?
In previous versions of gnome-screenshot (Edgy and Dapper) we had to click the specific window we wanted to capture.

Changed in gnome-utils:
status: Unknown → Unconfirmed
x (xk2c-deactivatedaccount) wrote :

upstream has now an duplicate reported by someone else:
http://bugzilla.gnome.org/show_bug.cgi?id=434585

Jordan Erickson (lns) wrote :

Just wanted to say this is happening to me too. I used 'Current window' and 'grab immediately' and it grabbed the actual screenshot utility window before it dissapeared completely (you can see that just the bare window and no content shows).

Caroline Ford (secretlondon) wrote :

My bug (bug #202338) has been marked a duplicate of this. It's on Hardy and only seems to affect epiphany.

Jorge (jorgesp) wrote :

The problem occurs when selecting "Grab the whole desktop".

Ubuntu 8.04 Hardy Heron

AMD 64 LE1620
1 GB mem.
Mother ASRock ALiveNF6G-VSTA
Video: Integrated Nvidia Gforce6-classgraphics DX 9.0 VGA - Shared memory 256 MB
Audio 7.1 ch. A:C888 codec.

Regards.

Jorge.

era (era) wrote :

Related upstream bug http://bugzilla.gnome.org/show_bug.cgi?id=434585 suggests to change the default delay to 1 second. That would have been my suggestion, too, and would seem like a very unintrusive patch whilst upstream are thinking about how to get their ducks in a row.

(This is on Hardy amd64, for me, installed from 2008-03-20 beta CD image.)

Changed in gnome-utils:
status: New → Confirmed
Changed in gnome-utils:
status: Confirmed → Triaged
Jordan Erickson (lns) wrote :

This issue seems to be resolved for 8.04.1, but now the "Current Window" option is broken - no matter what you choose, it grabs the whole desktop. BUT, the screenshot window isn't in there, so that's good.

I'm using this under LTSP, not sure if that makes a difference. Probably shouldn't.

Anyone else experiencing this in Hardy still, with all updates?

Hi this happens for me also on Jaunty

Package: gnome-utils
State: installed
Automatically installed: no
Version: 2.25.90-0ubuntu1
Priority: optional
Section: gnome

Rolf Leggewie (r0lf) wrote :

FWIW, I don't think I'm seeing this. Somebody using lucid to confirm it's indeed gone?

Changed in gnome-utils:
importance: Unknown → Medium
Changed in gnome-utils (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
summary: - [Feisty] gnome-screenshot should not take a screenie of itself
+ gnome-screenshot should not take a screenie of itself
Sebastien Bacher (seb128) wrote :

Rodrigo, that one is lower importance but would be nice to get fixed, could you check if there would be an easy way to fix that issue in natty?

Changed in gnome-utils (Ubuntu):
assignee: nobody → plexer (rodrigo)
assignee: plexer (rodrigo) → Rodrigo Moya (rodrigo-moya)
Sebastien Bacher (seb128) wrote :

Upstream though that the fix fro https://bugzilla.gnome.org/show_bug.cgi?id=434585 would have solved that but it seems not

Sebastien Bacher (seb128) wrote :

the other bug was slightly different in fact...

Sebastien Bacher (seb128) wrote :

ok, after some thinking rather than having the screenshoter doing some delay we should rather tell compiz to not animate this dialog, reassigning to compiz and didrocks

affects: gnome-utils (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
assignee: Rodrigo Moya (rodrigo-moya) → Didier Roche (didrocks)
Sebastien Bacher (seb128) wrote :

sam said "add & !(class=gnome-screenshot) to the end of the first line of "close animation" in the animations plugin"

Didier Roche (didrocks) on 2011-03-02
affects: compiz (Ubuntu) → compiz-plugins-main (Ubuntu)
Changed in compiz-plugins-main (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 0.9.4-0ubuntu3

---------------
compiz-plugins-main (0.9.4-0ubuntu3) natty; urgency=low

  * 03_default_options.patch:
    - change default option from 0.2s delay to 0s for compiz staticswitcher plugin
    - don't get a close animation on gnome-screenshot (LP: #93234)
    - Change <Super> + e to <Super> + s for switch workspace (trigger expo mode)
      in the classic session as in unity (LP: #723273)
    - deactivate mipmapping in staticswitcher as it can make alt Tab very slow
      (some seconds) on some hardware (LP: #684843)
 -- Didier Roche <email address hidden> Wed, 16 Mar 2011 19:21:19 +0100

Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-utils:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.