some users prefer the old grid behaviour (dividing each time the keybinding are used)

Bug #879218 reported by Joe Farley on 2011-10-21
366
This bug affects 80 people
Affects Status Importance Assigned to Milestone
Compiz
Wishlist
MC Return
Compiz Grid Plugin
Wishlist
Unassigned
Compiz Main Plugins
Wishlist
Unassigned
Unity
Won't Fix
Wishlist
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
compiz-plugins-main (Ubuntu)
Wishlist
Unassigned

Bug Description

I've used the Compiz Grid function for a long time and I generally use it to set my browser to the right 2/3 or 3/4 of the screen and have other apps on the top or bottom half of the remaining part. Now when I press ctrl + alt numpad 4 or numpad 6 it only does half and when pressing it a second or third time it does nothing. The options for different sizes work for all the corners and top and bottom. When I press ctrl + alt numpad 9 it does the same thing as pressing ctrl + alt numpat 8. Here's a video that may illustrate the problem better than my description.

http://www.youtube.com/watch?v=i3WC0BnXe5E

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.22.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,gnomecompat,mousepoll,imgpng,unitymtgrabhandles,regex,animation,grid,snap,expo,workarounds,ezoom,resize,vpswitch,place,wall,staticswitcher,fade,session,scale,unityshell]
Date: Thu Oct 20 23:03:00 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

A video of the latest Grid version (also showing this fix in action):
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/745159/+attachment/3660185/+files/GridAllFunctionalityFullyFixed.mp4

Related branches

Joe Farley (joeataoldotcom) wrote :
jclariana (jordiclariana) wrote :

Hi,

Same problem here in two different computers. Not happening few days ago.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
simon (archlich) wrote :

I have the same issues as well. Removed .gconf, .gconfd, .gnome2, .config, and .comiz-1 and same the behavior is displayed.

Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: New → Confirmed
Jason Scott (abdalalim1982) wrote :

I am also having these problems. A quick resolve would be appreciated, as this hurts productivity.

Clayton Smith (clayton-a-smith) wrote :

This duplicate status is wrong. Bug 878573 does not cover the bug mentioned above: repeating the command CTRL + ALT + NUM6 repeatedly does not re-size the window to 1/2, 1/3, 1/4 screen width as it is supposed to.

jclariana (jordiclariana) wrote :

Hi,

If any one have the urgent need for this to work (which I have), you can downgrade the package compiz-plugins-main-default to the version 1:0.9.6-0ubuntu2. I have tried with all the updates, and this is the latest to work.
You can found the package here: https://launchpad.net/ubuntu/oneiric/amd64/compiz-plugins-main-default/1:0.9.6-0ubuntu2 and install it with:
  $ sudo dpkg -i compiz-plugins-main-default_0.9.6-0ubuntu2_amd64.deb

Of course, it may break something, but so far, I've have no problems.

To ensure that no other Ubuntu update will replace the package again, you can run this:
  $ echo compiz-plugins-main-default hold | sudo dpkg --set-selections

To unhold it when you want to update it again (when the bug gets fixed, for example):
  $ echo compiz-plugins-main-default install | sudo dpkg --set-selections

Said that, is obvious that something between version 0.9.6-0ubuntu2 and 0.9.6-0ubuntu3 broke the Grid plugin.

jclariana (jordiclariana) wrote :

Well, it seems that downgrade really break something: no further system upgrades are possible, because there's dependencies unable to be resolved when you downgrade the package. Take a look:

====================================================
jordi@ubuntu: /home/jordi $ sudo aptitude dist-upgrade
The following packages will be upgraded:
  aisleriot binutils gnome-system-monitor libgssapi-krb5-2 libgssapi-krb5-2 libk5crypto3
  libk5crypto3 libkrb5-3 libkrb5-3 libkrb5support0 libkrb5support0 libunity-core-4.0-4
  libvlc-dev libvlc5 libvlccore-dev libvlccore4 unity unity-common unity-services vlc vlc-data
  vlc-nox vlc-plugin-notify vlc-plugin-pulse xserver-common xserver-xorg-core xserver-xorg-dev
27 packages upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 21.3 MB of archives. After unpacking 20.5 kB will be used.
The following packages have unmet dependencies:
  compiz-plugins-main: Depends: compiz-plugins-main-default (= 1:0.9.6-0ubuntu4) but 1:0.9.6-0ubuntu2 is installed and it is kept back.
The following actions will resolve these dependencies:

       Remove the following packages:
1) appmenu-qt
2) compiz-plugins-main
...
138) vlc
139) zlib1g

       Leave the following dependencies unresolved:
140) indicator-appmenu recommends appmenu-qt
141) compizconfig-settings-manager recommends compiz-plugins-main
142) ia32-libs recommends ia32-libs-multiarch
143) virtualbox recommends libqt4-opengl (>= 4:4.5.3)
144) ubuntu-restricted-addons recommends flashplugin-installer

Accept this solution? [Y/n/q/?]
====================================================

So I don't recommend this unless you really know what you are doing.

The duplicate status is wrong. These tickets detail two different problems.

h3 (h3) wrote :

I can confirm this bug on 4 differents computers.

As soon as I upgraded to Ubuntu 11.10 I noticed Ctrl+Alt+KPN stopped working. I noticed because I used it a million times a day.

With all the updates coming I thought it would be fixed pretty soon .. nope.

Bernard Banko (beernarrd) wrote :

This can not be a duplicate of bug #876591, as other ctr-alt KP combinations works well here (ie. also KP8 and KP9 work ok).

Bernie (bernie-rihn) wrote :

same here. also breaks any of the resize handles on the window as soon as you move to any corner/side....

This bug is driving me crazy. The resize function is critical - and confirmed on 3 machines here. Affects productivity (not to mention it puts the Windows grid function back on top).

tshirtman (gabriel-pettier) wrote :

this bug report about the same thing seems to get the most attention (and answers) from ubuntu developpers
https://bugs.launchpad.net/compiz-plugins-main/+bug/878820

Sebastien Bacher (seb128) wrote :

setting as wontfix for unity

Changed in compiz-plugins-main:
status: New → Invalid
importance: Undecided → Wishlist
Changed in unity:
importance: Undecided → Wishlist
status: Confirmed → Won't Fix
Changed in unity (Ubuntu):
status: Confirmed → Won't Fix
importance: Undecided → Wishlist
summary: - Compiz Grid feature under Unity stopped functioning properly
+ some users prefer the old grid behaviour (dividing theach time the
+ keybinding are used)
summary: - some users prefer the old grid behaviour (dividing theach time the
+ some users prefer the old grid behaviour (dividing each time the
keybinding are used)
Changed in hundredpapercuts:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

To summarize the new behaviour is to have the keys acting in a consistent way as placement binding, i.e doing twice the "put on the left side" just put it there and don't change the geometry the second time (which is an action hard to revert, how do you go back to "undo" an extra division?)

cherep (acherep) wrote :

I experience the same bug on Ubuntu 12.04 64bit :(

affects: compiz → compiz-core
affects: compiz-core → compiz-grid-plugin
Changed in compiz-plugins-main:
status: Invalid → New
affects: unity (Ubuntu) → compiz-plugins-main (Ubuntu)
Changed in compiz-plugins-main (Ubuntu):
status: Won't Fix → Confirmed
Changed in compiz-plugins-main:
status: New → Confirmed
Changed in compiz-grid-plugin:
status: New → Confirmed
importance: Undecided → Wishlist

Come on. This is a bug. Not a wishlist.

Cson (theceason) wrote :

this is a bug
also try the drag resize the window after grid
the window will fly away

Changed in compiz:
importance: Undecided → Wishlist
status: New → Confirmed
Gareth Bailey (garethbailey0) wrote :

IMO this is a bug, not a feature. If the new behaviour is a 'fature' then it bhaves like this through a bug and not by design. The bug is in the handling of the MAXIMIZE status for left and right puts and and inapropriate update of lastTarget to GridUnknown. The attached patch fixes this issue.

Gareth Bailey (garethbailey0) wrote :

Patch that I forgot to attach to the above comment.

The attachment "Fix-put-left-right" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Gareth Bailey (garethbailey0) wrote :
Rik Shaw (rik-shaw) wrote :

YES!!!!! Gareth Bailey is my hero. I have been searching for a fix for this for a very long long time. Thank you so much for making it available in a PPA!!

Does anyone know if this is going to be a fix merged back into Compiz / Unity or has Canonical taken the stance that by default Grid should "not" do anything for left and right except for 1/2 screen? Meaning, is this a bug fix or a feature enhancement (even though it previously existed?)

Thanks for any insights...

Peter Ryan (peter-peterryan) wrote :

thank you gareth bailey.

the_maplebar (mapesj) wrote :

+1 vote to fix this bug. The grid plugin is a great productivity booster.

Thank you Gareth Bailey, your fix works perfectly. Mainteners please incorporate this fix.

cako (goldencako) wrote :

This is clearly a bug, and it has been open for almost a year now. Gareth has already provided a patch and so generously built and distributed it for the rest of us (thanks a lot Gareth!).

Now the question is, why the hell hasn't this been included in the official repos?! I guess it boils down to Sebastian's opinion being worth more than that of 60 users.

This has been a major frustration of mine for a long time. I'm not sure what's more surprising - the fact that this hasn't been fixed yet or the fact that there's not 10 million people pounding on the table to get this functionality back. They're missing so much by not having the screen resize feature!

451F (max451f) wrote :

Confirms this bug on my 12.04 x64

Yes, there should be some "Open source innovation preservation project"
that protects cool features people liked from being completely removed from
the OS. There are many nice features that get removed "temporarily" in some
new version, when some new technology is adopted, but then the developers
forget about them and never bring them back, such as:

- these multilevel edge window dockings
- the world map depicting the movement of sunlight that used to be located
under the calendar when you clicked the time indicator
- the option to autohide the launcher only when a window is maximized or
covers it
- tabs and panes in Nautilus that we might lose in the future, to name
something more recent

I mean, for many of us, some of these features were among the reasons why
we switched to Ubuntu in the first place. Don't take them away from us and
don't take the credit away from the developers who put time and effort in
building them. Leave them at least as options. I know that the code gets
more complex that way, but some of these features were rock-solid and by
using good software design patterns, they could be kept under control.

On Thu, Sep 13, 2012 at 2:35 PM, 451F <email address hidden> wrote:

> Confirms this bug on my 12.04 x64
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (878513).
> https://bugs.launchpad.net/bugs/879218
>
> Title:
> some users prefer the old grid behaviour (dividing each time the
> keybinding are used)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/compiz/+bug/879218/+subscriptions
>

savanna (savanna) wrote :

I loved the feature, especially with very large displays, it's such an useful feature to quickly organize windows. Please bring it back.

no longer affects: hundredpapercuts
Karl Brand (brandk) wrote :

Devs, someone, anyone: please bring this awesome feature back!

Dražen Lučanin (kermit666) wrote :

I agree. I don't like seeing good features disappear. If there is a
supported way to resize a window to one half of the screen area, I don't
see why is it hard to calculate 1/3 or 2/3 of the size and leave some key
combination to do the resize.

On Thu, Nov 22, 2012 at 10:27 AM, Karl Brand <email address hidden>wrote:

> Devs, someone, anyone: please bring this awesome feature back!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (878513).
> https://bugs.launchpad.net/bugs/879218
>
> Title:
> some users prefer the old grid behaviour (dividing each time the
> keybinding are used)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/compiz/+bug/879218/+subscriptions
>

Karl Brand (brandk) wrote :

Gareth Bailey, thank you very much.

Changed in compiz:
assignee: nobody → Gareth Bailey (garethbailey0)
milestone: none → 0.9.9.0
status: Confirmed → In Progress
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Mike (mike123) wrote :

Will there be a ppa for quantal? *sniff*

Timo Palomaa (timppis) wrote :

I got the functionality back on 12.10 by building Grid from git (actually first did this because of a completely unrelated bug). Follow the build instructions on: http://wiki.compiz.org/Plugins/Grid

Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
MC Return (mc-return) on 2013-04-05
Changed in compiz:
assignee: Gareth Bailey (garethbailey0) → MC Return (mc-return)
MC Return (mc-return) wrote :

The branch linked here makes the cycling through different grid sizes behaviour fully configurable via CCSM.
CCSM Screenie: http://uppix.net/5/f/4/c21c285ee4ce86b1b9f756e3c17ab.png

:)

MC Return (mc-return) wrote :

@timppis:
I would not recommend the git version as it is old and full of bugs that already have been eliminated in 0.9.x trunk.
I could list many examples, but I'm too lazy @ this point ;)

Please test https://code.launchpad.net/~mc-return/compiz/compiz.merge-fix1082001-gridded-windows-jump-workspaces
Almost all known Grid related bugs are fixed there and you can choose if you want to cycle through sizes ;)

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision 3650, scheduled for release in compiz, milestone 0.9.10.0

Changed in compiz:
status: In Progress → Fix Committed
cako (goldencako) wrote :

@MC Return is there any way you could package this like Gareth did? I've managed to compile and run your Compiz, but I can't for the life of me configure CCSM to allow the grid plugin to work.

MC Return (mc-return) wrote :

@goldencako:
Hopefully there will soon be a PPA available ;)

If you've compiled my branch and are on Raring, you can simple copy the libgrid.so file from build/plugins/grid to ~/.compiz-1/plugins and the metadata (grid* files) from build/generated to ~/.compiz-1/metadata.
Then run "setsid unity" to replace your running Compiz version...

Open CCSM->Grid->Edges tab->Resize Actions submenu and enable Cycle Through Multiple Sizes.

Done :)

MC Return (mc-return) wrote :

*my branch or Compiz 0.9.10-dev (lp:compiz trunk)

cako (goldencako) wrote :

Unfortunately your solution generates the following errors:

compiz (core) - Info: Starting plugin: grid

(process:2723): GLib-GIO-ERROR **: Settings schema 'org.compiz.grid' does not contain a key named 'cycle-sizes'
Trace/breakpoint trap

Any ideas? Looking forward to the PPA!

MC Return (mc-return) wrote :

@goldencako:
This sounds like you forgot to install/copy the metadata==generated grid.xml, also copy the generated files grid_options.cpp and grid_options.h into .compiz-1/metadata...

Sam Spilsbury (smspillaz) wrote :
Download full text (3.7 KiB)

cako if you installed the plugin locally you need to ensure that the
gsettings schema is installed to the systemwide schema install dir or
you need to set XDG_DATA_DIRS as appropriate.

I seriously don't recommend copying files around for the following reasons:

1. The plugins will have been compiled for the in-tree ABI. This has
changed recently and the plugins will not load correctly if the
package in ubuntu doesn't have the most up to date ABI version.
2. As you've mentioned yourself, the gsettings schemas need to be
installed and then the gsettings binary file needs to be recompiled.

If you want to test out the new behavior, my recommendation is to
change into the grid/ subdirectory and build the plugin locally. For
example:

cd plugins/grid
mkdir build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=${HOME}/bin -DCOMPIZ_PLUGIN_INSTALL_TYPE=local
make install
glib-compile-schemas ${HOME}/bin/share/glib-2.0/schemas

Then you'll need to add ${HOME}/bin/share to your XDG_DATA_DIRS in
your .bashrc . For example:

export XDG_DATA_DIRS=${HOME}/bin/share/:${XDG_DATA_DIRS}

On Wed, May 1, 2013 at 4:51 AM, cako <email address hidden> wrote:
> Unfortunately your solution generates the following errors:
>
> compiz (core) - Info: Starting plugin: grid
>
> (process:2723): GLib-GIO-ERROR **: Settings schema 'org.compiz.grid' does not contain a key named 'cycle-sizes'
> Trace/breakpoint trap
>
> Any ideas? Looking forward to the PPA!
>
> --
> You received this bug notification because you are a member of Compiz
> Maintainers, which is subscribed to Compiz Grid Plugin.
> https://bugs.launchpad.net/bugs/879218
>
> Title:
> some users prefer the old grid behaviour (dividing each time the
> keybinding are used)
>
> Status in Compiz:
> Fix Committed
> Status in Compiz Grid Plugin:
> Confirmed
> Status in Compiz Main Plugins:
> Confirmed
> Status in Unity:
> Won't Fix
> Status in “compiz-plugins-main” package in Ubuntu:
> Confirmed
>
> Bug description:
> I've used the Compiz Grid function for a long time and I generally use
> it to set my browser to the right 2/3 or 3/4 of the screen and have
> other apps on the top or bottom half of the remaining part. Now when I
> press ctrl + alt numpad 4 or numpad 6 it only does half and when
> pressing it a second or third time it does nothing. The options for
> different sizes work for all the corners and top and bottom. When I
> press ctrl + alt numpad 9 it does the same thing as pressing ctrl +
> alt numpat 8. Here's a video that may illustrate the problem better
> than my description.
>
> http://www.youtube.com/watch?v=i3WC0BnXe5E
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: unity 4.22.0-0ubuntu3
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.0-12-generic x86_64
> NonfreeKernelModules: fglrx
> ApportVersion: 1.23-0ubuntu3
> Architecture: amd64
> CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,gnomecompat,mousepoll,imgpng,unitymtgrabhandles,regex,animation,grid,snap,expo,workarounds,ezoom,resize,vpswitch,place,wall,staticswitcher,fade,session,scale,unityshell]
> Date: Thu Oct 20 23:03:00 ...

Read more...

cako (goldencako) wrote :

@MC Return

Thank you for the thorough reply. I'll try this as soon as I can... this lack of resizing is driving me crazy.

MC Return (mc-return) on 2013-05-12
Changed in compiz-grid-plugin:
status: Confirmed → Fix Committed
Changed in compiz-plugins-main:
status: Confirmed → Fix Committed
Changed in compiz-plugins-main (Ubuntu):
status: Confirmed → Fix Committed
Stephen M. Webb (bregma) on 2013-07-23
Changed in compiz:
status: Fix Committed → Fix Released
Dražen Lučanin (kermit666) wrote :

Cool, thanks for the fix @MC Return!

Launchpad Janitor (janitor) wrote :
Download full text (70.8 KiB)

This bug was fixed in the package compiz - 1:0.9.10+13.10.20130822-0ubuntu1

---------------
compiz (1:0.9.10+13.10.20130822-0ubuntu1) saucy; urgency=low

  [ Sam Spilsbury ]
  * Bump version to 0.9.10

  [ Łukasz 'sil2100' Zemczak ]
  * Remove debian/patches/unity_support_test.patch:
    - Running the support test from compiz has bad side effects, from now
      on we run it from Xsession.d
  * Automatic snapshot from revision 3644

  [ Iven Hsu ]
  * Opacify: Only dim the windows above the active window.(LP:
    #1189374). (LP: #1189374)
  * KWD: Fix compile errors with KDE 4.11. The KWin developers made
    kdecorationbridge.h private. See:
    http://lists.freedesktop.org/archives/compiz/2013-March/003479.html
    (LP: #1193792). (LP: #1193792)

  [ Nikolay Martynov ]
  * When static switcher is enabled and has an option to show
    application icon turned on the icons are expected to be ~1/3 of a
    thumbnail (48px). Instead they are displayed in 512px size and
    completely cover everything. This change addresses this issue. See
    LP #1173914. (LP: #1173914, #1186426)

  [ BryanFRitt ]
  * Fixed the non-working Annotate 'Clear' Button. Moved this option's
    CCSM position upwards to keep the button shortcuts together. (LP:
    #1202907). (LP: #1202907)

  [ Mehrdad Afshari ]
  * Added "move window to previous monitor" feature to compiz Put
    plugin. (LP: #1178581)

  [ Hu Kang ]
  * gtk-window-decorator: destroy action menu when any of the (close,
    min, max) buttons on the title bar is pressed. (LP: #1101648)
  * Remove redundant src/logmessage/include/core/logmessage.h (LP:
    #1067246). (LP: #1067246)

  [ Steve Langasek ]
  * Fix for bug #763148 (with added test cases): when the desktop is
    resized, windows should stay on their original workspace. (LP:
    #763148)

  [ Brandon Schaefer ]
  * Unrevert 3728, fix failing tests. Change the behaviour of
    undecorating windows. Previously when a window was undecorated, we
    would shift it back to an appropriate position according to its
    gravity member. That behaviour was problematic because in the
    StaticGravity case the window has to just stay in the same place.
    But then if you had a window with StaticGravity which then did get a
    decoration and later removed it, it would be placed as though it was
    decorated and appear to be in the wrong place. The correct behaviour
    is to place all windows as though they have decorations, and then
    when decorations are removed, to move the window back to the corner
    as indicated in its gravity and then expand its size to cover the
    obscured regions no longer hidden because the decorations went away.
    (LP: #1165343).   1. Completely remove decorOffsetMove and other
    related code from      decor.cpp. Put the logic to handle the
    window->input () - window->border ()      placement offset inside of
    setWindowFrameExtents instead. Now the window      will always be
    offset from its original non-decorated position to the new
         decorated position, rather than having to guess between
    decoration sizes.   2. Make saveGeometry and restoreGeometry work
    relative to window->border ()      a...

Changed in compiz (Ubuntu):
status: New → Fix Released
cako (goldencako) wrote :

Thank you MC Return!!

Siro Mateos (siromateos) wrote :

This bug is still alive in compiz-0.9.10+20131011-0ubuntu1 (saucy salamander).

Vivek Ramadoss (keviv93) wrote :

So is there a fix for making ctrl + alt + numpad 4 and numpad 6 cycle between the various widths for multiple keypresses instead of just being half? Because my compiz grid still does not work. I am on Ubuntu 12.04 LTS.

Mondane (mondane-woodworker) wrote :

Ubuntu 15.04 / vivid is still missing this 'cycle' behavior.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.