Ctrl-Alt-KP_9 adjusts window to upper half instead of top right corner (behaves like Ctrl-Alt-KP_8)

Bug #876591 reported by Karim Moussa on 2011-10-17
408
This bug affects 100 people
Affects Status Importance Assigned to Milestone
Compiz Main Plugins
High
Daniel van Vugt
compiz-plugins-main (Ubuntu)
High
Didier Roche
Oneiric
High
Sam Spilsbury

Bug Description

In Ubuntu 11.10, updated with "proposed" and "backports" repositories enabled, Ctrl-Alt-Numpad_9 tiles the window into the upper half instead of the top right corner, thus behaves like Ctrl-Alt-Numpad_8. Checking configuration, the key bindings are matched with their normal actions correctly.
In a fresh Ubuntu 11.10 installation, Ctrl-Alt-Num_9 works as it should, but with the latest updates installed, it displays the described behaviour.

Related branches

Karim Moussa (karim-moussa) wrote :

Configuration was checked using compizconfig-settings-manager.

Dahaniel (dm-protzkeule) wrote :

I can confirm that bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Karim Moussa (karim-moussa) wrote :

Found out that reverting "compiz-plugins-main-default" from version 0.9.6-0ubuntu4 to 0.9.6-0ubuntu2 solves this particular problem.

Changed in compiz-plugins-main (Ubuntu):
status: New → Confirmed
affects: compiz-grid-plugin → compiz-plugins-main (Ubuntu)
Sebastien Bacher (seb128) wrote :

Settings to High since that's a SRU regression

tags: added: regression-update
Changed in compiz-plugins-main (Ubuntu Oneiric):
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
Bernie (lbrulet-8) wrote :

This bug was introduced by the fix for bug #862260 in version 0.9.6-0ubuntu3. The following line (grid/src/grid.cpp:1017) :

gridProps[GridTopRight] = GridProps {0,0, 1,2};

should be replaced by :

gridProps[GridTopRight] = GridProps {1,0, 2,2};

Probably a copy/paste error :-)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz-plugins-main (Ubuntu Oneiric):
status: New → Confirmed
Changed in compiz-plugins-main (Ubuntu):
status: New → Confirmed
Bernie (lbrulet-8) wrote :

I have uploaded a temporary patched package, solving this issue, to my ppa : ppa:lbrulet-8/ppa (compiz-plugins-main) :

https://launchpad.net/~lbrulet-8/+archive/ppa

holstein (mikeholstein) wrote :

Bernie... i just used your PPA pacakges from https://launchpad.net/~lbrulet-8/+archive/ppa and all is well... thanks

xubuntu 11.10 install

Richard Klein (kleinric) wrote :

Howzit,
Just to update:
Fresh install Ubuntu 11.10, then: sudo apt-get update && sudo apt-get dist-upgrade

Now I have the same problems with grid, so its not just in proposed/backports anymore... :/

Thanks for the patch though :D

This is a regression bug, I don't understand how it doesn't have a higher priority!

Agreed. The grid feature is one of my selling points for converting people to Ubuntu. This bug is killing my productivity.

Sebastien Bacher (seb128) wrote :
Changed in compiz-plugins-main (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Joe Farley (joeataoldotcom) wrote :

This also effects the Ctrl-Alt-KP_4 and Ctrl-Alt-KP_6 so they no longer have varying degrees of left and right and only fill the screen half way.

Chascon (chascone) wrote :

@ joeataoldotcom
Yes, and I thought that was just me imagining it!

Chascon (chascone) wrote :

@ joeataoldotcom
Another bug report?

Joe Farley (joeataoldotcom) wrote :

@chascon I reported it as a bug but it was marked as a duplicate of this bug.

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/878791

Joe Farley (joeataoldotcom) wrote :

Sorry, this is the bug I reported that was marked as a duplicate.

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/879218

studentz (studenz) wrote :

Same here
After Upgrade to Oneric
The ppa solve the problem

Sebastien Bacher (seb128) wrote :

ok, I've commited the patch to the vcs

Changed in compiz-plugins-main (Ubuntu):
status: Confirmed → Fix Committed

Bug #878820 is not a duplicate of this bug. Is there a way to remove it from the duplicate list?

psypher (psypher246) wrote :

Does this patch also fix the broken Ctrl alt 4, 6 keys? They no longer cycle between 1/4, 1/3 sizes just 1/2?

or that an unfortunate "feature" of oneiric?

Apparently it is a "feature". I really liked the previous behavior. It is very useful on widescreen monitors.

Chascon (chascone) wrote :

I agree. It was useful, and the latest version of grid has other issues as reported by yours truly, https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/885099

Hopefully, Bacher's patch also takes care of the other issue I'm having.

psypher (psypher246) wrote :

I have logged a bug about that: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/893017

It must be replaced, no reason to removed it. Chascon and Carlos, please go mark it a affecting you as well.

Thanks

abbas (4-abbas) on 2011-11-30
Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

no abbas; the fix has not been uploaded

Changed in compiz-plugins-main (Ubuntu):
status: Fix Released → Fix Committed
abbas (4-abbas) wrote :

I marked this as released; however it should not have been. I do not have the permissions to put it back into Fix Committed (where it should be). Sorry for the confusion.

Omer Akram (om26er) on 2011-12-01
Changed in compiz-plugins-main (Ubuntu):
importance: Undecided → High

Hello Karim, or anyone else affected,

Accepted compiz-plugins-main into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in compiz-plugins-main (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Serge Hallyn (serge-hallyn) wrote :

I'm currently on precise. The fix is not supposed to be there yet, is that correct?

Just making sure.

Calcipher (calcipher) wrote :

@pitti

I can confirm that the updated version of the grid plugin is working as expected. Xubuntu 11.10x64.

Jeremie Tamburini (jeremie2) wrote :

@pitti

Ctrl-Alt-KP_9 works now properly with the oneiric-proposed package on 11.10x86. Thanks!

Still problems with the Ctrl-Alt-KP_4 and Ctrl-Alt-KP_6. The windows can be resized only half screen.

Martin Pitt (pitti) on 2011-12-20
tags: added: verification-done
removed: verification-needed
psypher (psypher246) wrote :

I have activated proposed in Precise and updated. This issue is not fixed there yet. Will it be in proposed soon?

Marcio Merlone (mmerlone) wrote :

I confirm it is fixed on Ubuntu 11.10 Oneiric Ocelot, working as expected now. Thank you.

Ruquay K Calloway (ruquay) wrote :

For me the fix is also working, however I've noticed something peculiar that seems to be related to the issues with Ctrl-Alt-KP_4 and Ctrl-Alt-KP_6: after using either Ctrl-Alt-KP_4 or Ctrl-Alt-KP_6, further use of the "corner" keys, Ctrl-Alt-KP_(1|3|7|9) no longer resize the window using the full spectrum, but cycles between 1/3, 1/2, and 1/2 without any gap to bottom or right (before using Ctrl-Alt-KP_4 or Ctrl-Alt-KP_6, there is a small gap to the bottom and right that won't go away).

Karl Brand (brandk) wrote :

Devs, With a clean install of 11.10 (32bit);,Ctrl-Alt-KP_4 and Ctrl-Alt-KP_6 only delivers a 1/2 screen re-size, irrespective of repeated Ctrl-Alt-KP_(4 | 6). Ctrl-Alt-KP_(1|2|3|5|7|8|9) appear to work normally i.e., deliver further re-sized options with repeated key-requests. Happy & safe festivities!

Bernard Banko (beernarrd) wrote :

#879218 removed from duplicates (it reports KP4 and KP6 screen size only)

Changed in compiz-grid-plugin:
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.6-0ubuntu4.2

---------------
compiz-plugins-main (1:0.9.6-0ubuntu4.2) oneiric-proposed; urgency=low

  * debian/patches/fix-876591.patch:
    - Ctrl-Alt-KP_9 adjusts window to upper half instead of top right corner
      (behaves like Ctrl-Alt-KP_8)
      (lp: #876591)

compiz-plugins-main (1:0.9.6-0ubuntu4.1) oneiric-proposed; urgency=low

  * debian/patches/fix-875557.patch:
    - Compiz grid overlay appears after workspace switcher use.
      (LP: #875557)
  * debian/patches/fix-891886.patch:
    - Compiz grid plugin is fired when resizing a window. (LP: #891886)
 -- Omer Akram <email address hidden> Mon, 05 Dec 2011 20:38:27 +0500

Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz-plugins-main (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Jesse Otto (rootofjesse) wrote :

very nice, the update works for me

Daniel van Vugt (vanvugt) wrote :

Fix missing upstream (see bug 910698).

Changed in compiz-grid-plugin:
status: Triaged → In Progress
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz-grid-plugin:
status: In Progress → Fix Committed
affects: compiz-grid-plugin → compiz-plugins-main
Changed in compiz-plugins-main:
milestone: none → 0.9.7.0
Changed in compiz-plugins-main:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers