Hangs in animation sometimes

Bug #220631 reported by Michael Vogt on 2008-04-22
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz-fusion-plugins-main (Ubuntu)
Medium
Michael Vogt
Hardy
Medium
Unassigned
Intrepid
Medium
Michael Vogt

Bug Description

Binary package hint: compiz-fusion-plugins-main

This bug is somewhat hard to trigger but there are some situations where the animation plugin hangs, uses 100% cpu and leaves the system unresponsive (not mouse clicks or keyboard action accepted).

Test case:
1. install the upgrade and verify that there are no regression (focus still works as before, no hangs when opening/closing/changing various windows)

Michael Vogt (mvo) wrote :

I cherry picked the upstream git fixes for this, I have no reliable way (yet) to reproduce how it is triggered, however gobby seems to be a good candidate.

Changed in compiz-fusion-plugins-main:
importance: Undecided → Medium
milestone: none → ubuntu-8.04.1
Michael Vogt (mvo) on 2008-04-23
description: updated
Martin Pitt (pitti) wrote :

Do you have a patch for this for review? Please feel free to upload to hardy-proposed. It won't get accepted until after the release, but uploading to the queue is fine.

Martin Pitt (pitti) wrote :

Oh, you did already, nevermind.

Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test.

Changed in compiz-fusion-plugins-main:
status: New → Fix Committed
Steve Langasek (vorlon) on 2008-05-02
Changed in compiz-fusion-plugins-main:
milestone: ubuntu-8.04.1 → none
status: Fix Committed → Triaged
Martin Pitt (pitti) wrote :

I have used the new package for several hours on my laptop (Dell Latitude D430, Intel G945, intel driver) without any problems.

Sebastien Bacher (seb128) wrote :

I'm running the update on my desktop and laptop and didn't notice any hang or regression

Martin Pitt (pitti) wrote :

Works fine on my desktop, too.

Saivann Carignan (oxmosys) wrote :

I also confirm that it fixes the issue and that no regression appeared.

Martin Pitt (pitti) wrote :

Needs to be uploaded to Intrepid ASAP.

Changed in compiz-fusion-plugins-main:
assignee: nobody → mvo
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in compiz-fusion-plugins-main:
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2008-06-16
Changed in compiz-fusion-plugins-main:
milestone: none → intrepid-alpha-2
Steve Langasek (vorlon) wrote :

Just a reminder that this appears to still need fixed for intrepid; currently marked as targeted to alpha2, due out this week, but if that's not feasible we should re-target it.

Changed in compiz-fusion-plugins-main:
milestone: intrepid-alpha-2 → intrepid-alpha-3
Travis Watkins (amaranth) wrote :

SInce the fix for hardy was pulled from git and we have a git snapshot in intrepid now it should have this fix.

Changed in compiz-fusion-plugins-main:
status: Triaged → Fix Released
Saivann Carignan (oxmosys) wrote :

Steve Langasek, Michael Vogt : I can't reproduce this bug in Intrepid using the steps to reproduce mentioned in duplicate bug 218489 . IMO, this bug is already fixed in Intrepid, unless there are other situations where it can be reproduced.

Changed in compiz-fusion-plugins-main:
milestone: intrepid-alpha-3 → none
Steve Langasek (vorlon) on 2008-07-08
Changed in compiz-fusion-plugins-main:
milestone: none → intrepid-alpha-2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers