[karmic] coherence python support is (perhaps) broken

Bug #409518 reported by GiuseppeVerde on 2009-08-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
coherence (Debian)
Fix Released
Unknown
coherence (Ubuntu)
High
Charlie_Smotherman

Bug Description

Binary package hint: coherence

Coherence's python support seems broken in Karmic. When trying to activate the DLNA/UPnP plugin, the plugin fails to load/activate with the message "Plugin Error: Unable to activate plugin DLNA/UPnP sharing and control support". $HOME/.xsession-errors contains the following:
=====
Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/upnp_coherence/__init__.py", line 13, in <module>
    import coherence.extern.louie as louie
ImportError: No module named coherence.extern.louie

(rhythmbox:25339): Rhythmbox-WARNING **: Could not load plugin upnp_coherence

(rhythmbox:25339): Rhythmbox-WARNING **: Error, impossible to activate plugin 'DLNA/UPnP sharing and control support'
=====

Versions installed:
ii coherence 0.6.4-3 Python UPnP framework
ii rhythmbox 0.12.3-1ubuntu music player and organizer for GNOME

Lemme know if you need anything more.

Related branches

Charlie_Smotherman (cjsmo) wrote :

Thank you for the bug report.

I am waiting on a new release of coherence, which is due to be released this week or next. There is a known packaging bug which will be fixed with the new release.

Best regards
Charlie Smotherman

Changed in coherence (Ubuntu):
status: New → Confirmed
assignee: nobody → Charlie_Smotherman (porthose) (cjsmo)
importance: Undecided → High

Ah, cool. Glad to know the fix is already in the works! :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package coherence - 0.6.4-3ubuntu1

---------------
coherence (0.6.4-3ubuntu1) karmic; urgency=low

  * debian/control
    - changed package stanza to python-coherence, to provide a proper
      python-coherence package that will be installed in the global name space
      to make python-coherence accessible to upnp-inspector and other programs.
    - changed Conflicts/Replaces/Provides fields from python-coherence to
      coherence, to account for upgrade path.
  * debian/rules
    - removed --install-scripts and --install-libs, so python-coherence will
      be installed into the global name space (LP: #409518) (LP: #411209)
  * Added misc/Desktop-Applet/applet-coherence.1 to debian/manpages, upstream
    moved the location of applet-coherence.1.
  * Bumped Standards Version to 3.8.3 no changes needed.

 -- Charlie Smotherman <email address hidden> Mon, 24 Aug 2009 08:01:22 -0500

Changed in coherence (Ubuntu):
status: Confirmed → Fix Released
Changed in coherence (Debian):
status: Unknown → New
Changed in coherence (Debian):
status: New → Fix Released
rchristy1 (rchristy9) wrote :

It may be helpful to new users that the python coherence package for DLNA/UPnp is available in the synaptic package manager. Under the System > Administration Menu

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.