please merge cmake from debian

Bug #1563580 reported by Gianfranco Costamagna on 2016-03-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cmake (Ubuntu)
High
Steve Langasek

Bug Description

debdiff attached.
as you can see compared with 3.5 changes are just bug fixes and trivial to look at
https://anonscm.debian.org/cgit/pkg-cmake/cmake.git/commit/?id=b71943bca4ed372568050d460960764ca2b3d4aa

package building on ppa:costamagnagianfranco/locutusofborg-ppa

Changed in cmake (Ubuntu):
importance: Undecided → Critical
importance: Critical → High
Matthias Klose (doko) wrote :

I think that looks good. but please lets get the current changes into the release pocket first.

Changed in cmake (Ubuntu):
status: New → Triaged
Steve Langasek (vorlon) wrote :

Have reviewed this and am satisfied that this is correct, and 3.5.1 looks to be a better choice than 3.5.0 for release. Per discussion on IRC, it looks like we're waiting for 3.5.0-1ubuntu3 to migrate first; once this is done I'm happy to sponsor this upload.

Changed in cmake (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Sponsored with restoring the two lost changelog lines in the ubuntu delta log. Thanks!

Changed in cmake (Ubuntu):
status: In Progress → Fix Committed

Thanks, I'll keep an eye for new regressions, and write here if something breaks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cmake - 3.5.1-1ubuntu1

---------------
cmake (3.5.1-1ubuntu1) xenial; urgency=medium

  * Merge from Debian unstable (LP: #1563580). Remaining changes:
    - debian/cmake-data.install
      debian/MultiArchCross.cmake
      debian/patches/ubuntu_cmake-crosscompile.patch:
      help cmake to find libraries in multiarch path
      xnox says this is not yet ready to go upstream but he will work on it
    - debian/patches/ubuntu_boost-multiarch.patch
      find boost and python in multiarch path
      this is a candidate for removal but needs rdepend testing

cmake (3.5.1-1) unstable; urgency=medium

  * New upstream release.
    - Fixes FindCUDA regression in separate compilation. (Closes: #818937)
  * Update copyright file.

 -- Gianfranco Costamagna <email address hidden> Wed, 30 Mar 2016 00:59:16 +0200

Changed in cmake (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers