sru cloud-init (18.3.9-g2e62cb8a-0ubuntu1) to (18.4-0ubuntu1)

Bug #1795953 reported by Chad Smith on 2018-10-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

== Begin SRU Template ==
[Impact]
This release sports both bug-fixes and new features and we would like to
make sure all of our supported customers have access to these
improvements. The notable ones that affect Ubuntu are:

 - Add support for Infiniband network interfaces (IPoIB). [Mark Goddard]
 - cli: add cloud-init query subcommand to query instance metadata
 - OpenStack: Support setting mac address on bond.
      [Fabian Wiesel] (LP: #1682064)
 - EphemeralIPv4Network: Be more explicit when adding default route.
      (LP: #1792415)
 - OpenStack: support reading of newer versions of metdata.
 - OpenStack: fix bug causing 'latest' version to be used from network.
      (LP: #1792157)
 - user-data: jinja template to render instance-data.json in cloud-config
      (LP: #1791781)
 - config: disable ssh access to a configured user account
 - sysconfig: refactor sysconfig to accept distro specific templates paths
 - hyperv_reporting_handler: simplify threaded publisher
 - VMWare: Fix a network config bug in vm with static IPv4 and no gateway.
      [Pengpeng Sun] (LP: #1766538)
 - logging: Add logging config type hyperv for reporting via Azure KVP
      [Andy Liu]
 - Add oracle datasource to debian/cloud-init.templates
 - Add datasource Oracle Compute Infrastructure (OCI).
 - azure: allow azure to generate network configuration from IMDS per boot.
 - Scaleway: Add network configuration to the DataSource [Louis Bouchard]
      [Wesley Gao]
 - netplan: Correctly render macaddress on a bonds and bridges when
      provided. (LP: #1784699)
 - tools: Add 'net-convert' subcommand command to 'cloud-init devel'.
 - Use typeset or local in profile.d scripts. (LP: #1784713)
 - OpenNebula: Fix null gateway6 [Akihiko Ota] (LP: #1768547)
 - oracle: fix detect_openstack to report True on OracleCloud.com DMI data
      (LP: #1784685)
 - update_metadata re-config on every boot comments and tests not quite
      right [Mike Gerdts]
 - get_linux_distro: add support for centos6 and rawhide flavors of redhat
      (LP: #1781229)

See the changelog entry below for a full list of changes and bugs.

[Test Case]
The following development and SRU process was followed:
https://wiki.ubuntu.com/CloudinitUpdates

The cloud-init team will be in charge of attaching the artifacts and
console output of the appropriate run to the bug. cloud-init team
members will not mark ‘verification-done’ until this has happened.

* Automated Test Results
<TODO: attach automated cloud-init-proposed test artifacts from tests for each release with lxd artifacts>
<TODO: attach automated cloud-init-proposed test artifacts from tests for each release with kvm artifacts>
<TODO: attach automated curtin vmtest with cloud-init proposed>
<TODO: attach Solutions Testing team test results for each LTS>

* Manual Test Results
<TODO: attach manual cloud-init-proposed test artifacts from tests for each release on ec2 datasource>
<TODO: attach manual cloud-init-proposed test artifacts from tests for each release on gce datasource>
<TODO: attach manual cloud-init-proposed test artifacts from tests for each release on azure datasource>

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned integration tests are attached to this bug.

[Discussion]
<TODO: other background>

== End SRU Template ==

== Complete ChangeLog ==
    - release 18.4
    - tests: allow skipping an entire cloud_test without running.
    - tests: disable lxd tests on cosmic
    - cii-tests: use unittest2.SkipTest in ntp_chrony due to new deps
    - lxd: adjust to snap installed lxd.
    - docs: surface experimental doc in instance-data.json
    - tests: fix ec2 integration tests. process meta_data instead of meta-data
    - Add support for Infiniband network interfaces (IPoIB). [Mark Goddard]
    - cli: add cloud-init query subcommand to query instance metadata
    - tools/tox-venv: update for new features.
    - pylint: ignore warning assignment-from-no-return for _write_network
    - stages: Fix bug causing datasource to have incorrect sys_cfg.
    - Remove dead-code _write_network distro implementations.
    - net_util: ensure static configs have netmask in translate_network result
      [Thomas Berger]
    - Fall back to root:root on syslog permissions if other options fail.
      [Robert Schweikert]
    - tests: Add mock for util.get_hostname. [Robert Schweikert]
    - ds-identify: doc string cleanup.
    - OpenStack: Support setting mac address on bond. [Fabian Wiesel]
    - bash_completion/cloud-init: fix shell syntax error.
    - EphemeralIPv4Network: Be more explicit when adding default route.
    - OpenStack: support reading of newer versions of metdata.
    - OpenStack: fix bug causing 'latest' version to be used from network.
    - user-data: jinja template to render instance-data.json in cloud-config
    - config: disable ssh access to a configured user account
    - tests: print failed testname instead of docstring upon failure
    - tests: Disallow use of util.subp except for where needed.
    - sysconfig: refactor sysconfig to accept distro specific templates paths
    - Add unit tests for config/cc_ssh.py [Francis Ginther]
    - Fix the built-in cloudinit/tests/helpers:skipIf
    - read-version: enhance error message [Joshua Powers]
    - hyperv_reporting_handler: simplify threaded publisher
    - VMWare: Fix a network config bug in vm with static IPv4 and no gateway.
      [Pengpeng Sun]
    - logging: Add logging config type hyperv for reporting via Azure KVP
      [Andy Liu]
    - tests: disable other snap test as well [Joshua Powers]
    - tests: disable snap, fix write_files binary [Joshua Powers]
    - Add datasource Oracle Compute Infrastructure (OCI).
    - azure: allow azure to generate network configuration from IMDS per boot.
    - Scaleway: Add network configuration to the DataSource [Louis Bouchard]
    - docs: Fix example cloud-init analyze command to match output.
      [Wesley Gao]
    - netplan: Correctly render macaddress on a bonds and bridges when
      provided.
    - tools: Add 'net-convert' subcommand command to 'cloud-init devel'.
    - redhat: remove ssh keys on new instance.
    - Use typeset or local in profile.d scripts.
    - OpenNebula: Fix null gateway6 [Akihiko Ota]
    - oracle: fix detect_openstack to report True on OracleCloud.com DMI data
    - tests: improve LXDInstance trying to workaround or catch bug.
    - update_metadata re-config on every boot comments and tests not quite
      right [Mike Gerdts]
    - tests: Collect build_info from system if available.
    - pylint: Fix pylint warnings reported in pylint 2.0.0.
    - get_linux_distro: add support for rhel via redhat-release.
    - get_linux_distro: add support for centos6 and rawhide flavors of redhat
    - tools: add '--debug' to tools/net-convert.py
    - tests: bump the version of paramiko to 2.4.1.

Chad Smith (chad.smith) on 2018-10-03
description: updated
description: updated
Chad Smith (chad.smith) on 2018-10-05
summary: - sru cloud-init (18.3.9-g2e62cb8a-0ubuntu1) to (18.4-0ubuntu1~18.04.1)
+ sru cloud-init (18.3.9-g2e62cb8a-0ubuntu1) to (18.4-0ubuntu1)
Timo Aaltonen (tjaalton) on 2018-10-05
Changed in cloud-init (Ubuntu):
status: New → Fix Released

Hello Chad, or anyone else affected,

Accepted cloud-init into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/18.4-0ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cloud-init (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Timo Aaltonen (tjaalton) wrote :

Hello Chad, or anyone else affected,

Accepted cloud-init into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/18.4-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cloud-init (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers