Comment 6 for bug 1269626

Here is a diff between the SharedConfig.xml, with cloud-init.log as an attachment

--- waagent.pre/SharedConfig.xml 2014-01-15 22:46:09.619537000 +0000
+++ waagent/SharedConfig.xml 2014-01-15 22:54:33.606734299 +0000
@@ -1,32 +1,32 @@
 <?xml version="1.0" encoding="utf-8"?>
 <SharedConfig version="1.0.0.0" goalStateIncarnation="1">
- <Deployment name="ba5ce29e7b4d435f8d70ed5b7c471875" guid="{71d37c98-32e5-4627-a9c7-7498c603ed50}" incarnation="0">
- <Service name="utl-0115-s1" guid="{00000000-0000-0000-0000-000000000000}" />
- <ServiceInstance name="ba5ce29e7b4d435f8d70ed5b7c471875.0" guid="{c63183ea-1284-426b-a288-6af3f7397a36}" />
+ <Deployment name="fd9cfa887ac24eeab7efc8e5b48d799a" guid="{5fcccddd-25c5-47c1-9ed0-2c37ab5a8612}" incarnation="0">
+ <Service name="utl-0115-utl-0115-s1-A1" guid="{00000000-0000-0000-0000-000000000000}" />
+ <ServiceInstance name="fd9cfa887ac24eeab7efc8e5b48d799a.0" guid="{a610f152-aa8f-492e-82bc-053384ea88dd}" />
   </Deployment>
- <Incarnation number="1" instance="utl-0115-s1" guid="{07230d59-14a8-446a-9e2c-893250c47407}" />
- <Role guid="{692f906f-115d-e08d-2178-90db611dc71b}" name="utl-0115-s1" settleTimeSeconds="0" />
+ <Incarnation number="1" instance="utl-0115-utl-0115-s1-A1" guid="{7ef9d281-0865-459c-a1aa-4acf1f10123a}" />
+ <Role guid="{04c0d2f4-1503-977c-d3f7-408268609c71}" name="utl-0115-utl-0115-s1-A1" settleTimeSeconds="0" />
   <LoadBalancerSettings timeoutSeconds="0" waitLoadBalancerProbeCount="8">
     <Probes>
       <Probe name="D41D8CD98F00B204E9800998ECF8427E" />
- <Probe name="AEEC72A7AAC0423C26FCB170FD1035DA" />
+ <Probe name="B295630DB75FB8FCBC300D7E1500940F" />
     </Probes>
   </LoadBalancerSettings>
   <OutputEndpoints>
- <Endpoint name="utl-0115-s1:openInternalEndpoint" type="SFS">
- <Target instance="utl-0115-s1" endpoint="openInternalEndpoint" />
+ <Endpoint name="utl-0115-utl-0115-s1-A1:openInternalEndpoint" type="SFS">
+ <Target instance="utl-0115-utl-0115-s1-A1" endpoint="openInternalEndpoint" />
     </Endpoint>
   </OutputEndpoints>
   <Instances>
- <Instance id="utl-0115-s1" address="100.92.36.21">
+ <Instance id="utl-0115-utl-0115-s1-A1" address="100.92.38.42">
       <FaultDomains randomId="0" updateId="0" updateCount="0" />
       <InputEndpoints>
- <Endpoint name="openInternalEndpoint" address="100.92.36.21" protocol="any" isPublic="false" enableDirectServerReturn="false" isDirectAddress="false" disableStealthMode="false">
+ <Endpoint name="openInternalEndpoint" address="100.92.38.42" protocol="any" isPublic="false" enableDirectServerReturn="false" isDirectAddress="false" disableStealthMode="false">
           <LocalPorts>
             <LocalPortSelfManaged />
           </LocalPorts>
         </Endpoint>
- <Endpoint name="ssh" address="100.92.36.21:22" protocol="tcp" hostName="utl-0115-s1ContractContract" isPublic="true" loadBalancedPublicAddress="191.235.134.61:22" enableDirectServerReturn="false" isDirectAddress="false" disableStealthMode="false">
+ <Endpoint name="ssh" address="100.92.38.42:22" protocol="tcp" hostName="utl-0115-utl-0115-s1-A1ContractContract" isPublic="true" loadBalancedPublicAddress="191.235.132.109:22" enableDirectServerReturn="false" isDirectAddress="false" disableStealthMode="false">
           <LocalPorts>
             <LocalPortRange from="22" to="22" />
           </LocalPorts>