Installer should not ask about UTC if it has a net connection

Bug #8898 reported by Stuart Langridge on 2004-10-08
22
Affects Status Importance Assigned to Milestone
clock-setup (Ubuntu)
Wishlist
Unassigned

Bug Description

If Ubuntu is being installed using a network connection, where it can see the
internet, then it should not ask whether the hardware clock is set to UTC: it
should find out the time from an NTP server and decide for itself.

Matt Zimmerman (mdz) wrote :

Interesting idea. I don't think it can be made very reliable, however, since
the system's hardware clock could be wrong.

Colin Watson (cjwatson) wrote :

*** Bug 24870 has been marked as a duplicate of this bug. ***

Is this bug still relevant ? (I don't really understand because you have anyway to give your timezone).

Is it confirmed or wontfix or already fixed ?

Tormod Volden (tormodvolden) wrote :

> I don't really understand because you have anyway to give your timezone

Most people are able to tell in which timezone they are, but a lot of people don't understand the "UTC" and "hardware clock" question, or they are not able to check it at installation time.

Suggestion: Take the hw time +/- timezone and compare with network time. If it fits within +/- 10 minutes, decide on UTC/localtime based on this, otherwise ask user.

Also, make sure it does not hang waiting for the time server, if there is a firewall...

Changed in clock-setup:
status: Unconfirmed → Confirmed
Alan Jenkins (aj504) wrote :

Also wouldn't work all the time in the UK, where localtime may be UTC or UTC+1; for such zones you'd have to be asked if installing during the period when localtime is the same as UTC.

Colin Watson (cjwatson) on 2007-04-01
Changed in clock-setup:
assignee: kamion → nobody
Adam Niedling (krychek) wrote :

I don't know what version of Ubuntu was the original poster talking about, but Gutsy or Hardy definitely doesn't ask about UTC anymore. Bug can be closed.

Changed in clock-setup:
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

In some circumstances it still does. Please refer to the code. :-)

Changed in clock-setup:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.